




<!DOCTYPE html>
<html>
  <head>
    <script>
      dataLayer = [{
        'Market': 'seattle'
      }];
    </script>
    
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MVCXDDK');</script>
<!-- End Google Tag Manager -->


    


<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=yes">
<script type="text/javascript">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</script>

<script src="https://dyoeldxcrpb0a.cloudfront.net/assets/head-74d85b5ab282163c607f.js" ></script>
<link href="https://dyoeldxcrpb0a.cloudfront.net/assets/everout_head.3e0e15f2b2dec15a2dd1.css" rel="stylesheet" />
<script src="https://dyoeldxcrpb0a.cloudfront.net/assets/everout_head-263de19543c61c6514ef.js" ></script>
<link rel="icon" href="https://dyoeldxcrpb0a.cloudfront.net/assets/images/everout-favicon.ico">
<script data-ad-client="ca-pub-0969663119487598" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>


  <link rel="alternate" type="application/rss+xml" title="EverOut Seattle Picks & Guides Feed" href="https://everout.com/seattle/articles/feed" />



<link rel="stylesheet" href="https://use.typekit.net/wdx1hsa.css">

<script src="https://kit.fontawesome.com/ae403a2e1f.js" crossorigin="anonymous"></script>



  <script src="/assets/js/member-actions.js"></script>


<meta property="og:type" content="article" />

  
    <link rel="canonical" href="https://everout.com/seattle/articles/59-cheap-easy-things-to-do-in-seattle-this-weekend-dec-3-5-2021/c3987/" />
    <meta property="og:url" content="https://everout.com/seattle/articles/59-cheap-easy-things-to-do-in-seattle-this-weekend-dec-3-5-2021/c3987/" />
  
  
  



  <title>59 Cheap &amp; Easy Things To Do in Seattle This Weekend: Dec 3-5, 2021 - EverOut Seattle</title>
  <meta property="og:title" content="59 Cheap &amp; Easy Things To Do in Seattle This Weekend: Dec 3-5, 2021 - EverOut Seattle" />
  <meta name="apple-mobile-web-app-title" content="59 Cheap &amp; Easy Things To Do in Seattle This Weekend: Dec 3-5, 2021 - EverOut Seattle" />



  <meta property="og:description" content="59 Cheap &amp; Easy Things To Do in Seattle This Weekend: Dec 3-5, 2021 - The Kringles Filling Station Holiday Experience, Urban Craft Uprising&#x27;s Winter Show, and More Last-Minute Events Under $15" />
  <meta name="description" content="59 Cheap &amp; Easy Things To Do in Seattle This Weekend: Dec 3-5, 2021 - The Kringles Filling Station Holiday Experience, Urban Craft Uprising&#x27;s Winter Show, and More Last-Minute Events Under $15" />


  <meta name="twitter:image" content="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzODM5NDIwNzI5OTYzNS1TY3JlZW5fU2hvdF8yMDIxLTEyLTAxX2F0XzQuMjcuNDVfUE0ucG5nIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJpbnNpZGUiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogMTIwMCwgImhlaWdodCI6IDYzMH19fQ==" />
  <meta property="og:image" content="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzODM5NDIwNzI5OTYzNS1TY3JlZW5fU2hvdF8yMDIxLTEyLTAxX2F0XzQuMjcuNDVfUE0ucG5nIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJpbnNpZGUiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogMTIwMCwgImhlaWdodCI6IDYzMH19fQ==" />

<link rel="mask-icon" href="https://dyoeldxcrpb0a.cloudfront.net/assets/images/everout-pin-icon.svg" color="#fcdc00">

  <link rel="apple-touch-icon-precomposed" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA2MCwgImhlaWdodCI6IDYwfX19" />
  <link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA3MiwgImhlaWdodCI6IDcyfX19" />
  <link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiAxMjAsICJoZWlnaHQiOiAxMjB9fX0=" />
  <link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiAxNTIsICJoZWlnaHQiOiAxNTJ9fX0=" />



  <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
  <script>
    window.googletag = window.googletag || {cmd: []};
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[1, 1]]).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Background", [[1, 1]], "EverOut-Seattle-Content-Background-58").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[970, 250], [970, 100]]).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Top", [[970, 250], [970, 100]], "EverOut-Seattle-Content-Top-56").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], [[320, 50]]).addSize([768, 0], []).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Mobile_Top", [[320, 50]], "EverOut-Seattle-Content-Mobile-Top-57").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[300, 250], [300, 600]]).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Sidebar_1", [[300, 250], [300, 600]], "EverOut-Seattle-Content-Sidebar-1-50").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], [[300, 250]]).addSize([768, 0], []).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Mobile_Inline_1", [[300, 250]], "EverOut-Seattle-Content-Mobile-Inline-1-54").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], [[300, 250]]).addSize([768, 0], []).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Mobile_Inline_2", [[300, 250]], "EverOut-Seattle-Content-Mobile-Inline-2-55").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[300, 250], [300, 600]]).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Sidebar_2", [[300, 250], [300, 600]], "EverOut-Seattle-Content-Sidebar-2-51").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[300, 250], [300, 600]]).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Sidebar_3", [[300, 250], [300, 600]], "EverOut-Seattle-Content-Sidebar-3-52").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[300, 250], [300, 600]]).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Sidebar_4", [[300, 250], [300, 600]], "EverOut-Seattle-Content-Sidebar-4-53").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
            googletag.cmd.push(function() {
                googletag.pubads().enableSingleRequest();
                googletag.pubads().setTargeting("section", ['stranger-editorial-things-to-do']);googletag.pubads().setTargeting("oid", "c3987");
                googletag.enableServices();
            });
        
  </script>


<meta property="og:site_name" content="EverOut Seattle" />
<meta name="twitter:card" content="summary_large_image" />

  
    <meta name="twitter:site" content="@thestranger" />
  
  
    <meta property="article:publisher" content="https://www.facebook.com/strangerseattle" />
  
  
    <meta property="fb:app_id" content="43933993878"/>
  
  
    <meta property="fb:admins" content="741428065"/>
  
  
    <meta property="fb:pages" content="56439755991" />
  

<meta name="cached" content="2021-12-03 14:47:50.130052">

  </head>

  <body class="everout seattle ">
    
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MVCXDDK"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->


    <div class="flex-container wrapper">
      
      <div class="nav-stack">
        

  <div class="network-bar navbar d-none d-md-block navbar-expand-md navbar-dark bg-dark">
    <div class="container">
      <ul class="navbar-nav me-auto">
        <li class="nav-item dropdown">
          <a class="nav-link dropdown-toggle" href="#" id="networkBarDropdown" role="button" data-bs-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
            EverOut
          </a>
          <ul class="dropdown-menu" aria-labelledby="networkBarDropdown">
            <li class="dropdown-item"><a href="/" class="nav-link">Home</a></li>
            <div class="dropdown-divider"></div>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/seattle/">
                  Seattle
                </a>
              </li>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/portland/">
                  Portland
                </a>
              </li>
            
          </ul>
        </li>
        <li class="nav-item nav-item-separator">|</li>
        
          <li class="nav-item"><a class="nav-link" href="https://www.thestranger.com">The Stranger</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.portlandmercury.com">Portland Mercury</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.savagelovecast.com">Savage Love</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://humpfilmfest.com">Hump</a></li>
          
          
        
      </ul>
    </div>
  </div>


        



        <div id="mobileMemberNavContainer">
  <div class="mobile-member-bar mobile d-md-none collapse" id="mobileMemberNavTop">
    <div class="mobile-member-nav">
      <div class="nav-item"><a href="/account/profile/">Profile <i class="far fa-fw fa-user"></i></a></div>
      <div class="nav-item"><a href="/account/lists/">Lists & Likes <i class="far fa-fw fa-heart"></i></a></div>
      <div class="nav-item"><a href="/account/settings/">Account <i class="fal fa-fw fa-cog"></i></a></div>
      <div class="nav-item"><a href="/account/logout/">Log Out <i class="fal fa-fw fa-sign-out"></i></a></div>
    </div>
  </div>
</div>
<div class="top-nav desktop">
  <nav class="navbar">
    <div class="container">
      <div class="navbar-brand-container">
        <a class="navbar-brand d-inline-block seattle" href="/seattle/" alt="Seattle">
          
            <img src="https://d2i729k8wyri5w.cloudfront.net/market-159735153762325-everout-logo-seattle2.png" alt="EverOut Seattle">
          
        </a>
      </div>
      <div class="navbar-expand-md desktop-items-container">
        <ul class="nav collapse navbar-collapse justify-content-end nav-items main-nav">
          
            
          
            
              
                
  <li class="nav-item dropdown">
    <a class="nav-link dropdown-toggle" href="#" id="itemDropdown-878" role="button" data-bs-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
      Neighborhoods
    </a>
    <ul class="dropdown-menu dropdown-menu-right" aria-labelledby="itemDropdown-878">
      
        
          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/ballard/">
    
    
      Ballard
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/belltown/">
    
    
      Belltown
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/capitol-hill/">
    
    
      Capitol Hill
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/central-district/">
    
    
      Central District
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/chinatown-id/">
    
    
      Chinatown-International District
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/columbia-city-beacon-hill/">
    
    
      Columbia City/Beacon Hill
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/downtown/">
    
    
      Downtown
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/fremont/">
    
    
      Fremont
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/phinney-green-lake/">
    
    
      Phinney Ridge/Green Lake
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/pioneer-square/">
    
    
      Pioneer Square
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/queen-anne/">
    
    
      Queen Anne
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/sodo-georgetown/">
    
    
      Sodo/Georgetown
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/south-lake-union/">
    
    
      South Lake Union
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/university-district/">
    
    
      University District
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/west-seattle/">
    
    
      West Seattle/White Center
    
  </a>
</li>

          
        
      
    </ul>
  </li>

<li class="nav-item separator">|</li>

              
            
          
            
          
            
              
                
  <li class="nav-item">
    <a href="https://everout.com/seattle/articles/" class="nav-link">Picks &amp; Guides</a>
  </li>

<li class="nav-item separator">|</li>

              
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
              
                
  <li class="nav-item dropdown">
    <a class="nav-link dropdown-toggle" href="#" id="itemDropdown-876" role="button" data-bs-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
      Calendars
    </a>
    <ul class="dropdown-menu dropdown-menu-right" aria-labelledby="itemDropdown-876">
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/top-events/">
    
    
      Top Events Today & This Week
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="/seattle/events">
    
    
      All Events
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/stranger-seattle/events/?type=in-person">
    
    
      In-Person Events
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?category=music&amp;type=in-person">
    
    
      Live Music
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?category=food-drink">
    
    
      Food & Drink
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?category=readings-talks">
    
    
      Readings & Talks
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/visual-art/">
    
    
      Visual Art
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?category=performance">
    
    
      Theater & Performance
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/film/">
    
    
      Film
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?category=resistance">
    
    
      Activism & Social Justice
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/locations/?category=restaurants">
    
    
      Restaurants
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?category=restaurants&amp;feature=takeout-covid-19&amp;feature=delivery-covid-19&amp;feature=curbside-pickup&amp;feature=walk-up-ordering">
    
    
      Takeout & Delivery
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/stranger-seattle/events/?category=livestreamed">
    
    
      Online Events
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?feature=in-person-visits">
    
    
      Now-Open Shops & Attractions
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?category=weed-locations&amp;feature=takeout-covid-19">
    
    
      Weed Locations
    
  </a>
</li>

        
      
    </ul>
  </li>



              
            
          
          <li class="nav-item dropdown member-nav" id="desktopMemberNav">
            <a href="/login/" class="member-profile-link btn btn-light">Log In</a>
          </li>
        </ul>
      </div>
      <ul class="nav mobile nav-items main-nav d-md-none mt-2">
        
          
        
          
            
              
  <li class="nav-item menu-toggler" data-bs-toggle="collapse" data-bs-target="#navbarToggle-878" aria-controls="navbarToggle-878" aria-expanded="false" aria-label="Toggle navigation">
    <a href="#" class="nav-link" onclick="return false;">Neighborhoods <i class="fa fa-caret-down"></i></a>
  </li>

<li class="nav-item separator">|</li>

            
          
        
          
        
          
            
              
  <li class="nav-item">
    <a href="https://everout.com/seattle/articles/" class="nav-link">Picks &amp; Guides</a>
  </li>

<li class="nav-item separator">|</li>

            
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
            
              
  <li class="nav-item menu-toggler" data-bs-toggle="collapse" data-bs-target="#navbarToggle-876" aria-controls="navbarToggle-876" aria-expanded="false" aria-label="Toggle navigation">
    <a href="#" class="nav-link" onclick="return false;">Calendars <i class="fa fa-caret-down"></i></a>
  </li>



            
          
        
      </ul>
      <div class="member-nav d-md-none text-end" id="mobileAvatarContainer">
        <a href="/login/" class="member-profile-link btn btn-sm btn-light me-2">Log In</a>
      </div>
      
        
          

        
      
        
          
  <div class="collapse navbar-collapse nav-items mobile d-md-none" id="navbarToggle-878">
    <div class="more-nav">
      
        
          
            <div class="nav-item   class-change ">
  <a href="/seattle/neighborhoods/ballard/">
    
    
      Ballard
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/belltown/">
    
    
      Belltown
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/capitol-hill/">
    
    
      Capitol Hill
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/central-district/">
    
    
      Central District
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/chinatown-id/">
    
    
      Chinatown-International District
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/columbia-city-beacon-hill/">
    
    
      Columbia City/Beacon Hill
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/downtown/">
    
    
      Downtown
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/fremont/">
    
    
      Fremont
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/phinney-green-lake/">
    
    
      Phinney Ridge/Green Lake
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/pioneer-square/">
    
    
      Pioneer Square
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/queen-anne/">
    
    
      Queen Anne
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/sodo-georgetown/">
    
    
      Sodo/Georgetown
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/south-lake-union/">
    
    
      South Lake Union
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/university-district/">
    
    
      University District
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/west-seattle/">
    
    
      West Seattle/White Center
    
  </a>
</div>

          
        
      
    </div>
  </div>


        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
        
      
        
          
  <div class="collapse navbar-collapse nav-items mobile d-md-none" id="navbarToggle-876">
    <div class="more-nav">
      
        
          <div class="nav-item   class-change ">
  <a href="https://everout.com/seattle/top-events/">
    
    
      Top Events Today & This Week
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="/seattle/events">
    
    
      All Events
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/stranger-seattle/events/?type=in-person">
    
    
      In-Person Events
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?category=music&amp;type=in-person">
    
    
      Live Music
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?category=food-drink">
    
    
      Food & Drink
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?category=readings-talks">
    
    
      Readings & Talks
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/visual-art/">
    
    
      Visual Art
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?category=performance">
    
    
      Theater & Performance
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/film/">
    
    
      Film
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?category=resistance">
    
    
      Activism & Social Justice
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/locations/?category=restaurants">
    
    
      Restaurants
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?category=restaurants&amp;feature=takeout-covid-19&amp;feature=delivery-covid-19&amp;feature=curbside-pickup&amp;feature=walk-up-ordering">
    
    
      Takeout & Delivery
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/stranger-seattle/events/?category=livestreamed">
    
    
      Online Events
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?feature=in-person-visits">
    
    
      Now-Open Shops & Attractions
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?category=weed-locations&amp;feature=takeout-covid-19">
    
    
      Weed Locations
    
  </a>
</div>

        
      
    </div>
  </div>


        
      
      <script type="text/javascript">
        // ajax to reload the nav if you're logged in
        var userAuthenticated = false;
        var userId = null;
        var userLoaded = false;
        function getMemberMenu() {
          let xhr = new XMLHttpRequest();
          xhr.open('GET', `/members/menu/`);
          xhr.setRequestHeader('Content-Type', 'application/json');
          xhr.onload = function () {
            userLoaded = true;
            if (xhr.responseText) {
              response = JSON.parse(xhr.responseText);
              if (response.id) {
                userAuthenticated = true;
                userId = response.id;
                localStorage.removeItem('lists-' + userId);
                localStorage.removeItem('listskey-' + userId);
                if(typeof getAddToListMenu === "function") {
                  if (localStorage.getItem('lists') && localStorage.getItem('listskey') == response.lists_key) {
                    createAddToListMenuFromLocalStorage(userId);
                  } else {
                    getAddToListMenu();
                  }
                }
                let avatar = (response.avatar) ? `<img src="${response.avatar}" class="member-avatar">` : `<i class="fa fa-user-circle" style="position:relative;bottom:5px;"></i>`
                $('#desktopMemberNav').html(
                  `
                    <a href="#" class="member-profile-link" data-bs-toggle="dropdown" role="button" id="memberDropdownLink"><i class="far text-danger fa-heart fa-sm"></i> ${avatar}</a>
                    <ul class="dropdown-menu dropdown-menu-end" aria-labelledby="memberDropdownLink" style="z-index:9999;top:86%;right:0;">
                      <li class="dropdown-item username px-3 py-2"><a href="/account/profile/">${response.username}</a></li>
                      <li class="dropdown-item"><a href="/account/lists/"><i class="far fa-fw fa-heart text-danger"></i> Lists & Likes</a></li>
                      <li class="dropdown-item"><a href="/account/settings/"><i class="far fa-fw fa-cog"></i> Account</a></li>
                      <li class="dropdown-item"><a href="/account/logout/"><i class="far fa-fw fa-sign-out"></i> Log Out</a></li>
                    </ul>
                  `
                );
                $('#mobileAvatarContainer').html(
                  `
                    <a href="#" onclick="return false;" data-bs-toggle="collapse" data-bs-target="#mobileMemberNavTop" aria-controls="mobileMemberNavTop" aria-expanded="false" aria-label="Toggle member navigation" id="memberDropdownLink">${avatar}</a>
                  `
                )
              } else {
                localStorage.removeItem('lists')
                localStorage.removeItem('listskey')
              }
            }
          };
          xhr.send();
        }
        getMemberMenu();
      </script>
    </div>
  </nav>
</div>

        <div class="standalone-search-bar">
  <div class="search-container container" id="siteSearch">
    <span class="search-bar-label">Show Me</span>
    <input class="typeahead" type="text" placeholder="events, movies, venues, restaurants, guides..." data-sort-group="" data-site-section="">
    <i class="search-icon far fa-search"></i>

    <div role="listbox" class="default-search-panel p-3" style="display: none;" aria-expanded="false">
      <div role="presentation" class="row">
        <i class="loading-spinner fas fa-spinner fa-spin p-3"></i>
        <div class="col-6 col-sm-4 category-list">
        </div>
        <div class="col-6 col-sm-8 article-list">
        </div>
      </div>
    </div>
  </div>

  <script>
    $('.search-container .search-icon').on('click', function() {
      var market_slug = 'seattle';
      var search_value = $('.tt-input').val()
      if (search_value) {
        if (market_slug !== '') {
          window.location.href = '/' + market_slug + '/search?q=' + encodeURIComponent(search_value);
        } else {
          window.location.href = '/search?q=' + encodeURIComponent(search_value);
        }
      }
    })
  </script>
</div>

        
  <div class="trending-stories-bar">
    <div class="container">
      <div class="row g-0">
        <div class="col-md-auto d-none d-md-block">
          <div class="trending-stories-item indicator me-2"><i class="fad fa-branded fa-chevron-double-right"></i><i class="fad fa-branded fa-chevron-double-right"></i></div>
        </div>
        
          <div class="col-auto mb-2 mb-md-0">
            <a class="trending-stories-item me-2" href="https://everout.com/seattle/top-events/">✨ Top Things To Do Today &amp; This Week</a>
          </div>
        
          <div class="col-auto mb-2 mb-md-0">
            <a class="trending-stories-item me-2" href="https://everout.com/seattle/food/">🍜  Food &amp; Drink Guide</a>
          </div>
        
          <div class="col-auto mb-2 mb-md-0">
            <a class="trending-stories-item me-2" href="https://everout.com/seattle/events/?category=music&amp;type=in-person">🎵 Live Music</a>
          </div>
        
          <div class="col-auto mb-2 mb-md-0">
            <a class="trending-stories-item me-2" href="https://everout.com/seattle/articles/where-to-get-christmas-trees-holiday-wreaths-more-festive-greenery-in-seattle-winter-2021-edition/c3981/">🎄 Christmas Trees</a>
          </div>
        
          <div class="col-auto mb-2 mb-md-0">
            <a class="trending-stories-item me-2" href="https://everout.com/seattle/articles/the-top-11-holiday-markets-for-2021-gift-shopping-in-seattle/c3963/">🎁 Holiday Markets</a>
          </div>
        
      </div>
    </div>
  </div>


        
      </div>

      
        <div class="top-super text-center container">
          


  

  
    
      <div id='EverOut-Seattle-Content-Top-56' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Top-56'); });
        </script>
      </div>
    
  

  
    
      <div id='EverOut-Seattle-Content-Mobile-Top-57' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Mobile-Top-57'); });
        </script>
      </div>
    
  

  

  

  

  

  

  


        </div>
      

      <div class="container main-container">
        

        <div class="row main">
          
          <div class="col-md-8 primary">
            <header>
              
  <div class="row">
  <div class="col ttd-breadcrumbs">
    
      <a href="/seattle/">Seattle</a>
    
    <span class="breadcrumb-delimiter">&gt;</span>
    
      
        <a href="/seattle/articles/" class="">Picks &amp; Guides</a>
      
      
    
  </div>
</div>


            </header>

            <div class="content">
              
  <div class="item-detail article">
    <article>
      
      <header class="mb-2">
        
          
            <a class="category-tag" href="/seattle/articles/?category=cheap-easy">Cheap & Easy</a>
          
        
        <h1>
          59 Cheap & Easy Things To Do in Seattle This Weekend: Dec 3-5, 2021
        </h1>
        <div class="subhead">
          The Kringles Filling Station Holiday Experience, Urban Craft Uprising's Winter Show, and More Last-Minute Events Under $15
        </div>
        
          <div class="author">
            by <a href="https://everout.com/seattle/authors/elaina-friedman/w164/">Elaina Friedman</a>
          </div>
        
        
          <div class="published-date">
            December 1, 2021
          </div>
        
        
        


<div class="item-tools d-flex justify-content-around mt-2 p-2 p-md-1">
  <div class="d-flex align-items-center flex-column flex-md-row item-tool" style="transform: rotate(0);">
    <a href="#" class="like-btn stretched-link px-2" data-model="editorial.article" data-oid="3987" data-like-count="0">
      <i class="far fa-lg fa-heart like-btn-heart"></i>
    </a>
    <span class="item-tools-label">
      Like
      <small class="like-btn-count text-muted">
        0
      </small>
    </span>
  </div>
  <div class="d-flex align-items-center flex-column flex-md-row item-tool" style="transform: rotate(0);">
    <div class="atl-button-skelly"></div>
    <div class="atl-button-container d-flex align-items-center flex-column flex-md-row" style="display:none;">
      <a href="#" class="add-to-list-btn stretched-link px-2" data-bs-toggle="offcanvas" data-bs-target="#addToListSheet"
        aria-controls="addToListSheet" data-model="editorial.article" data-oid="3987"
        data-object-name="59 Cheap &amp; Easy Things To Do in Seattle This Weekend: Dec 3-5, 2021 ">
        <i class="fad fa-lg fa-plus-square fa-branded"></i>
      </a>
      <span class="item-tools-label">Add to a List</span>
    </div>
  </div>
  <div class="d-flex align-items-center flex-column flex-md-row">
    <div class="d-flex justify-content-evenly share-services">
      <div class="facebook-this share-tool">
    <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A//everout.com/articles/59-cheap-easy-things-to-do-in-seattle-this-weekend-dec-3-5-2021/c3987/" class="share-link new-window" target="_blank"><i class="fab fa-lg fa-facebook pe-2"></i></a>
</div>

      <div class="tweet-this share-tool">
    <a href="https://twitter.com/intent/tweet?text=59%20Cheap%20%26%20Easy%20Things%20To%20Do%20in%20Seattle%20This%20Weekend%3A%20Dec%203-5%2C%202021%2C%20from%20EverOut%20https%3A//everout.com/articles/59-cheap-easy-things-to-do-in-seattle-this-weekend-dec-3-5-2021/c3987/" class="share-link new-window" target="_blank"><i class="fab fa-lg fa-twitter pe-2"></i></a>
</div>

      <div class="mail-this share-tool">
    <a href="mailto:?subject=59%20Cheap%20%26%20Easy%20Things%20To%20Do%20in%20Seattle%20This%20Weekend%3A%20Dec%203-5%2C%202021%2C%20from%20EverOut&body=59%20Cheap%20%26%20Easy%20Things%20To%20Do%20in%20Seattle%20This%20Weekend%3A%20Dec%203-5%2C%202021%2C%20from%20EverOut%20https%3A//everout.com/articles/59-cheap-easy-things-to-do-in-seattle-this-weekend-dec-3-5-2021/c3987/"><i class="fas fa-lg fa-envelope"></i></a>
</div>

    </div>
    <span class="item-tools-label d-md-none">Share</span>
  </div>
</div>
<div class="item-on-lists-bar bg-light text-center fs-7 py-1" id="itemListBar-c3987" style="display:none;"></div>

<style type="text/css">
  .skelly {
    background: rgba(0, 0, 0, .2);
    min-width: 300px;
  }
  .add-title-skelly {
    height: 1em;
  }
  .list-wrapper-skelly {
    height: 240px;
    display: flex;
    align-items: center;
    justify-content: center;
  }
</style>
<div class="add-to-list-sheet offcanvas-sheet offcanvas offcanvas-bottom text-start h-auto" tabindex="-1" id="addToListSheet" aria-labelledby="addToListSheetLabel">
  <div class="offcanvas-header-wrapper g-0">
    <div class="container">
      <div class="offcanvas-header py-2">
        <h3 class="offcanvas-title" id="addToListSheetLabel">
          <div class="add-title-container">
            <div class="add-title display-item" style="display:none;">
              Adding <span class="object-name text-link"></span> to a list
            </div>
            <div class="add-title-skelly skelly"></div>
          </div>
        </h3>
        <button type="button" class="btn-close text-reset" data-bs-dismiss="offcanvas" aria-label="Close"></button>
      </div>
    </div>
  </div>
  <div class="container g-0">
    <div class="offcanvas-body">
      <div class="add-body">
        <div class="member-alert success fs-5 mb-3" id="newUserListIntro" style="display:none;">
          EverOut lists are a great tool for crafting weekend itineraries, curating restaurant recommendations for your out-of-town friends, and so much more! Endlessly customizable, you can mix and match events, locations, and articles, or keep them separate. You can even invite your friends to contribute to your lists!
        </div>
        <input type="hidden" name="model" value="">
        <input type="hidden" name="oid" value="">
        <div class="list-wrapper-skelly skelly">
          <div class="lds-ripple"><div></div><div></div></div>
        </div>
        <div class="list-wrapper display-item" style="display:none;">
          <div class="list-select-row new-list mb-1 bg-light">
            <div class="form-check">
              <input class="form-check-input" type="checkbox" id="listCheckNew" data-list="new" data-bs-toggle="collapse"
                data-bs-target="#newListInput" aria-expanded="false" aria-controls="newListInput">
              <label class="form-check-label" for="listCheckNew">Add to a New List</label>
              <div id="newListInput" class="collapse">
                <input type="text" name="newListName" class="form-control" placeholder="Give your new list a name!">
                <div class="form-text">
                  New lists are private and visible only to you. You can change this any time.
                </div>
              </div>
            </div>
          </div>
          <div id="existingListsHeader" class="fs-6 fw-bold mt-3" style="display:none;">Or add to your existing lists:</div>
          <div id="existingListsWrapper">
            <div class="list-group"></div>
          </div>
        </div>
        <div class="my-3">
          <label for="itemNote" class="form-label mb-1">Note</label>
          <span class="text-muted fs-8 ms-2">optional</span>
          <textarea class="form-control" id="itemNote" rows="2" name="note"></textarea>
          <div class="form-text">Say something about this item. If you add it to multiple lists, the note will be added to all lists. You can always change it later!</div>
        </div>
        <div class="mb-3">
          <button type="submit" class="add-btn btn btn-primary btn-lg" onClick="saveListItems();return false;">Add It!</button> <span class="error error-text danger-text fs-6 mx-3"></span>
        </div>
      </div>
      <div class="success-body" style="display:none;">
        <i class="fad fa-branded fa-thumbs-up fa-2x" aria-hidden="true"></i>
        <h1 class="d-inline-block">Done!</h1>
        <div class="mt-3 success-message"></div>
        <div class="lists-message fs-5">
          <strong class="object-name"></strong> is now on these lists:
          <ul class="added-lists list-unstyled mt-3"></ul>
        </div>
        <div class="mb-3 text-end">
          <button type="button" class="btn btn-secondary" data-bs-dismiss="offcanvas" aria-label="Close">Close</button>
        </div>
      </div>
      <div class="error-body" style="display:none;">
        <p class="error-message">
          Whoop! We ran into a problem. Please try again later.
        </p>
        <div class="mb-3">
          <button type="button" class="btn btn-secondary btn-lg" data-bs-dismiss="offcanvas" aria-label="Close">Close</button>
        </div>
      </div>
    </div>
  </div>
</div>

<div class="login-sheet offcanvas-sheet offcanvas offcanvas-bottom text-start h-auto" tabindex="-1" id="loginSheet" aria-labelledby="loginSheetLabel">
  <div class="offcanvas-header-wrapper g-0">
    <div class="container">
      <div class="offcanvas-header py-2">
        <h3 class="offcanvas-title" id="loginSheetLabel">
          <div class="login-title">Log In</div>
        </h3>
        <button type="button" class="btn-close text-reset" data-bs-dismiss="offcanvas" aria-label="Close"></button>
      </div>
    </div>
  </div>
  <div class="container g-0">
    <div class="offcanvas-body">
      <div class="login-body pb-4">
        <div class="fs-4 px-0 mx-0 px-md-5 mx-md-5 text-center" style="line-height:1.2;">
          Log in to like events and restaurants, create your own lists of all your favorite things, make plans with your friends, and more. It's free!
        </div>
        <div class="row justify-content-center mt-4">
          <div class="col-md-4 col-12 text-center mb-3 mb-md-0">
            <a class="btn btn-primary btn-lg d-block" href="/login/?next=/seattle/articles/59-cheap-easy-things-to-do-in-seattle-this-weekend-dec-3-5-2021/c3987/">Log In</a>
          </div>
          <div class="col-md-4 col-12 text-center">
            <a class="btn btn-primary btn-lg d-block" href="/signup/?next=/seattle/articles/59-cheap-easy-things-to-do-in-seattle-this-weekend-dec-3-5-2021/c3987/">Sign Up for Free</a>
          </div>
        </div>
      </div>
    </div>
  </div>
</div>


      </header>
      
        <div class="lead-image my-3">
          <img class="img-responsive" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzODM5NDIwNzI5OTYzNS1TY3JlZW5fU2hvdF8yMDIxLTEyLTAxX2F0XzQuMjcuNDVfUE0ucG5nIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJpbnNpZGUiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogMTAyNCwgImhlaWdodCI6IDgwMH19fQ== ">
          
            <div class="caption">
              Play a festive round of ski-ball, partake in holiday karaoke, and sip hot chocolate from a gas-pump rig at the <a href="https://everout.com/seattle/events/kringles-filling-station-holiday-experience/e106384/">Kringle's Filling Station Holiday Experience</a>.
              
                <span class="credit">
                  (Kringles Filling Station)
                </span>
              
            </div>
          
        </div>
      
      <div class="body-text">
        
          
            
              <p>It might be tempting to spend another rainy weekend glued to your couch (figuratively speaking), but even if you're pinching pennies and hate to plan, there are lots of reasons to put on your outside clothes over the next couple of days. We've compiled all the $15-and-under, easy-to-do-on-a-dime events below, from the opening of the Beverly Glenn-Copeland doc <em><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106625" href="https://everout.com/seattle/events/keyboard-fantasies/e106625/">Keyboard Fantasies</a></em> at Northwest Film Forum to Cookie Couture and Londyn Bradshaw's <a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106571" href="https://everout.com/seattle/events/weird-presents-a-comic-book-drag-show/e106571/">Comic Book Drag Show</a>, and from <a class="add-to-list-link" data-model="attractions.occurrence" data-oid="103424" href="https://everout.com/seattle/events/urban-craft-uprising-2021-winter-show/e103424/">Urban Craft Uprising's Winter Show</a> to a <a class="add-to-list-link" data-model="attractions.occurrence" data-oid="106373" href="https://everout.com/seattle/events/holiday-music-in-westlake-park/e106373/">free Sunday concert</a> with the Seattle String Quartet and the Dickens Carolers in Westlake Park. Want more options? Check out <a class="add-to-list-link" data-model="editorial.article" data-oid="3982" href="https://everout.com/seattle/articles/the-top-35-events-in-seattle-this-week-nov-29-dec-5-2021/c3982/">this week's top picks</a>. </p>
            
          
            
              
<hr/>
<p><small>Jump to: <a href="#friday">Friday</a> | <a href="#saturday">Saturday</a> | <a href="#sunday">Sunday</a></small></p>
            
          
            
              
<hr/>
<h3 id="friday">FRIDAY</h3>
<p><strong>MUSIC</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106572" href="https://everout.com/seattle/events/breaks-and-swells-maya-marie-debbie-miller/e106572/">Breaks and Swells, Maya Marie, Debbie Miller</a></strong><br/>Summed up as "soulful, classy, expressive, and percussive" by former <em>Stranger</em> writer Amber Cortes, local rockers Breaks and Swells will take the stage with songs from their latest release, <em>Entomology, </em>after sets from solo pop artists Maya Marie and Debbie Miller.<br/><em>Tractor Tavern, Ballard ($10)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106562" href="https://everout.com/seattle/events/candi-pop-taylors-version/e106562/">Candi Pop (Taylor's Version)</a></strong><br/>Taylor Swift fans can get hyped up on grande caramel non-fat lattes before dancing to breakup ballads and pop hits at this DJ dance party. <br/><em>Neumos, Capitol Hill ($12)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106518" href="https://everout.com/seattle/events/emotional-trash-saint-hussy-kitty-junk/e106518/">Emotional Trash, Saint Hussy, Kitty Junk</a></strong><br/>Start your weekend with a night of homebred alt-rock courtesy of Emotional Trash, Saint Hussy, and Kitty Junk.<br/><em>Cafe Racer, Capitol Hill ($10)</em></p>
            
          
            
              

<div class="fish-butter article-inline" data-spot="everout-editorial" data-context-oid="" data-ad-oid="" style="display:none;">
  
    <div class="fish-tag">
      Sponsored
    </div>
  
  <div class="fish-container">
    <div class="fish-image">
      
    </div>
    <div class="fish-body">
      <h1>
        
      </h1>
      <p>
        
      </p>
    </div>
  </div>
</div>

            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106555" href="https://everout.com/seattle/events/global-groove-dance-party/e106555/">Global Groove Dance Party</a></strong><br/>DJs Rizoma, Marvelette, Hot N' Spicy Disco, and Siempre Bruja will take turns spinning Afrobeat, funk, disco, cumbia, and other danceable genres from around the world. Guama Coffee will be onsite in case you're sleepy. <br/><em>LoFi, South Lake Union ($10)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106629" href="https://everout.com/seattle/events/northface-legends/e106629/">Northface Legends</a></strong><br/>Join up-and-comers Matt Hogenson, Ziggy Vola, City Boyy, Rich Hustle, Grand Gulla, Crystal C, and NVIII Dupree for a night of tunes. Will they be sporting identical puffer jackets? That we don't know. <br/><em>Skylark, West Seattle ($10)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106622" href="https://everout.com/seattle/events/the-foilies/e106622/">The Foilies</a></strong><br/>Get a taste of Montana-bred rock with The Follies, plus more from La'Goon, Kicked in the Zeke, and Molotov Juicebox. <br/><em>The Funhouse, Belltown ($8)</em></p>
            
          
            
              
<p><strong>PERFORMANCE</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106570" href="https://everout.com/seattle/events/drag-does-the-holidays/e106570/">Drag Does... the Holidays</a></strong><br/>Skarlet Dior Black's monthly pop-culture-themed drag show gets festive with nods to all the holidays on the calendar, from Hanukkah to Kwanzaa to Halloween.<br/><em>Kremwerk, Belltown ($10-$15)</em></p>
            
          
            
              


  

  

  

  

  
    
      <div id='EverOut-Seattle-Content-Mobile-Inline-1-54' class="mb-3 text-center ad-placement inline-ad">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Mobile-Inline-1-54'); });
        </script>
      </div>
    
  

  

  

  

  


            
          
            
              
<p><strong>SHOPPING</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106516" href="https://everout.com/seattle/events/holiday-market-at-lotte-hotel-seattle/e106516/">Holiday Market at Lotte Hotel</a></strong><br/>Shop for gifts from over 15 local vendors, try seasonal sweets like yule logs and macarons, enter raffles, and enjoy music from DJ Brian Hartbeat at this holiday market.<br/><em>The Sanctuary at Lotte Hotel, Downtown (free)</em></p>
            
          
            
              
<h3>FRIDAY-SATURDAY</h3>
<p><strong>WINTER HOLIDAYS</strong></p>
            
          
            
              
<p><strong><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="106384" href="https://everout.com/seattle/events/kringles-filling-station-holiday-experience/e106384/">Kringles Filling Station Holiday Experience </a></strong><br/>Kris Kringle's jolly brothers Otis and Sparky will open up their magical garage for the holidays, which will be decidedly merrier than your average gas station. Stop by for holiday karaoke and ski-ball, photo ops in front of the Kringles' sleigh, and cups of hot cocoa poured from a gas pump. <br/><em>8211 Aurora Ave, Greenwood ($10)</em></p>
            
          
            
              
<h3>FRIDAY-SUNDAY</h3>
<p><strong>FILM</strong></p>
            
          
            
              
<p><strong><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="106627" href="https://everout.com/seattle/events/the-empire-strikes-back/e106627/">The Empire Strikes Back</a></strong><br/>The Death Star has been destroyed and Imperial troops have driven the Rebel forces from their hidden base and pursued them across the galaxy. The empire strikes back in <em>Star Wars</em> Episode V, baby.<br/><em>Central Cinema, Central District ($8-$12)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106625" href="https://everout.com/seattle/events/keyboard-fantasies/e106625/">Keyboard Fantasies</a></strong><br/>When Beverly Glenn-Copeland, a Black trans septuagenarian and musical genius, received an unexpected email in 2016 from a record collector inquiring about his 1986 self-release, <em>Keyboard Fantasies</em>, the artist's music career went from complete obscurity to indie success, sending him on his first tour at the age of 74. Posy Dixon's joyful documentary follows the Canadian American musician's path to fame. <br/><em>Northwest Film Forum, Capitol Hill ($13) </em></p>
            
          
            
              
<p><strong><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="106628" href="https://everout.com/seattle/events/scrooged/e106628/">Scrooged</a></strong><br/>Richard Donner has a tendency to let the manic energy of his filmmaking slide into shrillness. Films that played as madcap hijinks on release (<em>The Goonies</em>, <em>Lethal Weapon 2</em>) are, on second viewing, just annoying noise. But 1988’s <em>Scrooged</em>—arguably the last great movie Donner made—is different. Rewatches reveal an underlying sweetness and patience it didn’t get credit for at the time—audiences and critics were likely distracted by its on-the-nose parodies of then-crass-but-now-quaint television programming and the evergreen joy of seeing Carol Kane swing a toaster like a mace. But Bill Murray’s expert blend of acid and schmaltz (along with the genius idea of making Bob Goldthwait into Bob Cratchit) turn what could have been a mean-spirited misfire of soured sentimentality into a Christmas gift that is both 100 percent of the decade that spawned it, and better than that decade deserved. <strong>BOBBY ROBERTS<br/></strong><em>Central Cinema, Central District ($</em><em>12)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106626" href="https://everout.com/seattle/events/the-two-sights-an-da-shealladh/e106626/">The Two Sights (An Dà Shealladh)</a></strong><br/>Shot in 16mm, Joshua Bonnetta's first solo documentary feature explores the disappearing Scottish phenomenon of Second Sight (a term that originated with the Gaels and refers to those gifted with a psychic ability yielding prophetic visions), featuring locals' accounts of phantom horses, ghost voices, and the like. We hear it has a spooky soundtrack, too.<br/><em>Northwest Film Forum, Capitol Hill ($13)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106624" href="https://everout.com/seattle/events/writing-with-fire/e106624/">Writing With Fire</a></strong><br/>Winner of both the Audience and Special Jury documentary prizes at this year's Sundance Film Festival, Rintu Thomas's documentary spotlights the journalists behind <em>Khabar Lahariya</em>, India’s only newspaper run by Dalit ("untouchable") women. <br/><em>SIFF Film Center, Queen Anne ($14)</em></p>
            
          
            
              
<p><strong>SHOPPING</strong></p>
            
          
            
              


  

  

  

  

  

  
    
      <div id='EverOut-Seattle-Content-Mobile-Inline-2-55' class="mb-3 text-center ad-placement inline-ad">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Mobile-Inline-2-55'); });
        </script>
      </div>
    
  

  

  

  


            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="105971" href="https://everout.com/seattle/events/holiday-shop-o-rama/e105971/">Holiday Shop-O-Rama</a></strong><br/>Local AAPI and Native Hawaiian vendors will sell all sorts of goods at Wing Luke's annual holiday market.<br/><em>Wing Luke Museum, Chinatown-International District (free)</em></p>
            
          
            
              
<p><strong>WINTER HOLIDAYS</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106407" href="https://everout.com/seattle/events/garden-dlights/e106407/">Garden d’Lights</a></strong><br/>Whimsical flora and fauna, birds, animals, and cascading waterfalls get the holiday light treatment at Bellevue Botanical Garden's annual display. (To be clear, actual birds and animals will not be strung with lights.) Wander the grounds and take photos among the "half a million" bulbs.<br/><em>Bellevue Botanical Garden ($5)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106367" href="https://everout.com/seattle/events/slu-after-dark/e106367/">SLU After Dark</a></strong><br/>Take yourself on a self-guided tour of South Lake Union's four interactive light installations in Van Vorst Plaza, Nitro Pizza, re:Invent Plaza, and Day 1 Playfield.<br/><em>Various locations, South Lake Union (free)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106374" href="https://everout.com/seattle/events/snowflake-lane/e106374/">Snowflake Lane</a></strong><br/>Every year, downtown Bellevue turns into a winter wonderland not just for one night but for a whole dang month, with (fake) falling snow, jolly music, and twinkling lights every night until Christmas Eve.<br/><em>Bellevue Square (free)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106411" href="https://everout.com/seattle/events/winter-porch-light-parade-2021/e106411/">Winter Porch Light Parade 2021</a></strong><br/>Bothell residents can try their luck at a grand prize for their porch or front-yard light displays. If you're not a participant, you can still walk or drive around the neighborhood to enjoy the sights. <br/><em>Various locations, Bothell (free)</em></p>
            
          
            
              
<h3 id="saturday">SATURDAY</h3>
<p><strong>FOOD &amp; DRINK</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106479" href="https://everout.com/seattle/events/post-pike-one-year-anniversary-party/e106479/">Post Pike One Year Anniversary Party</a></strong><br/>The neighborhood bar and cafe invites one and all to celebrate its first year around the sun with drink specials, a free photo booth, and funky tunes from DJ Pretty Please.<br/><em>Post Pike, Capitol Hill (free)</em></p>
            
          
            
              
<p><strong>MUSIC</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106616" href="https://everout.com/seattle/events/100-that-queen-a-lizzo-inspired-dance-party/e106616/">100% That Queen - a Lizzo Inspired Dance Party!</a></strong><br/>Taking a DNA test won't be necessary (but a COVID one will if you're unvaccinated) to attend this Lizzo-licious night of dancing which will also blast tracks by Doja Cat, Saweetie, Megan Thee Stallion, Cardi B, and more.<br/><em>Neumos, Capitol Hill ($5)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106614" href="https://everout.com/seattle/events/bloom-ft-succubass/e106614/">Bloom Ft. Succubass</a></strong><br/>The "cerebral sonic experience" that is DJ Gag Reflex's genre-spanning techno night will return, helmed this time by special guest Succubass.<br/><em>Timbre Room, Belltown ($12)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106517" href="https://everout.com/seattle/events/hallows-haunted-horses-profit-prison/e106517/">Hallows, Haunted Horses &amp; Profit Prison</a></strong><br/>Lean into a state of collective unease by dancing in time to paranoid darkwave from Seattle-based duo Hallows, sharing this bill with industrial punk outfit Haunted Horses and ambient punks Profit Prison.<br/><em>Cafe Racer, Capitol Hill ($10)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106623" href="https://everout.com/seattle/events/no-fi-soul-rebellion/e106623/">No-Fi Soul Rebellion</a></strong><br/>Bellingham-based husband-and-wife duo No-Fi Soul Rebellion has been playing music together for over 20 years. Join them for a night out with Separtr and The Wyrds.<br/><em>The Funhouse, Belltown ($8)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106560" href="https://everout.com/seattle/events/ol-doris-kids-on-fire-rat-paws/e106560/">Ol' Doris, Kids on Fire, Rat Paws</a></strong><br/>Eleanor Dumouchel and her indie-rock project Rat Paws will take the stage after sets from genre mutuals Ol' Doris and Kids on Fire.<br/><em>The Kraken Bar &amp; Lounge, University District ($8)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106617" href="https://everout.com/seattle/events/seacats-with-divorce-care-erik-walters/e106617/">Seacats with Divorce Care &amp; Erik Walters</a></strong><br/>Having started as an offshoot of a high-school comedy web show, Kelso-formed rock band Seacats have left the jokes behind in favor of songs about serious subjects like abuse. They'll head up in Ballard with support from Divorce Care and Erik Walters. <br/><em>Tractor Tavern, Ballard ($10)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106567" href="https://everout.com/seattle/events/sweet-creature-hurry-up-snufkin-don-forgetti/e106567/">Sweet Creature, Hurry Up, Snufkin, Don Forgetti</a></strong><br/>You won't have to pony up a single buck to rock out to sets from <span style="font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen, Ubuntu, Cantarell, 'Open Sans', 'Helvetica Neue', sans-serif;">Bellingham's Sweet Creature (who describe their sounds as "No taste fuckwitch guilt-rock"), Hurry Up, Snufkin, and Don Forgetti. <br/><em>Monkey Pub, University District (free)</em></span></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106630" href="https://everout.com/seattle/events/the-harper-conspiracy-the-fully-realized/e106630/">The Harper Conspiracy &amp; The Fully Realized</a></strong><br/>Dance to the harmonies of Seattle rock/soul band The Harper Conspiracy, who will be joined by The Fully Realized.<br/><em>Skylark, West Seattle ($10)</em></p>
            
          
            
              
<p><strong>PERFORMANCE</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="104309" href="https://everout.com/seattle/events/cornucopia-an-improvisational-feast/e104309/">Cornucopia: An Improvisational Feast</a></strong><br/>Seattle's best independent improv groups will aim to leave you in stitches after four 20-minute performances in one show, curated by Jet City's associate artistic director Mike Christensen.<br/><em>University Heights, University District ($5-$12)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106571" href="https://everout.com/seattle/events/weird-presents-a-comic-book-drag-show/e106571/">Weird Presents: A Comic Book Drag Show</a></strong><br/>Whether or not you're riding the <a class="add-to-list-link" data-model="attractions.occurrence" data-oid="106251" href="https://everout.com/seattle/events/emerald-city-comic-con/e106251/">Comic Con</a> wave this year, geek up your night with Londyn Bradshaw and Cookie Couture's tribute to Marvel, DC, Dark Horse, Archie Comics, and more. <br/><em>Kremwerk, Belltown ($13-$15)</em></p>
            
          
            
              
<p><strong>READINGS &amp; TALKS</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106563" href="https://everout.com/seattle/events/r-kikuo-johnson-book-launch/e106563/">R. Kikuo Johnson Book Launch</a></strong><br/>The Georgetown staple Fantagraphics will celebrate 11 years on the scene with an appearance from frequent <em>New Yorker</em> cover artist R. Kikou Johnson, who will be signing copies of his latest graphic novel, <em>No One Else</em>, plus the reissued 15-anniversary edition of <em>Night Fishe</em>r. There will also be snacks.<br/><em>Fantagraphics, Georgetown (free)</em></p>
            
          
            
              
<p><strong>SHOPPING</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106531" href="https://everout.com/seattle/events/arboretum-holiday-sale/e106531/">Arboretum Holiday Sale</a></strong><br/>After last year's hiatus, the arboretum is back with its annual holiday sale teeming with botanical decorations and other nature-inspired gifts.<br/><em>Washington Park Arboretum, Madison Park (free)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106513" href="https://everout.com/seattle/events/pioneer-square-holiday-market/e106513/">Pioneer Square Holiday Market</a></strong><br/>Red Eagle Soaring and Totem Star will keep you entertained while you dine, drink, and shop in the festively adorned Pioneer Square plaza.<br/><em>Occidental Square, Pioneer Square (free)</em></p>
            
          
            
              
<p><strong>WINTER HOLIDAYS</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106576" href="https://everout.com/seattle/events/auburns-lighted-santa-parade-tree-lighting/e106576/">Auburn's Lighted Santa Parade &amp; Tree Lighting</a></strong><br/>The streets of Auburn's Main Street and beyond will see a procession of light-strewn vehicles, floats, and more. Santa will make an appearance after the parade.<br/><em>Auburn Main Street (free)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106558" href="https://everout.com/seattle/events/ballard-holidayfest-2021/e106558/">Ballard HolidayFest 2021</a></strong><br/>Families can take advantage of free photos with Santa, a tree lighting, and festive treats and music in the park.<br/><em>Marvin's Garden, Ballard (free)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106559" href="https://everout.com/seattle/events/filson-santa/e106559/">Filson Santa</a></strong><br/>A particularly outdoorsy Santa will swing by Filson to take photos with kids and families. Enjoy drinking chocolate, hot cider, and complimentary gift wrapping while you wait.<br/><em>Filson Flagship, Sodo (free)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106564" href="https://everout.com/seattle/events/holiday-lenin-lighting-celebration/e106564/">Holiday Lenin Lighting Celebration</a></strong><br/>Fremont's towering and slightly menacing Lenin statue will be set aglow with twinkling lights.<br/><em>Lenin Statue, Fremont (free)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="105969" href="https://everout.com/seattle/events/holiday-open-house-artists-market/e105969/">Holiday Open House &amp; Artists Market</a></strong><br/>Buy pieces from guest artists and jewelers like AJ Powers, Carol Adelman, Cecelia Stitch, and others. <br/><em>Building C Studios, Phinney (free)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106578" href="https://everout.com/seattle/events/kent-winterfest-tree-lighting-parade/e106578/">Kent Winterfest Tree Lighting &amp; Parade</a></strong><br/>This annual celebration will return for a day of live seasonal music, inflatable decorations, free hot cider, hot cocoa, and popcorn, holiday storytime, a Christmas tree lighting, and, of course, a visit from Santa.<br/><em>Town Square Park, Kent (free)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="105963" href="https://everout.com/seattle/events/living-artists-collective-holiday-market/e105963/">Living Artists Collective Holiday Market</a></strong><br/>Shop for original stickers, prints, tarot decks, greeting cards, and other highly gift-able stuff by member artists of the Living Artists Collective.<br/><em>Ada's Technical Books, Capitol Hill (free)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="105973" href="https://everout.com/seattle/events/queen-city-holiday-market/e105973/">Queen City Holiday Market</a></strong><br/>Queen City's second annual pop-up market returns with giftable goods from local women-owned businesses. <br/><em>Black Dot, Central District (free)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106579" href="https://everout.com/seattle/events/west-seattle-junction-night-market-and-tree-lighting/e106579/">West Seattle Junction Night Market and Tree Lighting</a></strong><br/>Kick off West Seattle's Hometown Holidays with a tree lighting ceremony. You can also look forward to photos with Santa, ornament-making, and an artisan night market.<br/><em>West Seattle Junction (free)</em></p>
            
          
            
              
<h3>SATURDAY-SUNDAY</h3>
<p><strong>SHOPPING</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="105960" href="https://everout.com/seattle/events/phinney-neighborhood-associations-41st-annual-winter-festival-crafts-fair/e105960/">Phinney Neighborhood Association's 41st Annual Winter Festival &amp; Crafts Fair</a></strong><br/>Support local artists and PNA's nonprofit programs at this festival that will also include a wreath sale and quilt raffle, plus jewelry, pottery, home goods, and more gifts from 100 makers.<br/><em>Phinney Center Community Hall (free)</em></p>
            
          
            
              
<p><strong><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="103424" href="https://everout.com/seattle/events/urban-craft-uprising-2021-winter-show/e103424/">Urban Craft Uprising 2021 Winter Show</a></strong><br/>You're bound to find something special for a loved one or for yourself at the winter edition of "Seattle’s largest indie craft show," which features over 150 artsy vendors.<br/><em>Seattle Center Exhibition Hall (free)</em></p>
            
          
            
              
<p><strong>VISUAL ART</strong></p>
            
          
            
              
<p><strong><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="106505" href="https://everout.com/seattle/events/its-only-rock-n-roll-art-attack/e106505/">"It's Only Rock n Roll" Art Attack </a></strong><br/>The gallery will dedicate the entire month to 25 pieces of art inspired by rock and roll.<br/><em>Fogue Studios &amp; Gallery, Georgetown (free); opening</em></p>
            
          
            
              
<h3 id="sunday">SUNDAY</h3>
<p><strong>FILM</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106565" href="https://everout.com/seattle/events/vhs-movie-night-santas-slay/e106565/">VHS Movie Night: Santa's Slay</a></strong><br/>Be kind and rewind all the way back to 2005 for this VHS screening <em>Santa's Slay</em>, a fine cinematic endeavor that depicts Old Saint Nick as a demon who becomes the giver of toys and holiday cheer only after losing a bet with an angel. <br/><em>Cafe Racer, Capitol Hill (free)</em></p>
            
          
            
              
<p><strong>FOOD &amp; DRINK</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106590" href="https://everout.com/seattle/events/glogg-party-at-the-beer-hall/e106590/">Gløgg Party at the Beer Hall</a></strong><br/>Let the German Christmas vibes abound by glugging some gløgg in the beer hall's heated pergola, which will also play host to live holiday music, pølse, pretzels, fire pits, and a Viking pottery sale.<br/><em>Skål Beer Hall, <span class="text-muted">Ballard (free)</span></em></p>
            
          
            
              
<p><strong>GEEK</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106523" href="https://everout.com/seattle/events/buffy-the-vampire-slayer-trivia/e106523/">Buffy the Vampire Slayer Trivia</a></strong><br/>Sharpen your pencils and stakes and dive into a night of trivia about your favorite vampire-slaying Sunnydale residents.<br/><em>Distant Worlds Coffeehouse, University District ($5-$7)</em></p>
            
          
            
              
<p><strong>MUSIC</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106568" href="https://everout.com/seattle/events/artists-at-the-center-presents-khu-eex/e106568/">Artists at the Center presents: Khu.éex’</a></strong><br/>Headed up by Tlingit bassist/vocalist (and lauded glass artist) Preston Singletary, Khu.éex' (pronounced Koo-eex) are a supergroup composed largely of indigenous poets and musicians. Beginning as a chance meeting between Singletary and legendary funk keyboardist Bernie Worrell (Parliament-Funkadelic, Talking Heads), Khu.éex' combine far-out funk and jazz with spoken word and Great Native Northwest storytelling to present a contemporary interpretation of their culture to the world. Most recent EP <em>Héen</em> ("water" in Tlingit) deals with the importance of water to indigenous communities across the country. <strong>JAS KEIMIG<br/></strong><em>Seattle Center Armory (free)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106621" href="https://everout.com/seattle/events/seahawks-vs-49ers-after-party-feat-monster-road/e106621/">Seahawks vs. 49ers After Party Feat. Monster Road!</a></strong><br/>Groove to Monster Road's '60s- and '70s-inspired R&amp;B and soul after the big Seahawks game.<br/><em>Central Saloon, Pioneer Square ($5)</em></p>
            
          
            
              
<p><strong><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="106615" href="https://everout.com/seattle/events/spacy-international-disco-city-pop-lofi-house-downtempo-more/e106615/">Spacy</a></strong><br/>Three like-minded DJs bring "chill, international, city vibes" to Kremwerk's upstairs stage. <br/><em>Timbre Room, Belltown ($7-$10)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106557" href="https://everout.com/seattle/events/the-marina-albero-trio-entre-mundos/e106557/">The Marina Albero Trio + Entre Mundos</a></strong><br/>Barcelona-raised, Seattle-based piano virtuoso Marina Albero will bring a fiery amalgam of Spanish, flamenco, Cuban, and jazz influences to the Old Rainier Brewery.<br/><em>Old Rainier Brewery, Georgetown ($12-$15)</em></p>
            
          
            
              
<p><strong>PERFORMANCE</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106373" href="https://everout.com/seattle/events/holiday-music-in-westlake-park/e106373/">Holiday Music in Westlake Park </a></strong><br/>Punctuate your winter Sundays with free concerts in the park with groups like Warren Dunes, the Seattle String Quartet, and the Roosevelt Jazz Band, plus holiday carolers.<br/><em>Westlake Park, Downtown (free)</em></p>
            
          
            
              
<p><strong>READINGS &amp; TALKS</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106520" href="https://everout.com/seattle/events/fiercely-indigenous/e106520/">Fiercely Indigenous</a></strong><br/>Local Indigenous poets Laura Da’ (Eastern Shawnee), fabian romero (Purépecha), and Arianne True (Choctaw, Chickasaw) will come together for the winter edition of this storytelling showcase.<br/><em>Pier 62, Downtown (free)</em></p>
            
          
            
              
<p><strong>SHOPPING</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106433" href="https://everout.com/seattle/events/cookbook-sale/e106433/">Cookbook Sale</a></strong><br/>Find gifts for the gourmands in your life at this Ballard cookbook sale co-hosted by Friends of the Seattle Public Library.<br/><em>Percy's &amp; Co., Ballard (free)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106527" href="https://everout.com/seattle/events/december-holiday-market/e106527/">December Holiday Market</a></strong><br/>The Italian joint will introduce the guest chefs of its "Future of Diversity" lineup (a program that highlights up-and-coming chefs of color in Seattle) in conjunction with its inaugural holiday market, which promises lots of spice blends, baked goods, pantry items, and other specialty goodies for the food lovers in your life.<br/><em>Osteria La Spiga, <span class="text-muted">Capitol Hill (free)</span></em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106409" href="https://everout.com/seattle/events/jingle-mingle-holiday-market/e106409/">Jingle &amp; Mingle Holiday Market</a></strong><br/>You can shop for holiday gifts, visit with Santa, get sloshed at a cash bar, and make new friends at the casino.<br/><em>Tulalip Resort Casino, Tulalip (free)</em></p>
            
          
            
              
<p><strong>WINTER HOLIDAYS</strong></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106366" href="https://everout.com/seattle/events/giant-menorah-lighting-and-gelt-drop-in-ballard/e106366/">Giant Menorah Lighting and Gelt Drop</a></strong><br/>The last night of Hanukkah will be met with a menorah lighting, traditional treats like latkes, jelly doughnuts, and chocolate coins (which will rain down from an extended fire ladder in a "Great Gelt Drop"), and kids' activities.<br/><em>Bergen Place, Ballard (free)</em></p>
            
          
            
              
<p><strong><a class="event-header add-to-list-link" data-model="attractions.occurrence" data-oid="106561" href="https://everout.com/seattle/events/santa-at-ounces/e106561/">Santa at Ounces!</a></strong><br/>Bring your whole family (dogs included) to take free photos with Santa. <br/><em>Ounces, West Seattle (free)</em></p>
            
          
            
              </p>
            
          
            
              

<div class="fish-butter article-inline" data-spot="everout-editorial" data-context-oid="" data-ad-oid="" style="display:none;">
  
    <div class="fish-tag">
      Sponsored
    </div>
  
  <div class="fish-container">
    <div class="fish-image">
      
    </div>
    <div class="fish-body">
      <h1>
        
      </h1>
      <p>
        
      </p>
    </div>
  </div>
</div>

            
          
        
      </div>
    </article>
    
      


  <div class="related-articles border-top mt-4 pt-2">
    <h2 class="pt-4 mb-2 section-header highlighted">You Might Also Like</h2>
    <div class="row row-cols-2 row-cols-md-3 no-gutters">
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/this-week-in-seattle-event-news-jazmine-sullivan-foo-fighters-and-more/c3991/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzODQ3NjMxMDU5NTc5MS1qYXouanBlZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY292ZXIiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogNDAwLCAiaGVpZ2h0IjogMzAwfX19"></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/this-week-in-seattle-event-news-jazmine-sullivan-foo-fighters-and-more/c3991/">This Week in Seattle Event News: Jazmine Sullivan, Foo Fighters, and More</a>
              </div>
              
                <h6 class="card-subtitle mb-2">Ticket Alerts and Event Updates for the Week of November 29, 2021</h6>
              
            </div>
          </div>
        </div>
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/59-cheap-easy-things-to-do-in-seattle-this-weekend-dec-3-5-2021/c3987/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzODM5NDIwNzI5OTYzNS1TY3JlZW5fU2hvdF8yMDIxLTEyLTAxX2F0XzQuMjcuNDVfUE0ucG5nIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJjb3ZlciIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA0MDAsICJoZWlnaHQiOiAzMDB9fX0="></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/59-cheap-easy-things-to-do-in-seattle-this-weekend-dec-3-5-2021/c3987/">59 Cheap & Easy Things To Do in Seattle This Weekend: Dec 3-5, 2021</a>
              </div>
              
                <h6 class="card-subtitle mb-2">The Kringles Filling Station Holiday Experience, Urban Craft Uprising&#x27;s Winter Show, and More Last-Minute Events Under $15</h6>
              
            </div>
          </div>
        </div>
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/your-guide-to-december-2021-events-in-seattle/c3985/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzODIzNjAzNTY3ODU0OC1iZW5kZWxhY3JlbWUuanBlZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY292ZXIiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogNDAwLCAiaGVpZ2h0IjogMzAwfX19"></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/your-guide-to-december-2021-events-in-seattle/c3985/">Your Guide to December 2021 Events in Seattle</a>
              </div>
              
                <h6 class="card-subtitle mb-2">Holiday Shows, New Year&#x27;s Eve Parties, Concerts, and More</h6>
              
            </div>
          </div>
        </div>
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/18-great-wine-bars-wine-shops-and-other-places-to-get-wine-in-seattle/c3984/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzODIyOTU0MjU5NDk0NS1TY3JlZW5fU2hvdF8yMDIxLTExLTI5X2F0XzMuNDMuMzZfUE0ucG5nIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJjb3ZlciIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA0MDAsICJoZWlnaHQiOiAzMDB9fX0="></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/18-great-wine-bars-wine-shops-and-other-places-to-get-wine-in-seattle/c3984/">18 Great Wine Bars, Wine Shops, and Other Places to Get Wine in Seattle</a>
              </div>
              
                <h6 class="card-subtitle mb-2">Drink Books, La Dive, and More</h6>
              
            </div>
          </div>
        </div>
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/the-top-35-events-in-seattle-this-week-nov-29-dec-5-2021/c3982/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzODE0MDczNDU0OTI3Mi1TY3JlZW5fU2hvdF8yMDIxLTExLTI4X2F0XzYuMDUuMDJfUE0ucG5nIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJjb3ZlciIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA0MDAsICJoZWlnaHQiOiAzMDB9fX0="></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/the-top-35-events-in-seattle-this-week-nov-29-dec-5-2021/c3982/">The Top 35 Events in Seattle This Week: Nov 29-Dec 5, 2021</a>
              </div>
              
                <h6 class="card-subtitle mb-2">Emerald City Comic Con, Supernova&#x27;s Festival of Lights, and More Top Picks</h6>
              
            </div>
          </div>
        </div>
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/where-to-get-christmas-trees-holiday-wreaths-more-festive-greenery-in-seattle-winter-2021-edition/c3981/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzNzc5OTU3MDg5NDgwNS10cmVlcy5qcGVnIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJjb3ZlciIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA0MDAsICJoZWlnaHQiOiAzMDB9fX0="></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/where-to-get-christmas-trees-holiday-wreaths-more-festive-greenery-in-seattle-winter-2021-edition/c3981/">Where to Get Christmas Trees, Holiday Wreaths & More Festive Greenery in Seattle: Winter 2021 Edition</a>
              </div>
              
                <h6 class="card-subtitle mb-2">U-Cut Farms, DIY Wreaths, and More</h6>
              
            </div>
          </div>
        </div>
      
    </div>
  </div>


    
  </div>

            </div>
          </div>
          <div class="col-md-4 secondary">
            
  <div id="adSpaceSidebarModule" class="adspace sidebar-module sidebar-module-inset">
  


  

  

  

  
    
      <div id='EverOut-Seattle-Content-Sidebar-1-50' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Sidebar-1-50'); });
        </script>
      </div>
    
  

  

  

  
    
      <div id='EverOut-Seattle-Content-Sidebar-2-51' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Sidebar-2-51'); });
        </script>
      </div>
    
  

  
    
      <div id='EverOut-Seattle-Content-Sidebar-3-52' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Sidebar-3-52'); });
        </script>
      </div>
    
  

  
    
      <div id='EverOut-Seattle-Content-Sidebar-4-53' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Sidebar-4-53'); });
        </script>
      </div>
    
  


</div>


          </div>
          
        </div>
      </div>
    </div>
    <footer class="mt-4">
      <div class="site-footer">
  <!-- desktop footer -->
  <div class="d-none d-md-block">
    <div class="footer-top-block">
  <div class="container">
    
      

<div class="component email-sign-up ">
  <div class="container text-center">
    
      <h1>Subscribe to our Newsletter</h1>
    
    
      <div class="copy">
        <p>Seattle is reopening! Sign up to get the latest updates on things to do, delivered to you four times a week.</p>
      </div>
    
    <form id="mc-embedded-subscribe-form" class="form" action="https://everout.us4.list-manage.com/subscribe/post?u=d7708ba310556d83ed7895c57&amp;id=01ccd644f5" method="post" name="" target="_blank">
      <div class="row g-3 align-items-center">
        <div class="col-md-8 offset-md-1"><input class="form-control mb-2 me-sm-2 email-input" name="EMAIL" type="email" placeholder="Email Address" /></div>
        
          
            <input type="hidden" value="1" name="group[71361][1]">
          
        
        <div class="col-md-2"><button class="btn btn-primary mb-2 submit-button" style="width:100%;" type="submit">Sign Up</button></div>
        <div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_d7708ba310556d83ed7895c57_01ccd644f5" type="text" value="" /></div>
      </div>
      <script>
        function setCityValue() {
          if ($('#citySelect').val() == 'seattle') {
            $('#citySelectValue').attr('name', 'group[71361][1]');
            $('#citySelectValue').val(1);
          } else if ($('#citySelect').val() == 'portland') {
            $('#citySelectValue').attr('name', 'group[71361][2]');
            $('#citySelectValue').val(2);
          }
        }
        $(function () {
          setCityValue();
        });
      </script>
    </form>
  </div>
</div>

    
    
      <div class="footer-row row">
        <div class="col-md">
          <div class="col-sm text-center">
            <div class="footer-social-links mt-0">
              <h2>Follow Us</h2>
              
                <a href="https://www.twitter.com/everoutseattle" target="_blank"><i class="fab fa-twitter"></i></a>
              
                <a href="http://www.facebook.com/everoutseattle" target="_blank"><i class="fab fa-facebook-f"></i></a>
              
                <a href="https://instagram.com/everoutfood" target="_blank"><i class="fab fa-instagram"></i></a>
              
            </div>
          </div>
        </div>
      </div>
    
  </div>
</div>
<div class="footer-bottom-block">
  <div class="container">
    <div class="footer-row row">
      <div class="col-md">
        <div class="footer-brand">
  <a class="navbar-brand" href="https://everout.com/seattle/"><img src="/assets/images/everout-logo-yellow.png" alt="EverOut"></a>
</div>

      </div>
      <div class="col-md-8">
        
          <p class="footer-links text-end pipe-delimited-links">
            
              <span><a href="/about/">About</a></span>
            
              <span><a href="/contact-us/">Contact</a></span>
            
              <span><a href="/follow-us/">Follow Us</a></span>
            
              <span><a href="/FAQ/">FAQ</a></span>
            
              <span><a href="/privacy-policy/">Privacy Policy</a></span>
            
              <span><a href="/terms-of-use/">Terms of Use</a></span>
            
              <span><a href="/takedown-policy/">Takedown Policy</a></span>
            
              <span><a href="https://everout.com/masthead/">Our Team</a></span>
            
              <span><a href="https://everout.com/seattle/events/submit/">Submit an Event</a></span>
            
          </p>
        
      </div>
    </div>
    <div class="row">
      <div class="col">
        <p>
  All contents © Index Newspapers, LLC. 2021<br>
  800 Maynard Ave S, Ste 200, Seattle, WA 98134
</p>

      </div>
    </div>
  </div>
</div> <!-- end footer copyright desktop-->

  </div><!-- end desktop footer -->

  <!-- mobile footer -->
  <div class="d-md-none">
    <!-- mobile footer -->
<div class="footer-mobile">
  <div class="footer-top-block mb-4">
    
      

<div class="component email-sign-up ">
  <div class="container text-center">
    
      <h1>Subscribe to our Newsletter</h1>
    
    
      <div class="copy">
        <p>Seattle is reopening! Sign up to get the latest updates on things to do, delivered to you four times a week.</p>
      </div>
    
    <form id="mc-embedded-subscribe-form" class="form" action="https://everout.us4.list-manage.com/subscribe/post?u=d7708ba310556d83ed7895c57&amp;id=01ccd644f5" method="post" name="" target="_blank">
      <div class="row g-3 align-items-center">
        <div class="col-md-8 offset-md-1"><input class="form-control mb-2 me-sm-2 email-input" name="EMAIL" type="email" placeholder="Email Address" /></div>
        
          
            <input type="hidden" value="1" name="group[71361][1]">
          
        
        <div class="col-md-2"><button class="btn btn-primary mb-2 submit-button" style="width:100%;" type="submit">Sign Up</button></div>
        <div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_d7708ba310556d83ed7895c57_01ccd644f5" type="text" value="" /></div>
      </div>
      <script>
        function setCityValue() {
          if ($('#citySelect').val() == 'seattle') {
            $('#citySelectValue').attr('name', 'group[71361][1]');
            $('#citySelectValue').val(1);
          } else if ($('#citySelect').val() == 'portland') {
            $('#citySelectValue').attr('name', 'group[71361][2]');
            $('#citySelectValue').val(2);
          }
        }
        $(function () {
          setCityValue();
        });
      </script>
    </form>
  </div>
</div>

    
    
      <div class="footer-row row g-0">
        <div class="col-md">
          <div class="col-sm text-center">
            <div class="footer-social-links mt-0">
              <h2>Follow Us</h2>
              
                <a href="https://www.twitter.com/everoutseattle" target="_blank"><i class="fab fa-twitter"></i></a>
              
                <a href="http://www.facebook.com/everoutseattle" target="_blank"><i class="fab fa-facebook-f"></i></a>
              
                <a href="https://instagram.com/everoutfood" target="_blank"><i class="fab fa-instagram"></i></a>
              
            </div>
          </div>
        </div>
      </div>
    
  </div>
  <div class="container">
    <div class="footer-row row">
      <div class="col-sm text-center">
        <div class="footer-brand">
  <a class="navbar-brand" href="https://everout.com/seattle/"><img src="/assets/images/everout-logo-yellow.png" alt="EverOut"></a>
</div>

        <p>
  All contents © Index Newspapers, LLC. 2021<br>
  800 Maynard Ave S, Ste 200, Seattle, WA 98134
</p>

        
          <p class="footer-links pipe-delimited-links">
            <small>
              
                <span><a href="/about/">About</a></span>
              
                <span><a href="/contact-us/">Contact</a></span>
              
                <span><a href="/follow-us/">Follow Us</a></span>
              
                <span><a href="/FAQ/">FAQ</a></span>
              
                <span><a href="/privacy-policy/">Privacy Policy</a></span>
              
                <span><a href="/terms-of-use/">Terms of Use</a></span>
              
                <span><a href="/takedown-policy/">Takedown Policy</a></span>
              
                <span><a href="https://everout.com/masthead/">Our Team</a></span>
              
                <span><a href="https://everout.com/seattle/events/submit/">Submit an Event</a></span>
              
            </small>
          </p>
        
      </div>
    </div>
  </div>
</div><!-- end mobile footer -->

  </div><!-- end mobile footer -->
</div><!-- end footer -->

      

  <div class="network-bar navbar d-md-none navbar-dark bg-dark">
    <div class="container">
      <ul class="navbar-nav me-auto">
        <li class="nav-item dropdown">
          <a class="nav-link dropdown-toggle" href="#" id="networkBarDropdown" role="button" data-bs-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
            EverOut
          </a>
          <ul class="dropdown-menu" aria-labelledby="networkBarDropdown">
            <li class="dropdown-item"><a href="/" class="nav-link">Home</a></li>
            <div class="dropdown-divider"></div>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/seattle/">
                  Seattle
                </a>
              </li>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/portland/">
                  Portland
                </a>
              </li>
            
          </ul>
        </li>
        <li class="nav-item nav-item-separator">|</li>
        
          <li class="nav-item"><a class="nav-link" href="https://www.thestranger.com">The Stranger</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.portlandmercury.com">Portland Mercury</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.savagelovecast.com">Savage Love</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://humpfilmfest.com">Hump</a></li>
          
          
        
      </ul>
    </div>
  </div>


      
    </footer>
    <script src="https://dyoeldxcrpb0a.cloudfront.net/assets/foot-5c89f2dbe5da7dbe02f9.js" ></script>
    
    
    


  
    
      <div id='EverOut-Seattle-Content-Background-58' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Background-58'); });
        </script>
      </div>
    
  

  

  

  

  

  

  

  

  


  </body>

</html>
