




<!DOCTYPE html>
<html>
  <head>
    <script>
      dataLayer = [{
        'Market': 'seattle'
      }];
    </script>
    
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MVCXDDK');</script>
<!-- End Google Tag Manager -->


    


<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=yes">
<script type="text/javascript">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</script>

<script src="https://dyoeldxcrpb0a.cloudfront.net/assets/head-202f665eda3a6303c3aa.js" ></script>
<link href="https://dyoeldxcrpb0a.cloudfront.net/assets/everout_head.e8a3724b53f4b4856be4.css" rel="stylesheet" />
<script src="https://dyoeldxcrpb0a.cloudfront.net/assets/everout_head-263de19543c61c6514ef.js" ></script>
<link rel="icon" href="https://dyoeldxcrpb0a.cloudfront.net/assets/images/everout-favicon.ico">
<script data-ad-client="ca-pub-0969663119487598" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>


  <link rel="alternate" type="application/rss+xml" title="EverOut Seattle Picks & Guides Feed" href="https://everout.com/seattle/articles/feed" />



<link rel="stylesheet" href="https://use.typekit.net/wdx1hsa.css">

<script src="https://kit.fontawesome.com/ae403a2e1f.js" crossorigin="anonymous"></script>




<meta property="og:type" content="article" />

  
    <link rel="canonical" href="https://everout.com/seattle/articles/cheap-easy-things-to-do-in-seattle-this-weekend-sept-10-12-2021/c3825/" />
    <meta property="og:url" content="https://everout.com/seattle/articles/cheap-easy-things-to-do-in-seattle-this-weekend-sept-10-12-2021/c3825/" />
  
  
  



  <title>Cheap &amp; Easy Things To Do in Seattle This Weekend: Sept 10-12, 2021 - EverOut Seattle</title>
  <meta property="og:title" content="Cheap &amp; Easy Things To Do in Seattle This Weekend: Sept 10-12, 2021 - EverOut Seattle" />
  <meta name="apple-mobile-web-app-title" content="Cheap &amp; Easy Things To Do in Seattle This Weekend: Sept 10-12, 2021 - EverOut Seattle" />



  <meta property="og:description" content="Cheap &amp; Easy Things To Do in Seattle This Weekend: Sept 10-12, 2021 - Cafe Racer Returns, Kraken Community Iceplex Opens, and More Last-Minute Events Under $15" />
  <meta name="description" content="Cheap &amp; Easy Things To Do in Seattle This Weekend: Sept 10-12, 2021 - Cafe Racer Returns, Kraken Community Iceplex Opens, and More Last-Minute Events Under $15" />


  <meta name="twitter:image" content="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzMTMwNDA2NTA4NDI1Ny1FOWFDcElYWG9BSTVjcnAuanBlZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiaW5zaWRlIiwgInBvc2l0aW9uIjogImNlbnRyZSIsICJ3aWR0aCI6IDEyMDAsICJoZWlnaHQiOiA2MzB9fX0=" />
  <meta property="og:image" content="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzMTMwNDA2NTA4NDI1Ny1FOWFDcElYWG9BSTVjcnAuanBlZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiaW5zaWRlIiwgInBvc2l0aW9uIjogImNlbnRyZSIsICJ3aWR0aCI6IDEyMDAsICJoZWlnaHQiOiA2MzB9fX0=" />

<link rel="mask-icon" href="https://dyoeldxcrpb0a.cloudfront.net/assets/images/everout-pin-icon.svg" color="#fcdc00">

  <link rel="apple-touch-icon-precomposed" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA2MCwgImhlaWdodCI6IDYwfX19" />
  <link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA3MiwgImhlaWdodCI6IDcyfX19" />
  <link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiAxMjAsICJoZWlnaHQiOiAxMjB9fX0=" />
  <link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiAxNTIsICJoZWlnaHQiOiAxNTJ9fX0=" />



  <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
  <script>
    window.googletag = window.googletag || {cmd: []};
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[1, 1]]).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Background", [[1, 1]], "EverOut-Seattle-Content-Background-58").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[970, 250], [970, 100]]).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Top", [[970, 250], [970, 100]], "EverOut-Seattle-Content-Top-56").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], [[320, 50]]).addSize([768, 0], []).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Mobile_Top", [[320, 50]], "EverOut-Seattle-Content-Mobile-Top-57").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[300, 250], [300, 600]]).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Sidebar_1", [[300, 250], [300, 600]], "EverOut-Seattle-Content-Sidebar-1-50").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], [[300, 250]]).addSize([768, 0], []).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Mobile_Inline_1", [[300, 250]], "EverOut-Seattle-Content-Mobile-Inline-1-54").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], [[300, 250]]).addSize([768, 0], []).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Mobile_Inline_2", [[300, 250]], "EverOut-Seattle-Content-Mobile-Inline-2-55").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[300, 250], [300, 600]]).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Sidebar_2", [[300, 250], [300, 600]], "EverOut-Seattle-Content-Sidebar-2-51").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[300, 250], [300, 600]]).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Sidebar_3", [[300, 250], [300, 600]], "EverOut-Seattle-Content-Sidebar-3-52").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[300, 250], [300, 600]]).build();
                    googletag.defineSlot("/1047926/EverOut_Seattle_Content_Sidebar_4", [[300, 250], [300, 600]], "EverOut-Seattle-Content-Sidebar-4-53").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
            googletag.cmd.push(function() {
                googletag.pubads().enableSingleRequest();
                googletag.pubads().setTargeting("section", ['stranger-editorial-things-to-do']);googletag.pubads().setTargeting("oid", "c3825");
                googletag.enableServices();
            });
        
  </script>


<meta property="og:site_name" content="EverOut Seattle" />
<meta name="twitter:card" content="summary_large_image" />

  
    <meta name="twitter:site" content="@thestranger" />
  
  
    <meta property="article:publisher" content="https://www.facebook.com/strangerseattle" />
  
  
    <meta property="fb:app_id" content="43933993878"/>
  
  
    <meta property="fb:admins" content="741428065"/>
  
  
    <meta property="fb:pages" content="56439755991" />
  

<meta name="cached" content="2021-09-10 18:11:09.585218">

  </head>

  <body class="everout seattle">
    
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MVCXDDK"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->


    <div class="flex-container wrapper">
      <div class="nav-stack">
        

  <div class="network-bar navbar d-none d-md-block navbar-expand-md navbar-dark bg-dark">
    <div class="container">
      <ul class="navbar-nav me-auto">
        <li class="nav-item dropdown">
          <a class="nav-link dropdown-toggle" href="#" id="networkBarDropdown" role="button" data-bs-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
            EverOut
          </a>
          <ul class="dropdown-menu" aria-labelledby="networkBarDropdown">
            <li class="dropdown-item"><a href="/" class="nav-link">Home</a></li>
            <div class="dropdown-divider"></div>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/seattle/">
                  Seattle
                </a>
              </li>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/portland/">
                  Portland
                </a>
              </li>
            
          </ul>
        </li>
        <li class="nav-item nav-item-separator">|</li>
        
          <li class="nav-item"><a class="nav-link" href="/prefunq">Prefunq</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.thestranger.com">The Stranger</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.portlandmercury.com">Portland Mercury</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.savagelovecast.com">Savage Love</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://humpfilmfest.com">Hump</a></li>
          
          
        
      </ul>
    </div>
  </div>


        



        <div id="mobileMemberNavContainer">
  <div class="mobile-member-bar mobile d-md-none collapse" id="mobileMemberNavTop">
    <div class="mobile-member-nav">
      <div class="nav-item"><a href="/settings/">Account Settings <i class="fal fa-fw fa-cog"></i></a></div>
      <div class="nav-item"><a href="/logout/">Log Out <i class="fal fa-fw fa-sign-out"></i></a></div>
    </div>
  </div>
</div>
<div class="top-nav desktop">
  <nav class="navbar">
    <div class="container">
      <div class="navbar-brand-container">
        <a class="navbar-brand d-inline-block seattle" href="/seattle/" alt="Seattle">
          
            <img src="https://d2i729k8wyri5w.cloudfront.net/market-159735153762325-everout-logo-seattle2.png" alt="EverOut Seattle">
          
        </a>
      </div>
      <div class="navbar-expand-md desktop-items-container">
        <ul class="nav collapse navbar-collapse justify-content-end nav-items main-nav">
          
            
          
            
              
                
  <li class="nav-item">
    <a href="https://everout.com/seattle/articles/" class="nav-link">Picks &amp; Guides</a>
  </li>

<li class="nav-item separator">|</li>

              
            
          
            
              
                
  <li class="nav-item dropdown">
    <a class="nav-link dropdown-toggle" href="#" id="itemDropdown-878" role="button" data-bs-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
      Neighborhoods
    </a>
    <ul class="dropdown-menu dropdown-menu-right" aria-labelledby="itemDropdown-878">
      
        
          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/ballard/">
    
    
      Ballard
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/belltown/">
    
    
      Belltown
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/capitol-hill/">
    
    
      Capitol Hill
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/central-district/">
    
    
      Central District
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/chinatown-id/">
    
    
      Chinatown-International District
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/columbia-city-beacon-hill/">
    
    
      Columbia City/Beacon Hill
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/downtown/">
    
    
      Downtown
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/fremont/">
    
    
      Fremont
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/phinney-green-lake/">
    
    
      Phinney Ridge/Green Lake
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/pioneer-square/">
    
    
      Pioneer Square
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/queen-anne/">
    
    
      Queen Anne
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/sodo-georgetown/">
    
    
      Sodo/Georgetown
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/south-lake-union/">
    
    
      South Lake Union
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/university-district/">
    
    
      University District
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/west-seattle/">
    
    
      West Seattle/White Center
    
  </a>
</li>

          
        
      
    </ul>
  </li>

<li class="nav-item separator">|</li>

              
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
              
                
  <li class="nav-item dropdown">
    <a class="nav-link dropdown-toggle" href="#" id="itemDropdown-876" role="button" data-bs-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
      Calendars
    </a>
    <ul class="dropdown-menu dropdown-menu-right" aria-labelledby="itemDropdown-876">
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/stranger-seattle/events/?type=in-person">
    
    
      In-Person Events
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?category=music&amp;type=in-person">
    
    
      Live Music
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?category=food-drink">
    
    
      Food & Drink
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?category=readings-talks">
    
    
      Readings & Talks
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/visual-art/">
    
    
      Visual Art
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?category=performance">
    
    
      Theater & Performance
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/film/">
    
    
      Film
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?category=resistance">
    
    
      Activism & Social Justice
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/locations/?category=restaurants">
    
    
      Restaurants
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="/seattle/events">
    
    
      All Events
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/stranger-seattle/events/?category=livestreamed">
    
    
      Online Events
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?category=restaurants&amp;feature=takeout-covid-19&amp;feature=delivery-covid-19&amp;feature=curbside-pickup&amp;feature=walk-up-ordering">
    
    
      Takeout & Delivery
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?feature=in-person-visits">
    
    
      Now-Open Shops & Attractions
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?category=weed-locations&amp;feature=takeout-covid-19">
    
    
      Weed Locations
    
  </a>
</li>

        
      
    </ul>
  </li>



              
            
          
          <li class="nav-item dropdown member-nav" id="desktopMemberNav">
            
          </li>
        </ul>
      </div>
      <ul class="nav mobile nav-items main-nav d-md-none mt-2">
        
          
        
          
            
              
  <li class="nav-item">
    <a href="https://everout.com/seattle/articles/" class="nav-link">Picks &amp; Guides</a>
  </li>

<li class="nav-item separator">|</li>

            
          
        
          
            
              
  <li class="nav-item menu-toggler" data-bs-toggle="collapse" data-bs-target="#navbarToggle-878" aria-controls="navbarToggle-878" aria-expanded="false" aria-label="Toggle navigation">
    <a href="#" class="nav-link" onclick="return false;">Neighborhoods <i class="fa fa-caret-down"></i></a>
  </li>

<li class="nav-item separator">|</li>

            
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
            
              
  <li class="nav-item menu-toggler" data-bs-toggle="collapse" data-bs-target="#navbarToggle-876" aria-controls="navbarToggle-876" aria-expanded="false" aria-label="Toggle navigation">
    <a href="#" class="nav-link" onclick="return false;">Calendars <i class="fa fa-caret-down"></i></a>
  </li>



            
          
        
      </ul>
      <div class="member-nav d-md-none text-end" id="mobileAvatarContainer">
        
      </div>
      
        
          

        
      
        
          

        
      
        
          
  <div class="collapse navbar-collapse nav-items mobile d-md-none" id="navbarToggle-878">
    <div class="more-nav">
      
        
          
            <div class="nav-item   class-change ">
  <a href="/seattle/neighborhoods/ballard/">
    
    
      Ballard
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/belltown/">
    
    
      Belltown
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/capitol-hill/">
    
    
      Capitol Hill
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/central-district/">
    
    
      Central District
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/chinatown-id/">
    
    
      Chinatown-International District
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/columbia-city-beacon-hill/">
    
    
      Columbia City/Beacon Hill
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/downtown/">
    
    
      Downtown
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/fremont/">
    
    
      Fremont
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/phinney-green-lake/">
    
    
      Phinney Ridge/Green Lake
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/pioneer-square/">
    
    
      Pioneer Square
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/queen-anne/">
    
    
      Queen Anne
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/sodo-georgetown/">
    
    
      Sodo/Georgetown
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/south-lake-union/">
    
    
      South Lake Union
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/university-district/">
    
    
      University District
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/west-seattle/">
    
    
      West Seattle/White Center
    
  </a>
</div>

          
        
      
    </div>
  </div>


        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
        
      
        
          
  <div class="collapse navbar-collapse nav-items mobile d-md-none" id="navbarToggle-876">
    <div class="more-nav">
      
        
          <div class="nav-item   class-change ">
  <a href="https://everout.com/stranger-seattle/events/?type=in-person">
    
    
      In-Person Events
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?category=music&amp;type=in-person">
    
    
      Live Music
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?category=food-drink">
    
    
      Food & Drink
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?category=readings-talks">
    
    
      Readings & Talks
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/visual-art/">
    
    
      Visual Art
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?category=performance">
    
    
      Theater & Performance
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/film/">
    
    
      Film
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?category=resistance">
    
    
      Activism & Social Justice
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/locations/?category=restaurants">
    
    
      Restaurants
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="/seattle/events">
    
    
      All Events
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/stranger-seattle/events/?category=livestreamed">
    
    
      Online Events
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?category=restaurants&amp;feature=takeout-covid-19&amp;feature=delivery-covid-19&amp;feature=curbside-pickup&amp;feature=walk-up-ordering">
    
    
      Takeout & Delivery
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?feature=in-person-visits">
    
    
      Now-Open Shops & Attractions
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?category=weed-locations&amp;feature=takeout-covid-19">
    
    
      Weed Locations
    
  </a>
</div>

        
      
    </div>
  </div>


        
      
      <script type="text/javascript">
        // ajax to reload the nav if you're logged in
        function getMemberMenu() {
          xhr = new XMLHttpRequest();
          xhr.open('GET', `/members/menu/`);
          xhr.setRequestHeader('Content-Type', 'application/json');
          xhr.onload = function () {
            if (xhr.responseText) {
              response = JSON.parse(xhr.responseText);
              if (response.id) {
                let avatar = (response.avatar) ? `<img src="${response.avatar}" class="nav-avatar">` : `<i class="fa fa-user-circle"></i>`
                $('#desktopMemberNav').html(
                  `
                    <a href="#" class="member-profile-link" data-bs-toggle="dropdown" role="button" id="memberDropdownLink">${avatar}</a>
                    <ul class="dropdown-menu" aria-labelledby="memberDropdownLink" style="z-index:9999;top:86%;">
                      <li class="dropdown-item"><a href="/settings/">Account Settings</a></li>
                      <li class="dropdown-item"><a href="/logout/">Log Out</a></li>
                    </ul>
                  `
                );
                $('#mobileAvatarContainer').html(
                  `
                    <a href="#" onclick="return false;" data-bs-toggle="collapse" data-bs-target="#mobileMemberNavTop" aria-controls="mobileMemberNavTop" aria-expanded="false" aria-lable="Toggle member navigation" id="memberDropdownLink">${avatar}</a>
                  `
                )
              }
            }
          };
          xhr.send();
        }
        getMemberMenu();
      </script>
    </div>
  </nav>
</div>

        <div class="standalone-search-bar">
  <div class="search-container container" id="siteSearch">
    <span class="search-bar-label">Show Me</span>
    <input class="typeahead" type="text" placeholder="events, movies, venues, restaurants, guides..." data-sort-group="" data-site-section="">
    <i class="search-icon far fa-search"></i>

    <div role="listbox" class="default-search-panel p-3" style="display: none;" aria-expanded="false">
      <div role="presentation" class="row">
        <i class="loading-spinner fas fa-spinner fa-spin p-3"></i>
        <div class="col-6 col-sm-4 category-list">
        </div>
        <div class="col-6 col-sm-8 article-list">
        </div>
      </div>
    </div>
  </div>

  <script>
    $('.search-container .search-icon').on('click', function() {
      var market_slug = 'seattle';
      var search_value = $('.tt-input').val()
      if (search_value) {
        if (market_slug !== '') {
          window.location.href = '/' + market_slug + '/search?q=' + encodeURIComponent(search_value);
        } else {
          window.location.href = '/search?q=' + encodeURIComponent(search_value);
        }
      }
    })
  </script>
</div>

        
  <div class="trending-stories-bar">
    <div class="container">
      <div class="row g-0">
        <div class="col-md-auto d-none d-md-block">
          <div class="trending-stories-item indicator me-2"><i class="fad fa-branded fa-chevron-double-right"></i><i class="fad fa-branded fa-chevron-double-right"></i></div>
        </div>
        
          <div class="col-auto mb-2 mb-md-0">
            <a class="trending-stories-item me-2" href="https://everout.com/seattle/events/?category=music&amp;type=in-person">🎶 Live Music</a>
          </div>
        
          <div class="col-auto mb-2 mb-md-0">
            <a class="trending-stories-item me-2" href="https://everout.com/seattle/neighborhoods/">📍 Neighborhoods</a>
          </div>
        
          <div class="col-auto mb-2 mb-md-0">
            <a class="trending-stories-item me-2" href="https://everout.com/seattle/articles/your-guide-to-september-2021-events-in-seattle/c3800/">📅 September Event Guide</a>
          </div>
        
          <div class="col-auto mb-2 mb-md-0">
            <a class="trending-stories-item me-2" href="https://everout.com/seattle/food/">🍔 Food &amp; Drink Guide</a>
          </div>
        
          <div class="col-auto mb-2 mb-md-0">
            <a class="trending-stories-item me-2" href="https://everout.com/seattle/summer/">🍻 Oktoberfest</a>
          </div>
        
      </div>
    </div>
  </div>


        
      </div>

      <div class="top-super text-center container">
        


  

  
    
      <div id='EverOut-Seattle-Content-Top-56' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Top-56'); });
        </script>
      </div>
    
  

  
    
      <div id='EverOut-Seattle-Content-Mobile-Top-57' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Mobile-Top-57'); });
        </script>
      </div>
    
  

  

  

  

  

  

  


      </div>

      <div class="container main-container">
        <div class="row main">
          
          <div class="col-md-8 primary">
            <header>
              
  <div class="row">
  <div id="breadcrumbs" class="col-sm-12 ttd-breadcrumbs">
    
      <a href="/seattle/">Seattle</a>
    
    <span class="breadcrumb-delimiter">&gt;</span>
    
      
        <a href="/seattle/articles/" class="">Picks &amp; Guides</a>
      
      
    
  </div>
</div>


            </header>

            <div class="content">
              
  <div class="item-detail article">
    <article>
      
      <header class="mb-2">
        
          
            <a class="category-tag" href="/seattle/articles/?category=cheap-easy">Cheap & Easy</a>
          
        
        <h1>
          Cheap & Easy Things To Do in Seattle This Weekend: Sept 10-12, 2021
        </h1>
        <div class="subhead">
          <span style="font-weight: 400;">Cafe Racer Returns, Kraken Community Iceplex Opens, and More Last-Minute Events Under $15</span>
        </div>
        
          <div class="author">
            by <a href="https://everout.com/seattle/authors/chase-hutchinson/w175/">Chase Hutchinson</a>
          </div>
        
        
          <div class="published-date">
            September 10, 2021
          </div>
        
        
        

<div class="share-tools border-top border-bottom  ">
  <span class="share-tools-label pe-2" class="pe-2">Share</span>
  <div class="facebook-this share-tool">
    <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A//everout.com/articles/cheap-easy-things-to-do-in-seattle-this-weekend-sept-10-12-2021/c3825/" class="share-link new-window" target="_blank"><i class="fab fa-facebook pe-2"></i></a>
</div>

  <div class="tweet-this share-tool">
    <a href="https://twitter.com/intent/tweet?text=Cheap%20%26%20Easy%20Things%20To%20Do%20in%20Seattle%20This%20Weekend%3A%20Sept%2010-12%2C%202021%2C%20from%20EverOut%20https%3A//everout.com/articles/cheap-easy-things-to-do-in-seattle-this-weekend-sept-10-12-2021/c3825/" class="share-link new-window" target="_blank"><i class="fab fa-twitter pe-2"></i></a>
</div>

  <div class="mail-this share-tool">
    <a href="mailto:?subject=Cheap%20%26%20Easy%20Things%20To%20Do%20in%20Seattle%20This%20Weekend%3A%20Sept%2010-12%2C%202021%2C%20from%20EverOut&body=Cheap%20%26%20Easy%20Things%20To%20Do%20in%20Seattle%20This%20Weekend%3A%20Sept%2010-12%2C%202021%2C%20from%20EverOut%20https%3A//everout.com/articles/cheap-easy-things-to-do-in-seattle-this-weekend-sept-10-12-2021/c3825/"><i class="fas fa-envelope"></i></a>
</div>

</div>

      </header>
      
        <div class="lead-image my-3">
          <img class="img-responsive" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzMTMwNDA2NTA4NDI1Ny1FOWFDcElYWG9BSTVjcnAuanBlZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiaW5zaWRlIiwgInBvc2l0aW9uIjogImNlbnRyZSIsICJ3aWR0aCI6IDEwMjQsICJoZWlnaHQiOiA4MDB9fX0= ">
          
            <div class="caption">
              The <a href="https://everout.com/seattle/events/kraken-venue-opening-celebration/e103582/" target="_blank" rel="noopener">Kraken Community Iceplex is opening its doors</a> to hockey fans with events throughout the weekend.
              
            </div>
          
        </div>
      
      <div class="body-text">
        
          
            
              <p><span style="font-weight: 400;">Even as the weekend looks like it will be a bit cooler, hinting that fall is just around the corner, there are still some hot events to commemorate the waning days of summer. Celebrate the long-awaited return of</span><a href="https://everout.com/seattle/events/cafe-racer-grand-opening/e103396/"><span style="font-weight: 400;"> </span><span style="font-weight: 400;">Caf&eacute; Racer</span></a><strong>, </strong><span style="font-weight: 400;">which will hopefully </span><a href="https://www.thestranger.com/slog/2021/09/09/61089030/reborn-on-capitol-hill-cafe-racer-seeks-to-give-local-musicians-a-booster-shot"><span style="font-weight: 400;">give the local music scene a much needed boost</span></a><span style="font-weight: 400;">, or break the ice at another new venue&mdash;the Seattle Kraken Community Iceplex is opening its doors to the public for all things hockey.&nbsp; </span></p>
            
          
            
              
<hr />
<p><small>Jump to: <a href="#friday">Friday</a> | <a href="#saturday">Saturday</a> | <a href="#sunday">Sunday</a></small></p>
            
          
            
              
<hr />
<h3 id="&ldquo;friday&rdquo;"><strong>FRIDAY</strong></h3>
<p><strong>MUSIC</strong></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/electric-six/e101850/" target="_blank" rel="noopener"><strong>Electric Six</strong></a><br /><span style="font-weight: 400;">The American rock band Electric Six is described as a combination of garage, disco, punk rock, new wave, and metal, giving audiences a genre-defying performance with support from Me Like Bees, Detonator, and Ball Bag</span>.<br /><em>El Coraz&oacute;n, Eastlake ($15)</em></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/yeti-set-go/e101852/" target="_blank" rel="noopener"><strong>Yeti Set Go</strong></a><br /><span style="font-weight: 400;">A Seattle psychedelic rock trio known for their sense of humor in their music, Yeti Set Go promises that you will "be glad that you left your overpriced studio apartment to enjoy live music the way it was meant to be enjoyed."</span><br /><em>The Funhouse, Belltown</em> ($8)</p>
            
          
            
              
<p><strong>QUEER</strong></p>
            
          
            
              

<div class="fish-butter article-inline" data-spot="everout-editorial" data-context-oid="" data-ad-oid="" style="display:none;">
  
    <div class="fish-tag">
      Sponsored
    </div>
  
  <div class="fish-container">
    <div class="fish-image">
      
    </div>
    <div class="fish-body">
      <h1>
        
      </h1>
      <p>
        
      </p>
    </div>
  </div>
</div>

            
          
            
              
<p><a href="https://everout.com/seattle/events/queer-me-out/e103635/" target="_blank" rel="noopener"><strong>Queer Me Out</strong></a><br /><span style="font-weight: 400;">This panel discussion is centered around the queer community and how it connects to everything from fashion to media and politics. Panelists include Big Freedia, Gayshia Starr, Monseratt Padilla, Daddy Issues and Lee Williams. </span><br /><em>W Seattle, Downtown (free)</em></p>
            
          
            
              
<h3><strong>FRIDAY &amp; SATURDAY</strong></h3>
<p><strong>VISUAL ARTS</strong></p>
            
          
            
              
<p><strong><a href="https://everout.com/seattle/events/in-here/e103168/">In here</a></strong><br /><span style="font-weight: 400;">Have you ever noticed how a room gradually takes on different characteristics as you spend more time in it? This group show explores our subjective experiences of spaces with work by Molly Magai, Tessa O&rsquo;Brien, Emil Robinson, Gail Spaien, and Jay Stern.</span><br /><em>studio e, Georgetown (free)</em></p>
            
          
            
              
<p><strong><a href="https://everout.com/seattle/events/phinneywood-art-walk-the-big-one/e103589/" target="_blank" rel="noopener">PhinneyWood Art Walk: The BIG One</a><br /></strong><strong><span style="font-weight: 400;">The annual PhinneyWood art walk is back, featuring art in neighborhood businesses. Taking place across several blocks, you can stop by Phinney Books, Ken's Market, and more. </span><br /></strong><em>Phinney and Greenwood (free)</em></p>
            
          
            
              
<p><strong>MUSIC</strong></p>
            
          
            
              


  

  

  

  

  
    
      <div id='EverOut-Seattle-Content-Mobile-Inline-1-54' class="mb-3 text-center ad-placement inline-ad">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Mobile-Inline-1-54'); });
        </script>
      </div>
    
  

  

  

  

  


            
          
            
              
<p><strong><a href="https://everout.com/seattle/events/patio-season/e103653/">Patio Season</a><br /></strong><span style="font-weight: 400;">The opportunity to see local DJs taking to the Timbre Room Patio is fast coming to a close. On Friday, you can see Aquaphina, Gold Chisme, and Jaderade's Hip Hop BBQ. Then on Saturday, the season comes to a close with MattG, Mike Devlin, and Trevor Little.</span><br /><em>Timbre Room, Belltown (free-$5)</em></p>
            
          
            
              
<p><strong>COMEDY</strong></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/dustin-nickerson/e102469/" target="_blank" rel="noopener"><strong>Dustin Nickerson</strong></a><br /><span style="font-weight: 400;">Seattle-born comedian Dustin Nickerson is coming home from the hells of Southern California both to do a couple of shows and also get a glass of water. </span><br /><em>Laughs Comedy Club, Totem Lake ($15)</em></p>
            
          
            
              
<h3><strong>FRIDAY-SUNDAY</strong></h3>
<p><strong>SPORTS &amp; RECREATION</strong></p>
            
          
            
              
<p><strong><a href="https://everout.com/seattle/events/kraken-venue-opening-celebration/e103582/">Kraken Community Iceplex Opening Celebration</a><br /></strong><span style="font-weight: 400;">The time is almost here for hockey in Seattle, and that means the Kraken Community Iceplex is opening their doors to the public for the first time. This family-friendly event will boost excitement for the new team through public skate sessions, stick &amp; puck, and much more.</span><br /><em>Kraken Community Iceplex, Northgate </em><em>(free)</em></p>
            
          
            
              
<p><strong>FILM</strong></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/the-maltese-falcon-the-big-lebowski/e103627/" target="_blank" rel="noopener"><strong>The Maltese Falcon &amp; The Big Lebowski</strong></a><br /><span style="font-weight: 400;">A double feature opportunity featuring two vastly different noir characters, this film series by Central Cinema is some unique programming. Though that's just my opinion man. </span><br /><em>Central Cinema, Central District ($8-12)</em></p>
            
          
            
              
<p><strong>VISUAL ART</strong></p>
            
          
            
              
<p><strong><a href="https://everout.com/seattle/events/field-of-play/e103164/">Field of Play</a><br /></strong><span style="font-weight: 400;">An exhibit of photos by Stephan Jahanshahi that captures the amateur rugby world, this debut solo project showcases "portraits of the athletes who devote themselves to rugby for love of the game and the community it fosters."</span><br /><em>Gallery 110, Pioneer Square (free)</em></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/jim-hodges-selected-work/e103148/"><strong>Jim Hodges: Selected Work</strong></a><em><br /></em><span style="font-weight: 400;">Work from Spokane artist Jim Hodges will be on display throughout the month. He has shown in galleries throughout the world and is praised for his "approach to capturing experience through such diverse media as collage, light, and reflection."</span><em><br />Greg Kucera Gallery, Pioneer Square (free)</em></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/z-z-wei-new-works/e103159/"><strong>Z.Z. Wei: New Works</strong></a><em><br /></em>The 29th annual exhibit (impressive!) from artist Z.Z. Wei at this local gallery shows paintings that were made "in the face of an ongoing global crisis" and is entitled&nbsp;Rough Road. It "speaks to the difficulties in keeping the inner spirit nourished, the creative process churning and the artistic fires burning."<em><br />Patricia Rovzar Gallery, Downtown (free)</em></p>
            
          
            
              


  

  

  

  

  

  
    
      <div id='EverOut-Seattle-Content-Mobile-Inline-2-55' class="mb-3 text-center ad-placement inline-ad">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Mobile-Inline-2-55'); });
        </script>
      </div>
    
  

  

  

  


            
          
            
              
<p><a href="https://everout.com/seattle/events/mance-engine-gifts-of-distraction/e103154/" target="_blank" rel="noopener"><strong>Mance Engine: Gifts of Distraction</strong></a><br /><span style="font-weight: 400;">It's natural to want to scrape hidden meanings from works of art, but this series challenges the viewer to take the sculptural curiosities, assemblages, modified ready-mades, and collages at face value. </span><br /><em>BONFIRE, Chinatown-International District (free)</em></p>
            
          
            
              
<p><strong>FAIR</strong></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/washington-state-fair/e103625/" target="_blank" rel="noopener"><strong>Washington State Fair</strong></a><br /><span style="font-weight: 400;">If you haven't checked out the biggest fair in the state, now is your chance to do it. Friday night will bring an explosive fireworks display and there will be litany of animal events to check out throughout the weekend.</span><br /><em>Washington State Fair Events Center, Puyallup ($11-$16)</em></p>
            
          
            
              
<h3 id="&ldquo;saturday&rdquo;"><strong>SATURDAY</strong></h3>
<p><strong>FOOD &amp; DRINK</strong></p>
            
          
            
              
<p><strong><a href="https://everout.com/seattle/events/in-store-event-bake-away-by-sahana-vij/e103583/" target="_blank" rel="noopener">In Store Event: Bake Away by Sahana Vij</a><br /></strong><span style="font-weight: 400;">Teen author and baker Sahana Vij will discuss her new book </span><em><span style="font-weight: 400;">Bake Away</span></em><span style="font-weight: 400;">, sign copies, and demonstrate a recipe. 100% of the author royalties from book sales will be donated to No Kid Hungry.</span><br /><em>Book Larder, Fremont (free)</em></p>
            
          
            
              
<p><strong><a href="https://everout.com/seattle/events/cafe-racer-grand-opening/e103396/">Caf&eacute; Racer Grand Opening</a><br /></strong><span style="font-weight: 400;">Drink, dance, and celebrate</span><a href="https://www.thestranger.com/slog/2021/09/09/61089030/reborn-on-capitol-hill-cafe-racer-seeks-to-give-local-musicians-a-booster-shot"><span style="font-weight: 400;"> </span><span style="font-weight: 400;">at the highly anticipated grand opening</span></a><span style="font-weight: 400;"> of the new Caf&eacute; Racer in Capitol Hill. Entertainment will be provided by</span><a href="https://www.youtube.com/watch?v=5tp1nv4hvsE"><span style="font-weight: 400;"> Velvet Q</span></a><span style="font-weight: 400;">, </span><a href="https://www.youtube.com/watch?v=0VjmW5k9nKY"><span style="font-weight: 400;">Taylar Elizza Beth</span></a><span style="font-weight: 400;">, </span><a href="https://moroccandog.bandcamp.com/album/moroccan-dog"><span style="font-weight: 400;">Moroccan Dog</span></a><span style="font-weight: 400;">, </span><a href="https://mtfog.bandcamp.com/album/guide-to-the-unusual"><span style="font-weight: 400;">Mt Fog</span></a><span style="font-weight: 400;"> and </span><a href="https://www.facebook.com/djmarvelette/"><span style="font-weight: 400;">DJ Marvelette</span></a><span style="font-weight: 400;">.</span><br /><em>Caf&eacute; Racer, Capitol Hill ($5-$12)</em></p>
            
          
            
              
<p><strong>FILM</strong></p>
            
          
            
              
<p><strong><a href="https://everout.com/seattle/events/black-summer-camp/e102946/">Black Summer Camp</a></strong><br /><span style="font-weight: 400;">Join Sankofa Film Society every Saturday for outdoor screenings of movies centering the Black American experience. &ldquo;Some of these films are campy, some of these films are silly, some of these films pack a punch, but all of these films are about the Black experience,&rdquo; writes Sankofa co-founder Karen Toering. &ldquo;We just picked the films we love. The films we know that afterwards&mdash;or even during&mdash;folks will want to talk about.&rdquo;</span> John Berry's classic <em>Claudine </em>will be screened this week.<br /><em>El Centro de la Raza, Beacon Hill (free)</em></p>
            
          
            
              
<p><strong>VISUAL ART</strong></p>
            
          
            
              
<p style="text-align: left;"><a href="https://everout.com/seattle/events/arts-a-glow-2021/e103423/"><strong>Arts-A-Glow 2021</strong></a><em><br /></em>An art walk with a twist, you can head to Downtown Burien to "discover light installations and murals, visit a new night market and multiple museums, find art in businesses and yarn covered trees with the B-Town Beat, and more!" Attendees are also encouraged to dress in costume if you're into that sort of thing.<br /><em>Downtown Burien (free)</em></p>
            
          
            
              
<h3><strong>SATURDAY-SUNDAY</strong></h3>
<p><strong>VISUAL ART</strong></p>
            
          
            
              
<p><strong><a href="https://everout.com/seattle/events/recent-acquisitions-in-contemporary-art/e103130/">Recent Acquisitions in Contemporary Art</a></strong><br /><span style="font-weight: 400;">Seven recent artworks by Juventino Aranda, Rokni Haerizadeh, Rose Nestler, Mary Ann Peters, Cauleen Smith, Anthony White, and Ko Kirk Yamahira&mdash;all acquired by the museum in 2019&mdash;will finally get their spotlight.</span><br /><em>Frye Art Museum, First Hill (free)</em></p>
            
          
            
              
<h3 id="sunday">SUNDAY</h3>
<p><strong>MUSIC</strong></p>
            
          
            
              
<p><strong><a href="https://everout.com/seattle/events/seattle-center-festal-presents-music-at-the-mural/e103397/">Seattle Center Fest&aacute;l presents Music at the Mural</a></strong><br /><span style="font-weight: 400;">Shake your booty or chill out on the lawn at the last week of this free outdoor concert series presented by Seattle Center Fest&aacute;l. The Djeliyah Band featuring Kouyat&eacute; Arts will perform, fusing together traditional Griot music with Afro beat and modern Guinea music. </span><br /><em>Mural Amphitheatre, Uptown (free)</em></p>
            
          
            
              </p>
            
          
            
              

<div class="fish-butter article-inline" data-spot="everout-editorial" data-context-oid="" data-ad-oid="" style="display:none;">
  
    <div class="fish-tag">
      Sponsored
    </div>
  
  <div class="fish-container">
    <div class="fish-image">
      
    </div>
    <div class="fish-body">
      <h1>
        
      </h1>
      <p>
        
      </p>
    </div>
  </div>
</div>

            
          
        
      </div>
    </article>
    

<div class="share-tools border-top border-bottom d-block text-end">
  <span class="share-tools-label pe-2" class="pe-2">Share</span>
  <div class="facebook-this share-tool">
    <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A//everout.com/articles/cheap-easy-things-to-do-in-seattle-this-weekend-sept-10-12-2021/c3825/" class="share-link new-window" target="_blank"><i class="fab fa-facebook pe-2"></i></a>
</div>

  <div class="tweet-this share-tool">
    <a href="https://twitter.com/intent/tweet?text=Cheap%20%26%20Easy%20Things%20To%20Do%20in%20Seattle%20This%20Weekend%3A%20Sept%2010-12%2C%202021%2C%20from%20EverOut%20https%3A//everout.com/articles/cheap-easy-things-to-do-in-seattle-this-weekend-sept-10-12-2021/c3825/" class="share-link new-window" target="_blank"><i class="fab fa-twitter pe-2"></i></a>
</div>

  <div class="mail-this share-tool">
    <a href="mailto:?subject=Cheap%20%26%20Easy%20Things%20To%20Do%20in%20Seattle%20This%20Weekend%3A%20Sept%2010-12%2C%202021%2C%20from%20EverOut&body=Cheap%20%26%20Easy%20Things%20To%20Do%20in%20Seattle%20This%20Weekend%3A%20Sept%2010-12%2C%202021%2C%20from%20EverOut%20https%3A//everout.com/articles/cheap-easy-things-to-do-in-seattle-this-weekend-sept-10-12-2021/c3825/"><i class="fas fa-envelope"></i></a>
</div>

</div>

    
      


  <div class="related-articles border-top mt-4 pt-2">
    <h2 class="pt-4 mb-2 section-header highlighted">You Might Also Like</h2>
    <div class="row row-cols-2 row-cols-md-3 no-gutters">
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/cheap-easy-things-to-do-in-seattle-this-weekend-sept-10-12-2021/c3825/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzMTMwNDA2NTA4NDI1Ny1FOWFDcElYWG9BSTVjcnAuanBlZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY292ZXIiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogNDAwLCAiaGVpZ2h0IjogMzAwfX19"></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/cheap-easy-things-to-do-in-seattle-this-weekend-sept-10-12-2021/c3825/">Cheap & Easy Things To Do in Seattle This Weekend: Sept 10-12, 2021</a>
              </div>
              
                <h6 class="card-subtitle mb-2">Cafe Racer Returns, Kraken Community Iceplex Opens, and More Last-Minute Events Under $15</h6>
              
            </div>
          </div>
        </div>
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/this-week-in-seattle-food-news-former-canlis-chef-opens-tomo-cafe-racer-returns-and-kricket-club-is-coming-to-ravenna/c3824/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzMTMxMTUxNDg2ODY1OC1TY3JlZW5fU2hvdF8yMDIxLTA5LTEwX2F0XzMuMDMuMThfUE0ucG5nIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJjb3ZlciIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA0MDAsICJoZWlnaHQiOiAzMDB9fX0="></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/this-week-in-seattle-food-news-former-canlis-chef-opens-tomo-cafe-racer-returns-and-kricket-club-is-coming-to-ravenna/c3824/">This Week in Seattle Food News: Former Canlis Chef Opens Tomo, Cafe Racer Returns, and Kricket Club is Coming to Ravenna</a>
              </div>
              
                <h6 class="card-subtitle mb-2">September 10, 2021 Edition</h6>
              
            </div>
          </div>
        </div>
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/this-week-in-seattle-event-news-coldplay-imagine-dragons-and-more/c3820/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzMTIwODAwMTE1ODgzOS1MaXZlX05hdGlvbl9FbnRlcnRhaW5tZW50X19fQ29sZHBsYXkuanBlZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY292ZXIiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogNDAwLCAiaGVpZ2h0IjogMzAwfX19"></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/this-week-in-seattle-event-news-coldplay-imagine-dragons-and-more/c3820/">This Week in Seattle Event News: Coldplay, Imagine Dragons, and More</a>
              </div>
              
                <h6 class="card-subtitle mb-2">Ticket and Info Alerts for the Week of September 6, 2021</h6>
              
            </div>
          </div>
        </div>
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/where-to-celebrate-oktoberfest-2021-in-seattle/c3814/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzMTA1NTM2OTI1MjQ5OS1TY3JlZW5fU2hvdF8yMDIxLTA5LTA3X2F0XzMuNTUuMTJfUE0ucG5nIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJjb3ZlciIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA0MDAsICJoZWlnaHQiOiAzMDB9fX0="></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/where-to-celebrate-oktoberfest-2021-in-seattle/c3814/">Where to Celebrate Oktoberfest 2021 in Seattle</a>
              </div>
              
                <h6 class="card-subtitle mb-2">Biers, Pretzels, and More</h6>
              
            </div>
          </div>
        </div>
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/the-best-things-to-do-in-seattle-this-week-sept-7-12-2021/c3813/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzMTA1NjEwOTAxOTc1NS1tc3Bha21hbi5qcGciLCAiZWRpdHMiOiB7InJlc2l6ZSI6IHsiZml0IjogImNvdmVyIiwgInBvc2l0aW9uIjogImNlbnRyZSIsICJ3aWR0aCI6IDQwMCwgImhlaWdodCI6IDMwMH19fQ=="></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/the-best-things-to-do-in-seattle-this-week-sept-7-12-2021/c3813/">The Best Things To Do in Seattle This Week: Sept 7-12, 2021</a>
              </div>
              
                <h6 class="card-subtitle mb-2">Tinder Live, Tame Impala, Ms. Pak-Man, and More</h6>
              
            </div>
          </div>
        </div>
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/this-week-in-seattle-food-news-bale-breaker-x-yonder-taproom-opens-beths-cafe-closes-for-now-and-chucks-hop-shop-announces-a-third-location/c3811/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYzMDcwODAzODg5MDk3NS1iYWxlX2JyZWFrZXJfeF95b25kZXIuanBlZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY292ZXIiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogNDAwLCAiaGVpZ2h0IjogMzAwfX19"></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/this-week-in-seattle-food-news-bale-breaker-x-yonder-taproom-opens-beths-cafe-closes-for-now-and-chucks-hop-shop-announces-a-third-location/c3811/">This Week in Seattle Food News: Bale Breaker x Yonder Taproom Opens, Beth's Cafe Closes For Now, and Chuck's Hop Shop Announces a Third Location</a>
              </div>
              
                <h6 class="card-subtitle mb-2">September 3, 2021 Edition</h6>
              
            </div>
          </div>
        </div>
      
    </div>
  </div>


    
  </div>

            </div>
          </div>
          <div class="col-md-4 secondary">
            
  <div id="adSpaceSidebarModule" class="adspace sidebar-module sidebar-module-inset">
  


  

  

  

  
    
      <div id='EverOut-Seattle-Content-Sidebar-1-50' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Sidebar-1-50'); });
        </script>
      </div>
    
  

  

  

  
    
      <div id='EverOut-Seattle-Content-Sidebar-2-51' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Sidebar-2-51'); });
        </script>
      </div>
    
  

  
    
      <div id='EverOut-Seattle-Content-Sidebar-3-52' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Sidebar-3-52'); });
        </script>
      </div>
    
  

  
    
      <div id='EverOut-Seattle-Content-Sidebar-4-53' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Sidebar-4-53'); });
        </script>
      </div>
    
  


</div>


          </div>
          
        </div>
      </div>
    </div>
    <footer class="mt-4">
      <div class="site-footer">
  <!-- desktop footer -->
  <div class="d-none d-md-block">
    <div class="footer-top-block">
  <div class="container">
    
      

<div class="component email-sign-up ">
  <div class="container text-center">
    
      <h1>Subscribe to our Newsletter</h1>
    
    
      <div class="copy">
        <p>Seattle is reopening! Sign up to get the latest updates on things to do, delivered to you four times a week.</p>
      </div>
    
    <form id="mc-embedded-subscribe-form" class="form" action="https://everout.us4.list-manage.com/subscribe/post?u=d7708ba310556d83ed7895c57&amp;id=01ccd644f5" method="post" name="" target="_blank">
      <div class="row g-3 align-items-center">
        <div class="col-md-8 offset-md-1"><input class="form-control mb-2 me-sm-2 email-input" name="EMAIL" type="email" placeholder="Email Address" /></div>
        
          
            <input type="hidden" value="1" name="group[71361][1]">
          
        
        <div class="col-md-2"><button class="btn btn-primary mb-2 submit-button" style="width:100%;" type="submit">Sign Up</button></div>
        <div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_d7708ba310556d83ed7895c57_01ccd644f5" type="text" value="" /></div>
      </div>
      <script>
        function setCityValue() {
          if ($('#citySelect').val() == 'seattle') {
            $('#citySelectValue').attr('name', 'group[71361][1]');
            $('#citySelectValue').val(1);
          } else if ($('#citySelect').val() == 'portland') {
            $('#citySelectValue').attr('name', 'group[71361][2]');
            $('#citySelectValue').val(2);
          }
        }
        $(function () {
          setCityValue();
        });
      </script>
    </form>
  </div>
</div>

    
    
      <div class="footer-row row">
        <div class="col-md">
          <div class="col-sm text-center">
            <div class="footer-social-links mt-0">
              <h2>Follow Us</h2>
              
                <a href="http://www.facebook.com/everoutseattle" target="_blank"><i class="fab fa-facebook-f"></i></a>
              
                <a href="https://www.twitter.com/everoutseattle" target="_blank"><i class="fab fa-twitter"></i></a>
              
                <a href="https://instagram.com/everoutfood" target="_blank"><i class="fab fa-instagram"></i></a>
              
            </div>
          </div>
        </div>
      </div>
    
  </div>
</div>
<div class="footer-bottom-block">
  <div class="container">
    <div class="footer-row row">
      <div class="col-md">
        <div class="footer-brand">
  <a class="navbar-brand" href="https://everout.com/seattle/"><img src="/assets/images/everout-logo-yellow.png" alt="EverOut"></a>
</div>

      </div>
      <div class="col-md-8">
        
          <p class="footer-links text-end pipe-delimited-links">
            
              <span><a href="/about/">About</a></span>
            
              <span><a href="/contact-us/">Contact</a></span>
            
              <span><a href="/follow-us/">Follow Us</a></span>
            
              <span><a href="/FAQ/">FAQ</a></span>
            
              <span><a href="/privacy-policy/">Privacy Policy</a></span>
            
              <span><a href="/terms-of-use/">Terms of Use</a></span>
            
              <span><a href="/takedown-policy/">Takedown Policy</a></span>
            
              <span><a href="https://everout.com/masthead/">Our Team</a></span>
            
              <span><a href="https://everout.com/seattle/events/submit/">Submit an Event</a></span>
            
          </p>
        
      </div>
    </div>
    <div class="row">
      <div class="col">
        <p>
  All contents © EverOut, Inc. 2021<br>
  800 Maynard Ave S, Ste 200, Seattle, WA 98134
</p>

      </div>
    </div>
  </div>
</div> <!-- end footer copyright desktop-->

  </div><!-- end desktop footer -->

  <!-- mobile footer -->
  <div class="d-md-none">
    <!-- mobile footer -->
<div class="footer-mobile">
  <div class="footer-top-block mb-4">
    
      

<div class="component email-sign-up ">
  <div class="container text-center">
    
      <h1>Subscribe to our Newsletter</h1>
    
    
      <div class="copy">
        <p>Seattle is reopening! Sign up to get the latest updates on things to do, delivered to you four times a week.</p>
      </div>
    
    <form id="mc-embedded-subscribe-form" class="form" action="https://everout.us4.list-manage.com/subscribe/post?u=d7708ba310556d83ed7895c57&amp;id=01ccd644f5" method="post" name="" target="_blank">
      <div class="row g-3 align-items-center">
        <div class="col-md-8 offset-md-1"><input class="form-control mb-2 me-sm-2 email-input" name="EMAIL" type="email" placeholder="Email Address" /></div>
        
          
            <input type="hidden" value="1" name="group[71361][1]">
          
        
        <div class="col-md-2"><button class="btn btn-primary mb-2 submit-button" style="width:100%;" type="submit">Sign Up</button></div>
        <div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_d7708ba310556d83ed7895c57_01ccd644f5" type="text" value="" /></div>
      </div>
      <script>
        function setCityValue() {
          if ($('#citySelect').val() == 'seattle') {
            $('#citySelectValue').attr('name', 'group[71361][1]');
            $('#citySelectValue').val(1);
          } else if ($('#citySelect').val() == 'portland') {
            $('#citySelectValue').attr('name', 'group[71361][2]');
            $('#citySelectValue').val(2);
          }
        }
        $(function () {
          setCityValue();
        });
      </script>
    </form>
  </div>
</div>

    
    
      <div class="footer-row row g-0">
        <div class="col-md">
          <div class="col-sm text-center">
            <div class="footer-social-links mt-0">
              <h2>Follow Us</h2>
              
                <a href="http://www.facebook.com/everoutseattle" target="_blank"><i class="fab fa-facebook-f"></i></a>
              
                <a href="https://www.twitter.com/everoutseattle" target="_blank"><i class="fab fa-twitter"></i></a>
              
                <a href="https://instagram.com/everoutfood" target="_blank"><i class="fab fa-instagram"></i></a>
              
            </div>
          </div>
        </div>
      </div>
    
  </div>
  <div class="container">
    <div class="footer-row row">
      <div class="col-sm text-center">
        <div class="footer-brand">
  <a class="navbar-brand" href="https://everout.com/seattle/"><img src="/assets/images/everout-logo-yellow.png" alt="EverOut"></a>
</div>

        <p>
  All contents © EverOut, Inc. 2021<br>
  800 Maynard Ave S, Ste 200, Seattle, WA 98134
</p>

        
          <p class="footer-links pipe-delimited-links">
            <small>
              
                <span><a href="/about/">About</a></span>
              
                <span><a href="/contact-us/">Contact</a></span>
              
                <span><a href="/follow-us/">Follow Us</a></span>
              
                <span><a href="/FAQ/">FAQ</a></span>
              
                <span><a href="/privacy-policy/">Privacy Policy</a></span>
              
                <span><a href="/terms-of-use/">Terms of Use</a></span>
              
                <span><a href="/takedown-policy/">Takedown Policy</a></span>
              
                <span><a href="https://everout.com/masthead/">Our Team</a></span>
              
                <span><a href="https://everout.com/seattle/events/submit/">Submit an Event</a></span>
              
            </small>
          </p>
        
      </div>
    </div>
  </div>
</div><!-- end mobile footer -->

  </div><!-- end mobile footer -->
</div><!-- end footer -->

      

  <div class="network-bar navbar d-md-none navbar-dark bg-dark">
    <div class="container">
      <ul class="navbar-nav me-auto">
        <li class="nav-item dropdown">
          <a class="nav-link dropdown-toggle" href="#" id="networkBarDropdown" role="button" data-bs-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
            EverOut
          </a>
          <ul class="dropdown-menu" aria-labelledby="networkBarDropdown">
            <li class="dropdown-item"><a href="/" class="nav-link">Home</a></li>
            <div class="dropdown-divider"></div>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/seattle/">
                  Seattle
                </a>
              </li>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/portland/">
                  Portland
                </a>
              </li>
            
          </ul>
        </li>
        <li class="nav-item nav-item-separator">|</li>
        
          <li class="nav-item"><a class="nav-link" href="/prefunq">Prefunq</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.thestranger.com">The Stranger</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.portlandmercury.com">Portland Mercury</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.savagelovecast.com">Savage Love</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://humpfilmfest.com">Hump</a></li>
          
            </ul>
            <ul class="navbar-nav me-auto">
          
          
        
      </ul>
    </div>
  </div>


      
    </footer>
    <script src="https://dyoeldxcrpb0a.cloudfront.net/assets/foot-36cabf32a0206c820ed8.js" ></script>
    
    
    


  
    
      <div id='EverOut-Seattle-Content-Background-58' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Content-Background-58'); });
        </script>
      </div>
    
  

  

  

  

  

  

  

  

  


  </body>

</html>
