




<!DOCTYPE html>
<html>
  <head>
    <script>
      dataLayer = [{
        'Market': 'seattle'
      }];
    </script>
    
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MVCXDDK');</script>
<!-- End Google Tag Manager -->


    


<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=yes">
<script type="text/javascript">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</script>

<link type="text/css" href="https://dyoeldxcrpb0a.cloudfront.net/assets/head.d1fbb1b4b397a1dc1a5b.css" rel="stylesheet" />
<script type="text/javascript" src="https://dyoeldxcrpb0a.cloudfront.net/assets/head-d1fbb1b4b397a1dc1a5b.js" ></script>
<link type="text/css" href="https://dyoeldxcrpb0a.cloudfront.net/assets/everout_head.d1fbb1b4b397a1dc1a5b.css" rel="stylesheet" />
<script type="text/javascript" src="https://dyoeldxcrpb0a.cloudfront.net/assets/everout_head-d1fbb1b4b397a1dc1a5b.js" ></script>
<link rel="icon" href="https://dyoeldxcrpb0a.cloudfront.net/assets/images/everout-favicon.ico">
<script data-ad-client="ca-pub-0969663119487598" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>


  <link rel="alternate" type="application/rss+xml" title="EverOut Seattle Picks & Guides Feed" href="https://everout.com/seattle/articles/feed" />



<link rel="stylesheet" href="https://use.typekit.net/wdx1hsa.css">

<script src="https://kit.fontawesome.com/ae403a2e1f.js" crossorigin="anonymous"></script>




<meta property="og:type" content="article" />

  
    <link rel="canonical" href="https://everout.com/seattle/articles/top-picks-for-the-2021-seattle-international-film-festival/c572/" />
    <meta property="og:url" content="https://everout.com/seattle/articles/top-picks-for-the-2021-seattle-international-film-festival/c572/" />
  
  
  



  <title>Top Picks for the 2021 Seattle International Film Festival - EverOut Seattle</title>
  <meta property="og:title" content="Top Picks for the 2021 Seattle International Film Festival - EverOut Seattle" />
  <meta name="apple-mobile-web-app-title" content="Top Picks for the 2021 Seattle International Film Festival - EverOut Seattle" />



  <meta property="og:description" content="Top Picks for the 2021 Seattle International Film Festival - The 47th annual SIFF Lineup Has Been Announced" />
  <meta name="description" content="Top Picks for the 2021 Seattle International Film Festival - The 47th annual SIFF Lineup Has Been Announced" />


  <meta name="twitter:image" content="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjU0MjY4MTA2NTg0LVNjcmVlbl9TaG90XzIwMjEtMDMtMjNfYXRfNC4zNS4yMl9QTS5wbmciLCAiZWRpdHMiOiB7InJlc2l6ZSI6IHsiZml0IjogImluc2lkZSIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiAxMjAwLCAiaGVpZ2h0IjogNjMwfX19" />
  <meta property="og:image" content="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjU0MjY4MTA2NTg0LVNjcmVlbl9TaG90XzIwMjEtMDMtMjNfYXRfNC4zNS4yMl9QTS5wbmciLCAiZWRpdHMiOiB7InJlc2l6ZSI6IHsiZml0IjogImluc2lkZSIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiAxMjAwLCAiaGVpZ2h0IjogNjMwfX19" />

<link rel="mask-icon" href="https://dyoeldxcrpb0a.cloudfront.net/assets/images/everout-pin-icon.svg" color="#fcdc00">

  <link rel="apple-touch-icon-precomposed" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA2MCwgImhlaWdodCI6IDYwfX19" />
  <link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA3MiwgImhlaWdodCI6IDcyfX19" />
  <link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiAxMjAsICJoZWlnaHQiOiAxMjB9fX0=" />
  <link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiAxNTIsICJoZWlnaHQiOiAxNTJ9fX0=" />



  <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
  <script>
    window.googletag = window.googletag || {cmd: []};
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[1, 1]]).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Background", [[1, 1]], "Stranger-Content-Background-58").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[970, 250], [970, 100]]).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Top", [[970, 250], [970, 100]], "Stranger-Content-Top-56").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], [[320, 50]]).addSize([768, 0], []).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Mobile_Top", [[320, 50]], "Stranger-Content-Mobile-Top-57").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[300, 250], [300, 600]]).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Sidebar_1", [[300, 250], [300, 600]], "Stranger-Content-Sidebar-1-50").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], [[300, 250]]).addSize([768, 0], []).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Mobile_Inline_1", [[300, 250]], "Stranger-Content-Mobile-Inline-1-54").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], [[300, 250]]).addSize([768, 0], []).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Mobile_Inline_2", [[300, 250]], "Stranger-Content-Mobile-Inline-2-55").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[300, 250], [300, 600]]).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Sidebar_2", [[300, 250], [300, 600]], "Stranger-Content-Sidebar-2-51").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[300, 250], [300, 600]]).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Sidebar_3", [[300, 250], [300, 600]], "Stranger-Content-Sidebar-3-52").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[300, 250], [300, 600]]).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Sidebar_4", [[300, 250], [300, 600]], "Stranger-Content-Sidebar-4-53").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
            googletag.cmd.push(function() {
                googletag.pubads().enableSingleRequest();
                googletag.pubads().setTargeting("section", ['stranger-editorial-things-to-do']);
                googletag.enableServices();
            });
        
  </script>



<meta property="og:site_name" content="The Stranger" />
<meta name="twitter:card" content="summary_large_image" />

  
    <meta name="twitter:site" content="@thestranger" />
  
  
    <meta property="article:publisher" content="https://www.facebook.com/strangerseattle" />
  
  
    <meta property="fb:app_id" content="43933993878"/>
  
  
    <meta property="fb:admins" content="741428065"/>
  
  
    <meta property="fb:pages" content="56439755991" />
  

<meta name="cached" content="2021-03-24 13:02:55.281439">

  </head>

  <body class="everout seattle">
    
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MVCXDDK"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->


    <div class="flex-container wrapper">
      

  <div class="network-bar navbar d-none d-md-block navbar-expand-md navbar-dark bg-dark">
    <div class="container">
      <ul class="navbar-nav mr-auto">
        <li class="nav-item dropdown">
          <a class="nav-link dropdown-toggle" href="#" id="navbarDropdown" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
            EverOut
          </a>
          <ul class="dropdown-menu" aria-labelledby="navbarDropdown">
            <li class="dropdown-item"><a href="/" class="nav-link">Home</a></li>
            <div class="dropdown-divider"></div>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/seattle/">
                  Seattle
                </a>
              </li>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/portland/">
                  Portland
                </a>
              </li>
            
          </ul>
        </li>
        <li class="nav-item nav-item-separator">|</li>
        
          <li class="nav-item"><a class="nav-link" href="https://www.thestranger.com">The Stranger</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.portlandmercury.com">Portland Mercury</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.savagelovecast.com">Savage Love</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://humpfilmfest.com">Hump</a></li>
          
          
        
      </ul>
    </div>
  </div>


      



      <div class="top-nav desktop">
  <div class="container">
    <nav class="navbar">
      <div class="navbar-brand-container">
        <a class="navbar-brand seattle" href="/seattle/" alt="Seattle">
          
            <img src="https://d2i729k8wyri5w.cloudfront.net/market-159735153762325-everout-logo-seattle2.png" alt="EverOut Seattle">
          
        </a>
      </div>
      
        <div class="navbar-expand-md desktop-items-container">
          <ul class="nav collapse navbar-collapse justify-content-end nav-items main-nav">
            
              <li class="nav-item">
                <a href="/stranger-seattle/" class="nav-link">Picks &amp; Guides</a>
              </li>
              <li class="nav-item separator">|</li>
            
              <li class="nav-item">
                <a href="/stranger-seattle/events" class="nav-link">All Events</a>
              </li>
              <li class="nav-item separator">|</li>
            
              <li class="nav-item">
                <a href="/prefunq" class="nav-link">Prefunq</a>
              </li>
              <li class="nav-item separator">|</li>
            
            
              <li class="nav-item dropdown">
                <a class="nav-link dropdown-toggle" href="#" id="navbarDropdown" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
                  More
                </a>
                <ul class="dropdown-menu dropdown-menu-right" aria-labelledby="navbarDropdown">
                  
                  <li class="dropdown-item  highlighted   class-change ">
                    <a href="https://everout.com/stranger-seattle/events/?category=in-person">
                      
                        <span class="fas fa-star"></span>
                      
                      
                        In-Person Events
                      
                    </a>
                  </li>
                  
                  <li class="dropdown-item  highlighted  ">
                    <a href="https://everout.com/stranger-seattle/locations/?feature=covered-patio&amp;feature=heated-patio">
                      
                        <span class="fas fa-star"></span>
                      
                      
                        Covered & Heated Patios
                      
                    </a>
                  </li>
                  
                  <li class="dropdown-item  highlighted  ">
                    <a href="https://everout.com/stranger-seattle/events/?category=one-day-only">
                      
                        <span class="fas fa-star"></span>
                      
                      
                        One-Day-Only Events
                      
                    </a>
                  </li>
                  
                  <li class="dropdown-item  highlighted  ">
                    <a href="https://everout.com/streamlocal/">
                      
                        <span class="fas fa-star"></span>
                      
                      
                        StreamLocal
                      
                    </a>
                  </li>
                  
                  <li class="dropdown-item  highlighted  ">
                    <a href="https://everout.com/stranger-seattle/events/?category=livestreamed">
                      
                        <span class="fas fa-star"></span>
                      
                      
                        Livestreamed Events
                      
                    </a>
                  </li>
                  
                  <li class="dropdown-item  highlighted  ">
                    <a href="https://everout.com/stranger-seattle/events/?category=bipoc">
                      
                        <span class="fas fa-star"></span>
                      
                      
                        BIPOC-Focused Events
                      
                    </a>
                  </li>
                  
                  <li class="dropdown-item   class-change ">
                    <a href="https://everout.com/stranger-seattle/locations/?category=restaurants&amp;feature=takeout-covid-19&amp;feature=delivery-covid-19&amp;feature=curbside-pickup&amp;feature=walk-up-ordering">
                      
                      
                        Takeout & Delivery
                      
                    </a>
                  </li>
                  
                  <li class="dropdown-item  ">
                    <a href="https://everout.com/stranger-seattle/locations/?feature=in-person-visits">
                      
                      
                        Now-Open Shops & Attractions
                      
                    </a>
                  </li>
                  
                  <li class="dropdown-item  ">
                    <a href="https://everout.com/stranger-seattle/locations/?category=weed-locations&amp;feature=takeout-covid-19">
                      
                      
                        Weed Locations
                      
                    </a>
                  </li>
                  
                </ul>
              </li>
            
          </ul>
        </div>
        <ul class="nav mobile nav-items main-nav d-md-none mt-2">
          
            <li class="nav-item">
              <a href="/stranger-seattle/" class="nav-link">Picks &amp; Guides</a>
            </li>
            <li class="nav-item separator">|</li>
          
            <li class="nav-item">
              <a href="/stranger-seattle/events" class="nav-link">All Events</a>
            </li>
            <li class="nav-item separator">|</li>
          
            <li class="nav-item">
              <a href="/prefunq" class="nav-link">Prefunq</a>
            </li>
            <li class="nav-item separator">|</li>
          
          
            <li class="nav-item menu-toggler" data-toggle="collapse" data-target="#navbarToggle" aria-controls="navbarToggle" aria-expanded="false" aria-label="Toggle navigation">
              <a href="#" class="nav-link" onclick="return false;">More <i class="fa fa-caret-down"></i></a>
            </li>
          
        </ul>
        <div class="collapse navbar-collapse nav-items mobile d-md-none" id="navbarToggle">
          <div class="more-nav">
            
              <div class="nav-item  highlighted   class-change ">
                <a href=https://everout.com/stranger-seattle/events/?category=in-person>
                  
                    <span class="fas fa-star"></span>
                  
                  
                    In-Person Events
                  
                </a>
              </div>
            
              <div class="nav-item  highlighted  ">
                <a href=https://everout.com/stranger-seattle/locations/?feature=covered-patio&amp;feature=heated-patio>
                  
                    <span class="fas fa-star"></span>
                  
                  
                    Covered & Heated Patios
                  
                </a>
              </div>
            
              <div class="nav-item  highlighted  ">
                <a href=https://everout.com/stranger-seattle/events/?category=one-day-only>
                  
                    <span class="fas fa-star"></span>
                  
                  
                    One-Day-Only Events
                  
                </a>
              </div>
            
              <div class="nav-item  highlighted  ">
                <a href=https://everout.com/streamlocal/>
                  
                    <span class="fas fa-star"></span>
                  
                  
                    StreamLocal
                  
                </a>
              </div>
            
              <div class="nav-item  highlighted  ">
                <a href=https://everout.com/stranger-seattle/events/?category=livestreamed>
                  
                    <span class="fas fa-star"></span>
                  
                  
                    Livestreamed Events
                  
                </a>
              </div>
            
              <div class="nav-item  highlighted  ">
                <a href=https://everout.com/stranger-seattle/events/?category=bipoc>
                  
                    <span class="fas fa-star"></span>
                  
                  
                    BIPOC-Focused Events
                  
                </a>
              </div>
            
              <div class="nav-item   class-change ">
                <a href=https://everout.com/stranger-seattle/locations/?category=restaurants&amp;feature=takeout-covid-19&amp;feature=delivery-covid-19&amp;feature=curbside-pickup&amp;feature=walk-up-ordering>
                  
                  
                    Takeout & Delivery
                  
                </a>
              </div>
            
              <div class="nav-item  ">
                <a href=https://everout.com/stranger-seattle/locations/?feature=in-person-visits>
                  
                  
                    Now-Open Shops & Attractions
                  
                </a>
              </div>
            
              <div class="nav-item  ">
                <a href=https://everout.com/stranger-seattle/locations/?category=weed-locations&amp;feature=takeout-covid-19>
                  
                  
                    Weed Locations
                  
                </a>
              </div>
            
          </div>
        </div>
      
    </nav>
  </div>
</div>

      <div class="standalone-search-bar">
  <div class="search-container container" id="siteSearch">
    <span class="search-bar-label">Show Me</span>
    <input class="typeahead" type="text" placeholder="events, movies, venues, restaurants, guides..." data-sort-group="" data-site-section="">
    <i class="search-icon far fa-search"></i>

    <div role="listbox" class="default-search-panel p-3" style="display: none;" aria-expanded="false">
      <div role="presentation" class="row">
        <i class="loading-spinner fas fa-spinner fa-spin p-3"></i>
        <div class="col-6 col-sm-4 category-list">
        </div>
        <div class="col-6 col-sm-8 article-list">
        </div>
      </div>
    </div>
  </div>

  <script>
    $('.search-container .search-icon').on('click', function() {
      var market_slug = 'seattle';
      var search_value = $('.tt-input').val()
      if (search_value) {
        if (market_slug !== '') {
          window.location.href = '/' + market_slug + '/search?q=' + encodeURIComponent(search_value);
        } else {
          window.location.href = '/search?q=' + encodeURIComponent(search_value);
        }
      }
    })
  </script>
</div>

      

      <div class="top-super text-center container">
        


  

  
    
      <div id='Stranger-Content-Top-56' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Top-56'); });
        </script>
      </div>
    
  

  
    
      <div id='Stranger-Content-Mobile-Top-57' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Mobile-Top-57'); });
        </script>
      </div>
    
  

  

  

  

  

  

  


      </div>

      <div class="container">
        <div class="row main">
          
          <div class="col-md-8 primary">
            <header>
              
  <div class="row">
  <div id="breadcrumbs" class="col-sm-12 ttd-breadcrumbs">
    
      <a href="/seattle/">Seattle</a>
    
    <span class="breadcrumb-delimiter">&gt;</span>
    
      
        <a href="/seattle/articles/" class="">Picks &amp; Guides</a>
      
      
    
  </div>
</div>


            </header>

            <div class="content">
              
  <div class="item-detail article">
    <article>
      
      <header class="mb-2">
        
          
            <a class="category-tag" href="/seattle/articles/?category=film-tv">Film/TV</a>
          
        
        <h1>
          Top Picks for the 2021 Seattle International Film Festival
        </h1>
        <div class="subhead">
          The 47th annual SIFF Lineup Has Been Announced
        </div>
        
          <div class="author">
            by
            
              
                <a href="https://www.thestranger.com/authors/22700136/everout-things-to-do">Stranger EverOut Staff</a>
              
            
          </div>
        
        
          <div class="published-date">
            March 22, 2021
          </div>
        
        

<div class="share-tools border-top border-bottom  ">
  <span class="share-tools-label pr-2" class="pr-2">Share</span>
  <div class="facebook-this share-tool">
    <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A//everout.com/articles/top-picks-for-the-2021-seattle-international-film-festival/c572/" class="share-link new-window" target="_blank"><i class="fab fa-facebook pr-2"></i></a>
</div>

  <div class="tweet-this share-tool">
    <a href="https://twitter.com/intent/tweet?text=Top%20Picks%20for%20the%202021%20Seattle%20International%20Film%20Festival%2C%20from%20EverOut%20https%3A//everout.com/articles/top-picks-for-the-2021-seattle-international-film-festival/c572/" class="share-link new-window" target="_blank"><i class="fab fa-twitter pr-2"></i></a>
</div>

  <div class="mail-this share-tool">
    <a href="mailto:?subject=Top%20Picks%20for%20the%202021%20Seattle%20International%20Film%20Festival%2C%20from%20EverOut&body=Top%20Picks%20for%20the%202021%20Seattle%20International%20Film%20Festival%2C%20from%20EverOut%20https%3A//everout.com/articles/top-picks-for-the-2021-seattle-international-film-festival/c572/"><i class="fas fa-envelope"></i></a>
</div>

</div>

      </header>
      
        <div class="lead-image my-3">
          <img class="img-responsive" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjU0MjY4MTA2NTg0LVNjcmVlbl9TaG90XzIwMjEtMDMtMjNfYXRfNC4zNS4yMl9QTS5wbmciLCAiZWRpdHMiOiB7InJlc2l6ZSI6IHsiZml0IjogImluc2lkZSIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiAxMDI0LCAiaGVpZ2h0IjogODAwfX19 ">
          
            <div class="caption">
              If you missed its premiere at Sundance this year, you'll have another chance to catch James Redford&rsquo;s <a href="https://everout.com/seattle/events/amy-tan-unintended-memoir/e99205/"><em>Amy Tan: Unintended Memoir</em></a>, a portrait of the <em>Joy Luck Club</em> author, at SIFF next month.
              
                <span class="credit">
                  (SIFF)
                </span>
              
            </div>
          
        </div>
      
      <div class="body-text">
        
          
            
              <p>2020 was the Year Without a SIFF (and a lot of other things, thanks to COVID cancelations), but the largest film festival in the country, now in its 47th year, is gearing up for its <a href="https://everout.com/seattle/events/47th-seattle-international-film-festival-2021/e38436/">comeback</a> from April 8-18&mdash;and today they announced their official lineup! Pivoting to an all-virtual program, the festival will bring over 90 features and 100 short films to you, meaning you won't have to rush to a coveted matinee screening at a SIFF theater across town. We've rounded up a preview of the films we're&nbsp;most excited about, from Bassam Tariq's <em><a href="https://everout.com/seattle/events/mogul-mowgli/e99222/">Mogul Mowgli</a> </em>starring <em><a href="https://everout.com/seattle/events/sound-of-metal/e39389/">Sound of Metal</a></em>'s Riz Ahmed to Seattle director SJ Chiro's <em><a href="https://everout.com/seattle/events/east-of-the-mountains/e99220/">East of the Mountains</a>, </em>plus the opening-night film <a href="https://everout.com/seattle/events/opening-night-film-the-dry/e99250/"><em>The Dry</em></a> and the closing-night film <em><a href="https://everout.com/seattle/events/rosas-wedding/e99224/">Rosa's Wedding</a>.</em> Get your passes or single-film tickets now, and stay tuned&nbsp;for more recommendations and reviews as the event gets closer.</p>
            
          
            
              
<p><iframe title="YouTube video player" src="https://www.youtube.com/embed/bVcNCSMBmT4" width="945" height="532" frameborder="0" allowfullscreen=""></iframe></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/amy-tan-unintended-memoir/e99205/"><strong>Amy Tan: Unintended Memoir</strong></a><br /><strong>SIFF says:</strong> James Redford&rsquo;s final film is an illuminating rendering of author Amy Tan (<em>The Joy Luck Club</em>) through her own family photo albums and video footage, linking her prolific and groundbreaking work with the generations of women and immigrants before her.</p>
            
          
            
              
<p><img class="img-responsive" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjYwNTk1OTAyODM1OC1DYXB0YWluc29mWmFhdGFyaS5qcGciLCAiZWRpdHMiOiB7InJlc2l6ZSI6IHsiZml0IjogImluc2lkZSIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA3MjAsICJoZWlnaHQiOiA0ODB9fX0=" alt="" /></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/captains-of-zaatari/e99217/"><strong>Captains of Zaatari</strong></a><br /><strong>SIFF says: </strong>A rousing, heartfelt tale about two soccer-obsessed Syrian friends living in Jordan&rsquo;s Zaatari Refugee Camp who, upon learning that a famed Qatari sports academy is visiting the camp, may have finally found their ticket to a bigger, brighter future.</p>
            
          
            
              
<p><img class="img-responsive" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjYwNjA4NDg5MzQ4OS1TY3JlZW5fU2hvdF8yMDIxLTAzLTIzX2F0XzQuMzUuNDRfUE0ucG5nIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJpbnNpZGUiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogNzIwLCAiaGVpZ2h0IjogNDgwfX19" alt="" /></p>
            
          
            
              

<div class="fish-butter article-inline" data-spot="article-inline-ad" data-context-oid="" data-ad-oid="" style="display:none;">
  
    <div class="fish-tag">
      Sponsored
    </div>
  
  <div class="fish-container">
    <div class="fish-image">
      
    </div>
    <div class="fish-body">
      <h1>
        
      </h1>
      <p>
        
      </p>
    </div>
  </div>
</div>

            
          
            
              
<p><a href="https://everout.com/seattle/events/censor/e99206/"><strong>Censor</strong></a><br /><strong>SIFF says:</strong> Enid, a film censor involved with the &ldquo;video nasties&rdquo; slate of 1980s horror films, journeys into a dark, unsettling fairytale world when she happens upon a cult film that might explain her sister&rsquo;s disappearance years earlier.</p>
            
          
            
              
<p><strong>Stranger adds:</strong> In many ways, <em>Censor</em> creates its own tradition of horror. Even as it loves trashy horror flicks of decades-old, <em>Censor</em> becomes a beast all its own. <em>(Read Chase Hutchinson's full review <a href="https://www.thestranger.com/slog/2021/01/29/54987339/sundance-review-censor-is-unhinged-vhs-fueled-horror">here</a>.)</em></p>
            
          
            
              
<p><iframe title="YouTube video player" src="https://www.youtube.com/embed/Njx0mze3eNs" width="945" height="532" frameborder="0" allowfullscreen=""></iframe></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/charter/e99218/"><strong>Charter</strong></a><br /><strong>SIFF says:</strong> A complex and empathetic portrayal of motherhood in conflict with self-preservation, a recent divorc&eacute;e kidnaps her estranged children and spirits them away to the Canary Islands. From the director of <em>Sami Blood</em>, SIFF 2017 Grand Jury Prize winner.</p>
            
          
            
              
<p><img class="img-responsive" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjYwNjE5OTg1MzM3OC1EZWFkbHlDdXRzLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiaW5zaWRlIiwgInBvc2l0aW9uIjogImNlbnRyZSIsICJ3aWR0aCI6IDcyMCwgImhlaWdodCI6IDQ4MH19fQ==" alt="" /></p>
            
          
            
              


  

  

  

  

  
    
      <div id='Stranger-Content-Mobile-Inline-1-54' class="mb-3 text-center ad-placement inline-ad">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Mobile-Inline-1-54'); });
        </script>
      </div>
    
  

  

  

  

  


            
          
            
              
<p><strong><a href="https://everout.com/seattle/events/deadly-cuts/e99219/">Deadly Cuts</a></strong><br /><strong>SIFF says:</strong> They&rsquo;re going to do more than &ldquo;take a little off the top&rdquo; in Rachel Carey&rsquo;s blackly comic feature debut, as a group of working-class Dublin hairdressers become accidental vigilantes to protect themselves from the local gang threatening their neighborhood.</p>
            
          
            
              
<p><img class="img-responsive" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjYwNjI0NjczODY1OS1EcnkuanBnIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJpbnNpZGUiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogNzIwLCAiaGVpZ2h0IjogNDgwfX19" alt="" /></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/opening-night-film-the-dry/e99250/"><strong>The Dry (Opening Night Film)</strong></a><br /><strong>SIFF says:</strong> Eric Bana returns to Australian cinema in this crackling neo-noir murder mystery about a tortured Melbourne detective drawn back to his outback hometown of Kiewarra to investigate the death of a childhood friend.</p>
            
          
            
              
<p><iframe title="YouTube video player" src="https://www.youtube.com/embed/mDYiiBwoBPU" width="945" height="532" frameborder="0" allowfullscreen=""></iframe></p>
            
          
            
              
<p><strong><a href="https://everout.com/seattle/events/east-of-the-mountains/e99220/">East of the Mountains</a></strong><br /><strong>SIFF says:</strong> Local filmmaker SJ Chiro directs Tom Skerritt in this heartrending tale, based on the novel by David Guterson (<em>Snow Falling on Cedars</em>), about a terminally ill, retired heart surgeon who journeys back to Eastern Washington to end his life.</p>
            
          
            
              
<p><iframe title="YouTube video player" src="https://www.youtube.com/embed/zwHMvQ9SU0w" width="945" height="532" frameborder="0" allowfullscreen=""></iframe></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/get-the-hell-out/e99207/"><strong>Get the Hell Out</strong></a><br /><strong>SIFF says:</strong> Politics may bring out the worst in us, but nothing compares to the events in this action-packed Grand Guignol comedy about a team of activists, legislators, and civilians going up against a parliament filled with hyperactive zombie mutants infected with &ldquo;idiot rabies.&rdquo;</p>
            
          
            
              
<p><iframe title="YouTube video player" src="https://www.youtube.com/embed/XZchCtsAtW8" width="945" height="532" frameborder="0" allowfullscreen=""></iframe></p>
            
          
            
              
<p><strong><a href="https://everout.com/seattle/events/im-fine-thanks-for-asking/e99208/">I'M FINE (Thanks for Asking)</a></strong><br /><strong>SIFF says:</strong> A recently widowed mother on the outer edges of Los Angeles works her rollerskating tail off to get her and her eight-year-old daughter off the streets, over one long day of pawn shop negotiations, food app delivery mishaps, and shady landlords.</p>
            
          
            
              
<p><img class="img-responsive" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjYwNzAwODkxNTM0MS1JbnRoZVNhbWVCcmVhdGguanBnIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJpbnNpZGUiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogNzIwLCAiaGVpZ2h0IjogNDgwfX19" alt="" /></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/in-the-same-breath/e99209/"><strong>In the Same Breath</strong></a><br /><strong>SIFF says:</strong> Nanfu Wang (<em>One Child Nation</em>) directs this tragic, revealing, and journalistically risky contextualization of the COVID-19 outbreak, spotlighting the similar Chinese and American government propagandic responses to the once-in-a-century pandemic that brought the world to a standstill.</p>
            
          
            
              


  

  

  

  

  

  
    
      <div id='Stranger-Content-Mobile-Inline-2-55' class="mb-3 text-center ad-placement inline-ad">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Mobile-Inline-2-55'); });
        </script>
      </div>
    
  

  

  

  


            
          
            
              
<p><img class="img-responsive" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjYwNzA1Njc5NTY4NS1NYUJlbGxlTXlCZWF1dHkuanBnIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJpbnNpZGUiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogNzIwLCAiaGVpZ2h0IjogNDgwfX19" alt="" /></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/ma-belle-ma-beauty/e99221/"><strong>Ma Belle, Ma Beauty</strong></a><br /><strong>SIFF says:</strong> Set in the sun-drenched vineyards of southern France, two newlywed musicians adjusting to their new European life get a sudden visit from Lane, the former third party in their polyamorous relationship back in New Orleans.<br /><br /><strong>Stranger adds:</strong> <em>Ma Belle, My Beauty&nbsp;</em>is a fun and engaging study of queer relationships, polyamory, and how fucking SICK slurping wine in the French countryside can look. The film opens with Fred and Bertie (Lucien Guignard and Idella Johnson), two recently married musicians who live in Fred's parents' beautiful farmhouse in the south of France. A depressed Bertie feels like a stranger in a strange land, hardly finding the will to sing despite her upcoming tour. In an attempt to raise her spirits, Fred invites their ex-lover from their life in New Orleans, Lane (Hannah Pepper-Cunningham), to the property as a surprise. Sensuous parties, heartbreak revisited, strained silences, soaring music, and really hot sex ensue. (<em>Read Jasmyne Keimig's full review <a href="https://www.thestranger.com/slog/2021/01/31/55035713/sundance-review-ma-belle-my-beauty-is-the-queer-poly-escape-we-needed">here</a>.</em>)</p>
            
          
            
              
<p><img class="img-responsive" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjYwNzExOTU2NjI1OS1Nb2d1bE1vd2dsaS5qcGciLCAiZWRpdHMiOiB7InJlc2l6ZSI6IHsiZml0IjogImluc2lkZSIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA3MjAsICJoZWlnaHQiOiA0ODB9fX0=" alt="" /></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/mogul-mowgli/e99222/"><strong>Mogul Mowgli</strong></a><br /><strong>SIFF says:</strong> Oscar nominee Riz Ahmed (<em>Sound of Metal</em>, <em>The Night Of</em>) co-authors and stars in this drama about an up-and-coming British rapper who develops an autoimmune degenerative disorder, forcing him to move back in with his traditional-minded Pakistani family.</p>
            
          
            
              
<p><iframe title="YouTube video player" src="https://www.youtube.com/embed/hX55Xx49UBA" width="945" height="532" frameborder="0" allowfullscreen=""></iframe></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/the-pink-cloud/e99210/"><strong>The Pink Cloud</strong></a><br /><strong>SIFF says:</strong> When a mysterious and lethal pink cloud appears over a Brazilian city, two people engaging in a one-night stand are forced to quarantine together over several years in this eerie and prescient science-fiction film that now seems all too real.</p>
            
          
            
              
<p><img class="img-responsive" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjYwNzIzODA2NjczOS1Qb3RhdG9EcmVhbXNvZkFtZXJpY2EuanBnIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJpbnNpZGUiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogNzIwLCAiaGVpZ2h0IjogNDgwfX19" alt="" /></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/potato-dreams-of-america/e99211/"><strong>Potato Dreams of America</strong></a><br /><strong>SIFF says:</strong> From Wes Hurley, the creator of famed local webseries &ldquo;Capitol Hill,&rdquo; comes an autobiographical coming-of-age dark comedy about a young closeted Russian boy in the disintegrating USSR who moves to Seattle with his prison doctor-turned-mail-order bride single mother.</p>
            
          
            
              
<p><img class="img-responsive" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjYwNzI4ODQ4Nzg5My1SaWRlcnNvZkp1c3RpY2UuanBnIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJpbnNpZGUiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogNzIwLCAiaGVpZ2h0IjogNDgwfX19" alt="" /></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/riders-of-justice/e99223/"><strong>Riders of Justice</strong></a><br /><strong>SIFF says:</strong> Mads Mikkelsen (<em>Another Round</em>) reunites with the writer/director of <em>Men &amp; Chicken</em> in this pitch-black screwball comedy of revenge, starring as a heartbroken man whose wife&rsquo;s suspicious death in a train crash leads to outlandish conspiracy theories and gangland bloodshed.</p>
            
          
            
              
<p><img class="img-responsive" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjYwNzM1Nzk2OTMxMS1SaXRhTW9yZW5vSnVzdEFHaXJsV2hvRGVjaWRlZFRvR29Gb3JJdC5qcGciLCAiZWRpdHMiOiB7InJlc2l6ZSI6IHsiZml0IjogImluc2lkZSIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA3MjAsICJoZWlnaHQiOiA0ODB9fX0=" alt="" /></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/rita-moreno-just-a-girl-who-decided-to-go-for-it/e99212/"><strong>Rita Moreno: Just a Girl Who Decided to Go For It</strong></a><br /><strong>SIFF says:</strong> Rita&rsquo;s gonna get her kicks tonight. A close-up on Rita Moreno, now an ebullient 89 and one of the few actors from Hollywood&rsquo;s studio era still working today, from her childhood in Puerto Rico to her illustrious career on Broadway and in Hollywood.</p>
            
          
            
              
<p><iframe title="YouTube video player" src="https://www.youtube.com/embed/1gb05HNgIG0" width="945" height="532" frameborder="0" allowfullscreen=""></iframe></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/rosas-wedding/e99224/"><strong>Rosa's Wedding (Closing Night Film)</strong></a><br /><strong>SIFF says:</strong> In this joyful Catalan dramedy, costume designer Rosa is about to turn 45 and sick of being taken for granted, taken advantage of, and putting out other people&rsquo;s fires. Taking control of her own life, she announces a surprise engagement to a mysterious suitor, much to the dismay of her family.</p>
            
          
            
              
<p><iframe title="YouTube video player" src="https://www.youtube.com/embed/STSOPJQftbw" width="945" height="532" frameborder="0" allowfullscreen=""></iframe></p>
            
          
            
              
<p><strong><a href="https://everout.com/seattle/events/slalom/e99225/">Slalom</a></strong><br /><strong>SIFF says: </strong>In Charl&egrave;ne Favier&rsquo;s timely and unsentimental feature debut that explores when mentorship becomes abuse, up-and-coming actress No&eacute;e Abita (<em>Sink or Swim</em>) plays a 15-year-old skiing prodigy in training who falls prey to her manipulative and lecherous coach (J&eacute;r&eacute;mie Renier,<em> In Bruges</em>).</p>
            
          
            
              
<p><img class="img-responsive" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjYwNzgzMzYzOTM3OC1TdHJhd2JlcnJ5TWFuc2lvbi5qcGciLCAiZWRpdHMiOiB7InJlc2l6ZSI6IHsiZml0IjogImluc2lkZSIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA3MjAsICJoZWlnaHQiOiA0ODB9fX0=" alt="" /></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/strawberry-mansion/e99213/"><strong>Strawberry Mansion</strong></a><br /><strong>SIFF says:</strong> In this sweet and colorful bit of surrealistic speculative fiction set in the near future, a &ldquo;dream auditor&rdquo; on assignment becomes obsessed with an aging eccentric and, while investigating the VHS archive of her subconscious, happens upon a chance at love.</p>
            
          
            
              
<p><iframe title="YouTube video player" src="https://www.youtube.com/embed/rLp23RTk_dQ" width="945" height="532" frameborder="0" allowfullscreen=""></iframe></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/under-the-open-sky/e99214/"><strong>Under the Open Sky</strong></a><br /><strong>SIFF says:</strong> Yakusho K&ocirc;ji (<em>The Third Murder</em>) gives a riveting performance as a lifelong Yakuza, released from prison after 13 years, whose journey to find the mother who abandoned him as a child is hindered by his gangster past.</p>
            
          
            
              
<p><iframe title="YouTube video player" src="https://www.youtube.com/embed/U6AETCm4HGY" width="945" height="532" frameborder="0" allowfullscreen=""></iframe></p>
            
          
            
              
<p><a href="https://everout.com/seattle/events/veins-of-the-world/e99251/"><strong>Veins of the World</strong></a><br /><strong>SIFF says: </strong><span style="font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen, Ubuntu, Cantarell, 'Open Sans', 'Helvetica Neue', sans-serif;">Eleven-year-old Amra lives in a traditional nomad community on the Mongolian steppe, which is threatened by the influx of global mining companies. He longs for a modern way of life, but when his father tragically dies, Amra must honor his father&rsquo;s legacy and fight to protect his community.</span></p>
            
          
            
              </p>
            
          
            
              

<div class="fish-butter article-inline" data-spot="article-inline-ad" data-context-oid="" data-ad-oid="" style="display:none;">
  
    <div class="fish-tag">
      Sponsored
    </div>
  
  <div class="fish-container">
    <div class="fish-image">
      
    </div>
    <div class="fish-body">
      <h1>
        
      </h1>
      <p>
        
      </p>
    </div>
  </div>
</div>

            
          
        
      </div>
    </article>
    

<div class="share-tools border-top border-bottom d-block text-right">
  <span class="share-tools-label pr-2" class="pr-2">Share</span>
  <div class="facebook-this share-tool">
    <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A//everout.com/articles/top-picks-for-the-2021-seattle-international-film-festival/c572/" class="share-link new-window" target="_blank"><i class="fab fa-facebook pr-2"></i></a>
</div>

  <div class="tweet-this share-tool">
    <a href="https://twitter.com/intent/tweet?text=Top%20Picks%20for%20the%202021%20Seattle%20International%20Film%20Festival%2C%20from%20EverOut%20https%3A//everout.com/articles/top-picks-for-the-2021-seattle-international-film-festival/c572/" class="share-link new-window" target="_blank"><i class="fab fa-twitter pr-2"></i></a>
</div>

  <div class="mail-this share-tool">
    <a href="mailto:?subject=Top%20Picks%20for%20the%202021%20Seattle%20International%20Film%20Festival%2C%20from%20EverOut&body=Top%20Picks%20for%20the%202021%20Seattle%20International%20Film%20Festival%2C%20from%20EverOut%20https%3A//everout.com/articles/top-picks-for-the-2021-seattle-international-film-festival/c572/"><i class="fas fa-envelope"></i></a>
</div>

</div>

    
      


  <div class="related-articles border-top mt-4 pt-2">
    <h2 class="pt-4 mb-2 section-header highlighted">You Might Also Like</h2>
    <div class="card-deck">
      <div class="row row-cols-2 row-cols-md-3 no-gutters">
        
          <div class="col mb-4">
            <div class="card h-100">
              <a href="https://everout.com/seattle/articles/tell-us-something-good-melissa-miranda/c3466/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjYxMDQ2NjI1Njc1LU1lbGlzc2FfTWlyYW5kYS5qcGVnIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJjb3ZlciIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA0MDAsICJoZWlnaHQiOiAzMDB9fX0="></a>
              <div class="card-body">
                <div class="card-title">
                  <a class="headline" href="https://everout.com/seattle/articles/tell-us-something-good-melissa-miranda/c3466/">Tell Us Something Good, Melissa Miranda</a>
                </div>
              </div>
            </div>
          </div>
        
          <div class="col mb-4">
            <div class="card h-100">
              <a href="https://everout.com/seattle/articles/let-us-make-restaurant-suggestions-for-you/c3465/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjUzODkwMjU1ODI5OS12aWN0b3JpYW5vLWl6cXVpZXJkby1KRzM1Q3BaTGZWcy11bnNwbGFzaC5qcGciLCAiZWRpdHMiOiB7InJlc2l6ZSI6IHsiZml0IjogImNvdmVyIiwgInBvc2l0aW9uIjogImNlbnRyZSIsICJ3aWR0aCI6IDQwMCwgImhlaWdodCI6IDMwMH19fQ=="></a>
              <div class="card-body">
                <div class="card-title">
                  <a class="headline" href="https://everout.com/seattle/articles/let-us-make-restaurant-suggestions-for-you/c3465/">Let Us Make Restaurant Suggestions for You!</a>
                </div>
              </div>
            </div>
          </div>
        
          <div class="col mb-4">
            <div class="card h-100">
              <a href="https://everout.com/seattle/articles/this-week-in-seattle-event-news-siff-mariners-games-farmers-markets-and-more/c3463/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjUzNTY5ODA0NjY0NS04MTc3MDYwNV8xMDE1Nzk3NDE2NDU4ODk3OV8yNzQ2MzQ3MzIzMzgxNTE0MjQwX28uanBlZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY292ZXIiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogNDAwLCAiaGVpZ2h0IjogMzAwfX19"></a>
              <div class="card-body">
                <div class="card-title">
                  <a class="headline" href="https://everout.com/seattle/articles/this-week-in-seattle-event-news-siff-mariners-games-farmers-markets-and-more/c3463/">This Week in Seattle Event News: SIFF, Mariners Games, Farmers Markets, and More</a>
                </div>
              </div>
            </div>
          </div>
        
          <div class="col mb-4">
            <div class="card h-100">
              <a href="https://everout.com/seattle/articles/top-picks-for-the-2021-seattle-international-film-festival/c572/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjU0MjY4MTA2NTg0LVNjcmVlbl9TaG90XzIwMjEtMDMtMjNfYXRfNC4zNS4yMl9QTS5wbmciLCAiZWRpdHMiOiB7InJlc2l6ZSI6IHsiZml0IjogImNvdmVyIiwgInBvc2l0aW9uIjogImNlbnRyZSIsICJ3aWR0aCI6IDQwMCwgImhlaWdodCI6IDMwMH19fQ=="></a>
              <div class="card-body">
                <div class="card-title">
                  <a class="headline" href="https://everout.com/seattle/articles/top-picks-for-the-2021-seattle-international-film-festival/c572/">Top Picks for the 2021 Seattle International Film Festival</a>
                </div>
              </div>
            </div>
          </div>
        
          <div class="col mb-4">
            <div class="card h-100">
              <a href="https://everout.com/seattle/articles/tell-us-something-good-renee-erickson/c571/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjUxNTg3NzcyOTUyNi1SZW5lZS1Fcmlja3Nvbl9FdmVyb3V0LmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY292ZXIiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogNDAwLCAiaGVpZ2h0IjogMzAwfX19"></a>
              <div class="card-body">
                <div class="card-title">
                  <a class="headline" href="https://everout.com/seattle/articles/tell-us-something-good-renee-erickson/c571/">Tell Us Something Good, Renee Erickson</a>
                </div>
              </div>
            </div>
          </div>
        
          <div class="col mb-4">
            <div class="card h-100">
              <a href="https://everout.com/seattle/articles/the-best-things-to-do-from-home-in-seattle-this-week-march-22-28-2021/c569/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYxNjQ0Mjc4MzIwNzk4MS1wYXJpc2FsZXhhLW5pa29zZXJwYW5vcy01LmpwZWciLCAiZWRpdHMiOiB7InJlc2l6ZSI6IHsiZml0IjogImNvdmVyIiwgInBvc2l0aW9uIjogImNlbnRyZSIsICJ3aWR0aCI6IDQwMCwgImhlaWdodCI6IDMwMH19fQ=="></a>
              <div class="card-body">
                <div class="card-title">
                  <a class="headline" href="https://everout.com/seattle/articles/the-best-things-to-do-from-home-in-seattle-this-week-march-22-28-2021/c569/">The Best Things To Do from Home in Seattle This Week: March 22-28, 2021</a>
                </div>
              </div>
            </div>
          </div>
        
      </div>
    </div>
  </div>


    
  </div>

            </div>
          </div>
          <div class="col-md-4 secondary">
            
  <div id="adSpaceSidebarModule" class="adspace sidebar-module sidebar-module-inset">
  


  

  

  

  
    
      <div id='Stranger-Content-Sidebar-1-50' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Sidebar-1-50'); });
        </script>
      </div>
    
  

  

  

  
    
      <div id='Stranger-Content-Sidebar-2-51' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Sidebar-2-51'); });
        </script>
      </div>
    
  

  
    
      <div id='Stranger-Content-Sidebar-3-52' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Sidebar-3-52'); });
        </script>
      </div>
    
  

  
    
      <div id='Stranger-Content-Sidebar-4-53' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Sidebar-4-53'); });
        </script>
      </div>
    
  


</div>


          </div>
          
        </div>
      </div>
    </div>
    <footer class="mt-4">
      <div class="site-footer">
  <!-- desktop footer -->
  <div class="d-none d-md-block">
    <!-- footer top block -->
<div class="footer-top-block">
  <div class="container">
    <div class="footer-row row">
      
    </div>
  </div>
</div> <!-- end footer top block -->


    <!-- footer bottom block -->
<div class="footer-middle-block">
  <div class="container">
    <div class="row">
      <div class="col-sm text-center">
        <div class="footer-cover">
          <h4>Latest Print Issue</h4>
          
          <p>
            <a href="https://www.thestranger.com/issues">
              
                <img src="https://media2.fdncms.com/stranger/imager/u/original/43106034/cover_mag.jpg" id="issue-cover" class="issue-cover-thumb" alt="Cover of this issue of The Stranger" style="max-width: 130px">
              
              Print Archives
            </a>
          </p>
          
        </div>
      </div>
      
        <div class="col-sm text-center">
          <h4>Publication Info</h4>
          <ul class="list-unstyled">
            
              <li><a href="https://www.thestranger.com/masthead">Masthead</a></li>
            
              <li><a href="https://www.thestranger.com/ad-info">Ad Info &amp; Rates</a></li>
            
              <li><a href="https://www.thestranger.com/distribution">Distribution</a></li>
            
              <li><a href="https://www.thestranger.com/jobs">Jobs at The Stranger</a></li>
            
              <li><a href="https://everout.com">EverOut</a></li>
            
              <li><a href="https://www.thestranger.com/contact-information">Contact</a></li>
            
              <li><a href="https://everout.com/tacoma/movies/">Tacoma Movie Times</a></li>
            
          </ul>
        </div>
      
      <div class="col-sm text-center">
        <h4>Check It Out</h4>
        
          <div class="footer-promo" style="margin-left:0">
            <a href="https://www.savagelovecast.com">
              <img src="https://media1.fdncms.com/stranger/imager/u/original/39759989/savagelovecast.jpg" alt="Savage Lovecast">
            </a>
          </div>
        
          <div class="footer-promo" style="margin-left:0">
            <a href="http://www.cocktailcompass.com">
              <img src="https://media2.fdncms.com/stranger/imager/u/original/39759990/cocktailcompass-188x80.png" alt="Cocktail Compass">
            </a>
          </div>
        
          <div class="footer-promo" style="margin-left:0">
            <a href="https://www.thestranger.com/promotions">
              <img src="https://media1.fdncms.com/stranger/imager/u/original/39759991/checkitout_button-contests.png" alt="The Stranger Promotions">
            </a>
          </div>
        
      </div>
      <div class="col-sm text-center">
       <h4>Follow Us</h4>
        <ul class="footer-social-links list-unstyled text-left">
          
            <li><a href="https://www.thestranger.com/syndication" target="_blank"><i class="fas fa-rss"></i> RSS</a></li>
          
            <li><a href="https://www.thestranger.com/twitter" target="_blank"><i class="fab fa-twitter"></i> Twitter</a></li>
          
            <li><a href="http://www.facebook.com/strangerseattle" target="_blank"><i class="fab fa-facebook-f"></i> Facebook</a></li>
          
            <li><a href="http://instagram.com/thestrangerseattle" target="_blank"><i class="fab fa-instagram"></i> Instagram</a></li>
          
        </ul>
      </div>
    </div>
  </div>
</div><!-- end footer bottom block -->


    <!-- footer bottom block desktop -->
<div class="footer-bottom-block">
  <div class="container">
    <div class="footer-row row">
      <div class="col-md">
        <div class="footer-brand">
  <a class="navbar-brand" href="https://everout.com/seattle/"><img src="/assets/images/everout-logo-black.png" alt="EverOut"></a>
</div>

      </div>
      <div class="col-md-8">
        
          <p class="footer-links text-right pipe-delimited-links">
            
              <span><a href="/about/">About</a></span>
            
              <span><a href="/contact-us/">Contact Us</a></span>
            
              <span><a href="/follow-us/">Follow Us</a></span>
            
              <span><a href="/FAQ/">FAQ</a></span>
            
              <span><a href="/privacy-policy/">Privacy Policy</a></span>
            
              <span><a href="/terms-of-use/">Terms of Use</a></span>
            
              <span><a href="/takedown-policy/">Takedown Policy</a></span>
            
          </p>
        
      </div>
    </div>
    <div class="row">
      <div class="col">
        <p>
  All contents © EverOut, Inc.<br>
  Index Newspapers, LLC<br>
  800 Maynard Ave S, Ste 200, Seattle, WA 98134
</p>

      </div>
    </div>
  </div>
</div> <!-- end footer copyright desktop-->

  </div><!-- end desktop footer -->

  <!-- mobile footer -->
  <div class="d-md-none">
    <!-- mobile footer -->
<div class="footer-mobile">
  <div class="container">
    <div class="footer-row row">
      <div class="col-sm text-center">
        <div class="footer-mobile-social-links">
          
            <a href="https://www.thestranger.com/syndication" target="_blank"><i class="fas fa-rss"></i></a>
          
            <a href="https://www.thestranger.com/twitter" target="_blank"><i class="fab fa-twitter"></i></a>
          
            <a href="http://www.facebook.com/strangerseattle" target="_blank"><i class="fab fa-facebook-f"></i></a>
          
            <a href="http://instagram.com/thestrangerseattle" target="_blank"><i class="fab fa-instagram"></i></a>
          
        </div>
        <div class="footer-brand">
  <a class="navbar-brand" href="https://everout.com/seattle/"><img src="/assets/images/everout-logo-black.png" alt="EverOut"></a>
</div>

        <p>
  All contents © EverOut, Inc.<br>
  Index Newspapers, LLC<br>
  800 Maynard Ave S, Ste 200, Seattle, WA 98134
</p>

        
          <p class="footer-links pipe-delimited-links">
            <small>
              
                <span><a href="/about/">About</a></span>
              
                <span><a href="/contact-us/">Contact Us</a></span>
              
                <span><a href="/follow-us/">Follow Us</a></span>
              
                <span><a href="/FAQ/">FAQ</a></span>
              
                <span><a href="/privacy-policy/">Privacy Policy</a></span>
              
                <span><a href="/terms-of-use/">Terms of Use</a></span>
              
                <span><a href="/takedown-policy/">Takedown Policy</a></span>
              
            </small>
          </p>
        
      </div>
    </div>
  </div>
</div><!-- end mobile footer -->

  </div><!-- end mobile footer -->
</div><!-- end footer -->

      

  <div class="network-bar navbar d-md-none navbar-dark bg-dark">
    <div class="container">
      <ul class="navbar-nav mr-auto">
        <li class="nav-item dropdown">
          <a class="nav-link dropdown-toggle" href="#" id="navbarDropdown" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
            EverOut
          </a>
          <ul class="dropdown-menu" aria-labelledby="navbarDropdown">
            <li class="dropdown-item"><a href="/" class="nav-link">Home</a></li>
            <div class="dropdown-divider"></div>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/seattle/">
                  Seattle
                </a>
              </li>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/portland/">
                  Portland
                </a>
              </li>
            
          </ul>
        </li>
        <li class="nav-item nav-item-separator">|</li>
        
          <li class="nav-item"><a class="nav-link" href="https://www.thestranger.com">The Stranger</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.portlandmercury.com">Portland Mercury</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.savagelovecast.com">Savage Love</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://humpfilmfest.com">Hump</a></li>
          
          
        
      </ul>
    </div>
  </div>


      
    </footer>
    <script type="text/javascript" src="https://dyoeldxcrpb0a.cloudfront.net/assets/foot-d1fbb1b4b397a1dc1a5b.js" ></script>
    
    
    


  
    
      <div id='Stranger-Content-Background-58' class="mb-3 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Background-58'); });
        </script>
      </div>
    
  

  

  

  

  

  

  

  

  


  </body>

</html>
