




<!DOCTYPE html>
<html>
  <head>
    <script>
      dataLayer = [{
        'Market': 'seattle'
      }];
    </script>
    
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MVCXDDK');</script>
<!-- End Google Tag Manager -->


    


<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=yes">
<script type="text/javascript">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</script>

<script src="https://dyoeldxcrpb0a.cloudfront.net/assets/head-85ffe2ba0e7063db1a53.js" ></script>
<link href="https://dyoeldxcrpb0a.cloudfront.net/assets/everout_head.a33df68b4e9229599219.css" rel="stylesheet" />
<script src="https://dyoeldxcrpb0a.cloudfront.net/assets/everout_head-9256b0eae64bdc3fa4dc.js" ></script>
<link rel="icon" href="https://dyoeldxcrpb0a.cloudfront.net/assets/images/everout-favicon.ico">
<script data-ad-client="ca-pub-0969663119487598" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>


  <link rel="alternate" type="application/rss+xml" title="EverOut Seattle Picks & Guides Feed" href="https://everout.com/seattle/articles/feed" />



<link rel="stylesheet" href="https://use.typekit.net/wdx1hsa.css">

<script src="https://kit.fontawesome.com/ae403a2e1f.js" crossorigin="anonymous"></script>



  <script src="/assets/js/member-actions.js?cb=202201141039"></script>


<meta property="og:type" content="article" />

  
    <link rel="canonical" href="https://everout.com/seattle/articles/ticket-alert-modest-mouse-burna-boy-and-more-seattle-events-going-on-sale-this-week/c4525/" />
    <meta property="og:url" content="https://everout.com/seattle/articles/ticket-alert-modest-mouse-burna-boy-and-more-seattle-events-going-on-sale-this-week/c4525/" />
  
  
  



  <title>Ticket Alert: Modest Mouse, Burna Boy, and More Seattle Events Going On Sale This Week - EverOut Seattle</title>
  <meta property="og:title" content="Ticket Alert: Modest Mouse, Burna Boy, and More Seattle Events Going On Sale This Week - EverOut Seattle" />
  <meta name="apple-mobile-web-app-title" content="Ticket Alert: Modest Mouse, Burna Boy, and More Seattle Events Going On Sale This Week - EverOut Seattle" />



  <meta property="og:description" content="Ticket Alert: Modest Mouse, Burna Boy, and More Seattle Events Going On Sale This Week - Plus, Flo Milli and Event Updates for Sept 8" />
  <meta name="description" content="Ticket Alert: Modest Mouse, Burna Boy, and More Seattle Events Going On Sale This Week - Plus, Flo Milli and Event Updates for Sept 8" />


  <meta name="twitter:image" content="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTY2MjY3MTk2NTQ1Njc2Mi1tb2Rlc3Rtb3VzZTMuanBnIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJpbnNpZGUiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogMTIwMCwgImhlaWdodCI6IDYzMH19fQ==" />
  <meta property="og:image" content="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTY2MjY3MTk2NTQ1Njc2Mi1tb2Rlc3Rtb3VzZTMuanBnIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJpbnNpZGUiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogMTIwMCwgImhlaWdodCI6IDYzMH19fQ==" />

<link rel="mask-icon" href="https://dyoeldxcrpb0a.cloudfront.net/assets/images/everout-pin-icon.svg" color="#fcdc00">

  <link rel="apple-touch-icon-precomposed" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA2MCwgImhlaWdodCI6IDYwfX19" />
  <link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA3MiwgImhlaWdodCI6IDcyfX19" />
  <link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiAxMjAsICJoZWlnaHQiOiAxMjB9fX0=" />
  <link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiAxNTIsICJoZWlnaHQiOiAxNTJ9fX0=" />



  <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
  <script>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</script>


<meta property="og:site_name" content="EverOut Seattle" />
<meta name="twitter:card" content="summary_large_image" />

  
    <meta name="twitter:site" content="@thestranger" />
  
  
    <meta property="article:publisher" content="https://www.facebook.com/strangerseattle" />
  
  
    <meta property="fb:app_id" content="43933993878"/>
  
  
    <meta property="fb:admins" content="741428065"/>
  
  
    <meta property="fb:pages" content="56439755991" />
  

<meta name="cached" content="2022-09-08 16:55:53.408783">

  </head>

  <body class="everout seattle ">
    
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MVCXDDK"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->


    <div class="flex-container wrapper">
      
      <div class="nav-stack">
        

  <div class="network-bar navbar d-none d-md-block navbar-expand-md navbar-dark bg-dark">
    <div class="container">
      <ul class="navbar-nav me-auto">
        <li class="nav-item dropdown">
          <a class="nav-link dropdown-toggle" href="#" id="networkBarDropdown" role="button" data-bs-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
            EverOut
          </a>
          <ul class="dropdown-menu" aria-labelledby="networkBarDropdown">
            <li class="dropdown-item"><a href="/" class="nav-link">Home</a></li>
            <div class="dropdown-divider"></div>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/seattle/">
                  Seattle
                </a>
              </li>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/portland/">
                  Portland
                </a>
              </li>
            
          </ul>
        </li>
        <li class="nav-item nav-item-separator">|</li>
        
          <li class="nav-item"><a class="nav-link" href="https://www.thestranger.com">The Stranger</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.portlandmercury.com">Portland Mercury</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.savagelovecast.com">Savage Love</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://humpfilmfest.com">Hump</a></li>
          
          
        
      </ul>
    </div>
  </div>


        



        <div id="mobileMemberNavContainer">
  <div class="mobile-member-bar mobile d-md-none collapse" id="mobileMemberNavTop">
    <div class="mobile-member-nav">
      <div class="nav-item"><a href="/account/profile/">Profile <i class="far fa-fw fa-user"></i></a></div>
      <div class="nav-item"><a href="/account/lists/">Lists & Likes <i class="far fa-fw fa-heart"></i></a></div>
      <div class="nav-item"><a href="/account/settings/">Account <i class="fal fa-fw fa-cog"></i></a></div>
      <div class="nav-item"><a href="/account/logout/">Log Out <i class="fal fa-fw fa-sign-out"></i></a></div>
    </div>
  </div>
</div>
<div class="top-nav desktop">
  <nav class="navbar">
    <div class="container">
      <div class="navbar-brand-container">
        <a class="navbar-brand d-inline-block seattle" href="/seattle/" alt="Seattle">
          
            <img src="https://d2i729k8wyri5w.cloudfront.net/market-159735153762325-everout-logo-seattle2.png" alt="EverOut Seattle">
          
        </a>
      </div>
      <div class="navbar-expand-md desktop-items-container">
        <ul class="nav collapse navbar-collapse justify-content-end nav-items main-nav">
          
            
          
            
          
            
              
                
  <li class="nav-item dropdown">
    <a class="nav-link dropdown-toggle" href="#" id="itemDropdown-878" role="button" data-bs-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
      Neighborhoods
    </a>
    <ul class="dropdown-menu dropdown-menu-right" aria-labelledby="itemDropdown-878">
      
        
          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/ballard/">
    
    
      Ballard
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/belltown/">
    
    
      Belltown
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/capitol-hill/">
    
    
      Capitol Hill
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/central-district/">
    
    
      Central District
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/chinatown-id/">
    
    
      Chinatown-International District
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/columbia-city-beacon-hill/">
    
    
      Columbia City/Beacon Hill
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/downtown/">
    
    
      Downtown
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/fremont/">
    
    
      Fremont
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/phinney-green-lake/">
    
    
      Phinney Ridge/Green Lake
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/pioneer-square/">
    
    
      Pioneer Square
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/queen-anne/">
    
    
      Queen Anne
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/sodo-georgetown/">
    
    
      Sodo/Georgetown
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/south-lake-union/">
    
    
      South Lake Union
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/university-district/">
    
    
      University District
    
  </a>
</li>

          
            <li class="dropdown-item  ">
  <a href="/seattle/neighborhoods/west-seattle/">
    
    
      West Seattle/White Center
    
  </a>
</li>

          
        
      
    </ul>
  </li>

<li class="nav-item separator">|</li>

              
            
          
            
              
                
  <li class="nav-item">
    <a href="https://everout.com/seattle/articles/" class="nav-link">Picks &amp; Guides</a>
  </li>

<li class="nav-item separator">|</li>

              
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
          
            
              
                
  <li class="nav-item dropdown">
    <a class="nav-link dropdown-toggle" href="#" id="itemDropdown-876" role="button" data-bs-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
      Calendars
    </a>
    <ul class="dropdown-menu dropdown-menu-right" aria-labelledby="itemDropdown-876">
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/top-events/">
    
    
      Top Events Today & This Week
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="/seattle/events">
    
    
      All Events
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/stranger-seattle/events/?type=in-person">
    
    
      In-Person Events
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?category=live-music">
    
    
      Live Music
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?category=food-drink">
    
    
      Food & Drink
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?category=readings-talks">
    
    
      Readings & Talks
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/visual-art/">
    
    
      Visual Art
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?category=festivals">
    
    
      Festivals
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?category=performance&amp;category=comedy">
    
    
      Theater & Performance
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?category=film">
    
    
      Film
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?category=activism">
    
    
      Activism & Social Justice
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/locations/?category=restaurants">
    
    
      Restaurants
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?category=restaurants&amp;feature=takeout-covid-19&amp;feature=delivery-covid-19&amp;feature=curbside-pickup&amp;feature=walk-up-ordering">
    
    
      Takeout & Delivery
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/?type=online">
    
    
      Online Events
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?feature=in-person-visits">
    
    
      Now-Open Shops & Attractions
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?category=weed-locations&amp;feature=takeout-covid-19">
    
    
      Weed Locations
    
  </a>
</li>

        
      
        
          <li class="dropdown-item  ">
  <a href="https://everout.com/seattle/events/submit/">
    
    
      Submit an Event
    
  </a>
</li>

        
      
    </ul>
  </li>



              
            
          
          <li class="nav-item dropdown member-nav" id="desktopMemberNav">
            <a href="/login/" class="member-profile-link btn btn-light">Log In</a>
          </li>
        </ul>
      </div>
      <ul class="nav mobile nav-items main-nav d-md-none mt-2">
        
          
        
          
        
          
            
              
  <li class="nav-item menu-toggler" data-bs-toggle="collapse" data-bs-target="#navbarToggle-878" aria-controls="navbarToggle-878" aria-expanded="false" aria-label="Toggle navigation">
    <a href="#" class="nav-link" onclick="return false;">Neighborhoods <i class="fa fa-caret-down"></i></a>
  </li>

<li class="nav-item separator">|</li>

            
          
        
          
            
              
  <li class="nav-item">
    <a href="https://everout.com/seattle/articles/" class="nav-link">Picks &amp; Guides</a>
  </li>

<li class="nav-item separator">|</li>

            
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
        
          
            
              
  <li class="nav-item menu-toggler" data-bs-toggle="collapse" data-bs-target="#navbarToggle-876" aria-controls="navbarToggle-876" aria-expanded="false" aria-label="Toggle navigation">
    <a href="#" class="nav-link" onclick="return false;">Calendars <i class="fa fa-caret-down"></i></a>
  </li>



            
          
        
      </ul>
      <div class="member-nav d-md-none text-end" id="mobileAvatarContainer">
        <a href="/login/" class="member-profile-link btn btn-sm btn-light me-2">Log In</a>
      </div>
      
        
          

        
      
        
          

        
      
        
          
  <div class="collapse navbar-collapse nav-items mobile d-md-none" id="navbarToggle-878">
    <div class="more-nav">
      
        
          
            <div class="nav-item   class-change ">
  <a href="/seattle/neighborhoods/ballard/">
    
    
      Ballard
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/belltown/">
    
    
      Belltown
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/capitol-hill/">
    
    
      Capitol Hill
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/central-district/">
    
    
      Central District
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/chinatown-id/">
    
    
      Chinatown-International District
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/columbia-city-beacon-hill/">
    
    
      Columbia City/Beacon Hill
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/downtown/">
    
    
      Downtown
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/fremont/">
    
    
      Fremont
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/phinney-green-lake/">
    
    
      Phinney Ridge/Green Lake
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/pioneer-square/">
    
    
      Pioneer Square
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/queen-anne/">
    
    
      Queen Anne
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/sodo-georgetown/">
    
    
      Sodo/Georgetown
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/south-lake-union/">
    
    
      South Lake Union
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/university-district/">
    
    
      University District
    
  </a>
</div>

          
            <div class="nav-item  ">
  <a href="/seattle/neighborhoods/west-seattle/">
    
    
      West Seattle/White Center
    
  </a>
</div>

          
        
      
    </div>
  </div>


        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          
  <div class="collapse navbar-collapse nav-items mobile d-md-none" id="navbarToggle-863">
    <div class="more-nav">
      
        
          <div class="nav-item   class-change ">
  <a href="category=performance-childrens-theater">
    
    
      Children's Theater
    
  </a>
</div>

        
      
    </div>
  </div>


        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          

        
      
        
          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
            

          
        
      
        
          
  <div class="collapse navbar-collapse nav-items mobile d-md-none" id="navbarToggle-876">
    <div class="more-nav">
      
        
          <div class="nav-item   class-change ">
  <a href="https://everout.com/seattle/top-events/">
    
    
      Top Events Today & This Week
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="/seattle/events">
    
    
      All Events
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/stranger-seattle/events/?type=in-person">
    
    
      In-Person Events
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?category=live-music">
    
    
      Live Music
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?category=food-drink">
    
    
      Food & Drink
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?category=readings-talks">
    
    
      Readings & Talks
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/visual-art/">
    
    
      Visual Art
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?category=festivals">
    
    
      Festivals
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?category=performance&amp;category=comedy">
    
    
      Theater & Performance
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?category=film">
    
    
      Film
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?category=activism">
    
    
      Activism & Social Justice
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/locations/?category=restaurants">
    
    
      Restaurants
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?category=restaurants&amp;feature=takeout-covid-19&amp;feature=delivery-covid-19&amp;feature=curbside-pickup&amp;feature=walk-up-ordering">
    
    
      Takeout & Delivery
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/?type=online">
    
    
      Online Events
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?feature=in-person-visits">
    
    
      Now-Open Shops & Attractions
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/stranger-seattle/locations/?category=weed-locations&amp;feature=takeout-covid-19">
    
    
      Weed Locations
    
  </a>
</div>

        
      
        
          <div class="nav-item  ">
  <a href="https://everout.com/seattle/events/submit/">
    
    
      Submit an Event
    
  </a>
</div>

        
      
    </div>
  </div>


        
      
      <script type="text/javascript">
        // ajax to reload the nav if you're logged in
        var userAuthenticated = false;
        var userId = null;
        var userLoaded = false;
        function getMemberMenu() {
          let xhr = new XMLHttpRequest();
          xhr.open('GET', `/members/menu/`);
          xhr.setRequestHeader('Content-Type', 'application/json');
          xhr.onload = function () {
            userLoaded = true;
            if (xhr.responseText) {
              response = JSON.parse(xhr.responseText);
              if (response.id) {
                userAuthenticated = true;
                userId = response.id;
                localStorage.removeItem('lists-' + userId);
                localStorage.removeItem('listskey-' + userId);
                if(typeof getAddToListMenu === "function") {
                  if (localStorage.getItem('lists') && localStorage.getItem('listskey') == response.lists_key) {
                    createAddToListMenuFromLocalStorage(userId);
                  } else {
                    getAddToListMenu();
                  }
                }
                let avatar = (response.avatar) ? `<img src="${response.avatar}" class="member-avatar">` : `<i class="fa fa-user-circle" style="position:relative;bottom:5px;"></i>`
                $('#desktopMemberNav').html(
                  `
                    <a href="#" class="member-profile-link" data-bs-toggle="dropdown" role="button" id="memberDropdownLink"><i class="far text-danger fa-heart fa-sm"></i> ${avatar}</a>
                    <ul class="dropdown-menu dropdown-menu-end" aria-labelledby="memberDropdownLink" style="z-index:9999;top:86%;right:0;">
                      <li class="dropdown-item username px-3 py-2"><a href="/account/profile/">${response.username}</a></li>
                      <li class="dropdown-item"><a href="/account/lists/"><i class="far fa-fw fa-heart text-danger"></i> Lists & Likes</a></li>
                      <li class="dropdown-item"><a href="/account/settings/"><i class="far fa-fw fa-cog"></i> Account</a></li>
                      <li class="dropdown-item"><a href="/account/logout/"><i class="far fa-fw fa-sign-out"></i> Log Out</a></li>
                    </ul>
                  `
                );
                $('#mobileAvatarContainer').html(
                  `
                    <a href="#" onclick="return false;" data-bs-toggle="collapse" data-bs-target="#mobileMemberNavTop" aria-controls="mobileMemberNavTop" aria-expanded="false" aria-label="Toggle member navigation" id="memberDropdownLink">${avatar}</a>
                  `
                )
              } else {
                localStorage.removeItem('lists')
                localStorage.removeItem('listskey')
              }
            }
          };
          xhr.send();
        }
        getMemberMenu();
      </script>
    </div>
  </nav>
</div>

        <div class="standalone-search-bar">
  <div class="search-container container" id="siteSearch">
    <span class="search-bar-label">Show Me</span>
    <input class="typeahead" type="text" placeholder="events, movies, venues, restaurants, guides..." data-sort-group="" data-site-section="">
    <i class="search-icon far fa-search"></i>

    <div role="listbox" class="default-search-panel p-3" style="display: none;" aria-expanded="false">
      <div role="presentation" class="row">
        <i class="loading-spinner fas fa-spinner fa-spin p-3"></i>
        <div class="col-6 col-sm-4 category-list">
        </div>
        <div class="col-6 col-sm-8 article-list">
        </div>
      </div>
    </div>
  </div>

  <script>
    $('.search-container .search-icon').on('click', function() {
      var market_slug = 'seattle';
      var search_value = $('.tt-input').val()
      if (search_value) {
        if (market_slug !== '') {
          window.location.href = '/' + market_slug + '/search?q=' + encodeURIComponent(search_value);
        } else {
          window.location.href = '/search?q=' + encodeURIComponent(search_value);
        }
      }
    })
  </script>
</div>

        
  <div class="trending-stories-bar">
    <div class="container">
      <div class="row g-0">
        <div class="col-md-auto d-none d-md-block">
          <div class="trending-stories-item indicator me-2"><i class="fad fa-branded fa-chevron-double-right"></i><i class="fad fa-branded fa-chevron-double-right"></i></div>
        </div>
        
          <div class="col-auto mb-2 mb-md-0">
            <a class="trending-stories-item me-2" href="https://everout.com/seattle/top-events/">🗓   Top Things To Do Today &amp; This Week</a>
          </div>
        
          <div class="col-auto mb-2 mb-md-0">
            <a class="trending-stories-item me-2" href="https://everout.com/seattle/articles/where-to-find-mooncakes-and-more-for-the-2022-mid-autumn-festival-in-seattle/c4517/">🥮 Mooncakes</a>
          </div>
        
          <div class="col-auto mb-2 mb-md-0">
            <a class="trending-stories-item me-2" href="https://everout.com/seattle/events/?category=hispanic-heritage-month">💃🏽 Hispanic Heritage Month</a>
          </div>
        
          <div class="col-auto mb-2 mb-md-0">
            <a class="trending-stories-item me-2" href="https://everout.com/seattle/music/">🎵 Live Music</a>
          </div>
        
          <div class="col-auto mb-2 mb-md-0">
            <a class="trending-stories-item me-2" href="https://everout.com/seattle/food/">🍜  Food &amp; Drink</a>
          </div>
        
          <div class="col-auto mb-2 mb-md-0">
            <a class="trending-stories-item me-2" href="https://everout.com/seattle/reviews/">⭐️ Stranger Reviews</a>
          </div>
        
      </div>
    </div>
  </div>


        
      </div>

      
        <div class="top-super text-center container">
          

  
    
  

  
    
  

  
    
      
        <div id='EverOut-Seattle-Default-EverOut-TopPage-Top' class="mb-3 text-center ad-placement " style="display:none;">
          <script>
            googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Default-EverOut-TopPage-Top'); });
          </script>
        </div>
      
    
  

  
    
      
        <div id='EverOut-Seattle-Default-EverOut-Mobile-TopPage-Top' class="mb-3 text-center ad-placement " style="display:none;">
          <script>
            googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Default-EverOut-Mobile-TopPage-Top'); });
          </script>
        </div>
      
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  


        </div>
      

      <div class="container main-container">
        

        <div class="row main">
          
          <div class="col-md-8 primary">
            <header>
              
  <div class="row">
  <div class="col ttd-breadcrumbs">
    
      <a href="/seattle/">Seattle</a>
    
    <span class="breadcrumb-delimiter">&gt;</span>
    
      
        <a href="/seattle/articles/" class="">Picks &amp; Guides</a>
      
      
    
  </div>
</div>


            </header>

            <div class="content">
              
  <div class="item-detail article">
    <article>
      
      <header class="mb-2">
        
          
            <a class="category-tag" href="/seattle/articles/?category=event-news">Event News</a>
          
        
        <h1>
          Ticket Alert: Modest Mouse, Burna Boy, and More Seattle Events Going On Sale This Week
        </h1>
        <div class="subhead">
          Plus, Flo Milli and Event Updates for Sept 8
        </div>
        
          <div class="author">
            by <a href="https://everout.com/seattle/authors/audrey-vann/w271/">Audrey Vann</a> and <a href="https://everout.com/portland/authors/lindsay-costello/w272/">Lindsay Costello</a>
          </div>
        
        
          <div class="published-date">
            September 8, 2022
          </div>
        
        

  
    
      
        <div id='EverOut-Seattle-Default-EverOut-Article-SponsorSponsor-Header' class="mb-3 text-center ad-placement mt-3" style="display:none;">
          <script>
            googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Default-EverOut-Article-SponsorSponsor-Header'); });
          </script>
        </div>
      
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  


        


<div class="item-tools d-flex justify-content-around mt-2 p-2 p-md-1">
  <div class="d-flex align-items-center flex-column flex-md-row item-tool" style="transform: rotate(0);">
    <a href="#" class="like-btn stretched-link px-2" data-model="editorial.article" data-oid="4525" data-like-count="0">
      <i class="far fa-lg fa-heart like-btn-heart"></i>
    </a>
    <span class="item-tools-label">
      Like
      <small class="like-btn-count text-muted">
        0
      </small>
    </span>
  </div>
  <div class="d-flex align-items-center flex-column flex-md-row item-tool" style="transform: rotate(0);">
    <div class="atl-button-skelly"></div>
    <div class="atl-button-container d-flex align-items-center flex-column flex-md-row" style="display:none;">
      <a href="#" class="add-to-list-btn stretched-link px-2" data-bs-toggle="offcanvas" data-bs-target="#addToListSheet"
        aria-controls="addToListSheet" data-model="editorial.article" data-oid="4525"
        data-object-name="Ticket Alert: Modest Mouse, Burna Boy, and More Seattle Events Going On Sale This Week ">
        <i class="fad fa-lg fa-plus-square fa-branded"></i>
      </a>
      <span class="item-tools-label">Add to a List</span>
    </div>
  </div>
  <div class="d-flex align-items-center flex-column flex-md-row">
    <div class="d-flex justify-content-evenly share-services">
      <div class="facebook-this share-tool">
    <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A//everout.com/articles/ticket-alert-modest-mouse-burna-boy-and-more-seattle-events-going-on-sale-this-week/c4525/" class="share-link new-window" target="_blank"><i class="fab fa-lg fa-facebook pe-2"></i></a>
</div>

      <div class="tweet-this share-tool">
    <a href="https://twitter.com/intent/tweet?text=Ticket%20Alert%3A%20Modest%20Mouse%2C%20Burna%20Boy%2C%20and%20More%20Seattle%20Events%20Going%20On%20Sale%20This%20Week%2C%20from%20EverOut%20https%3A//everout.com/articles/ticket-alert-modest-mouse-burna-boy-and-more-seattle-events-going-on-sale-this-week/c4525/" class="share-link new-window" target="_blank"><i class="fab fa-lg fa-twitter pe-2"></i></a>
</div>

      <div class="mail-this share-tool">
    <a href="mailto:?subject=Ticket%20Alert%3A%20Modest%20Mouse%2C%20Burna%20Boy%2C%20and%20More%20Seattle%20Events%20Going%20On%20Sale%20This%20Week%2C%20from%20EverOut&body=Ticket%20Alert%3A%20Modest%20Mouse%2C%20Burna%20Boy%2C%20and%20More%20Seattle%20Events%20Going%20On%20Sale%20This%20Week%2C%20from%20EverOut%20https%3A//everout.com/articles/ticket-alert-modest-mouse-burna-boy-and-more-seattle-events-going-on-sale-this-week/c4525/"><i class="fas fa-lg fa-envelope"></i></a>
</div>

    </div>
    <span class="item-tools-label d-md-none">Share</span>
  </div>
</div>
<div class="item-on-lists-bar bg-light text-center fs-7 py-1" id="itemListBar-c4525" style="display:none;"></div>

      </header>
      
        <div class="lead-image my-3">
          <img class="img-responsive" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTY2MjY3MTk2NTQ1Njc2Mi1tb2Rlc3Rtb3VzZTMuanBnIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJpbnNpZGUiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogMTAyNCwgImhlaWdodCI6IDgwMH19fQ== ">
          
            <div class="caption">
              Did you know: The Westin Seattle graces the cover of <a href="https://everout.com/seattle/events/modest-mouse-the-lonesome-crowded-west-tour/e127736/">Modest Mouse</a>'s second album, <em>The Lonesome Crowded West</em>?
              
                <span class="credit">
                  (Modest Mouse via Facebook)
                </span>
              
            </div>
          
        </div>
      
      <div class="body-text">
        
          
            
              <div class="no-item-tools"><span style="font-weight: 400;">Issaquah-born rock band </span><a href="https://everout.com/seattle/events/modest-mouse-the-lonesome-crowded-west-tour/e127736/"><span style="font-weight: 400;">Modest Mouse</span></a><span style="font-weight: 400;"> will float on over to Seattle during their Lonesome Crowded West tour to celebrate the 25th anniversary of their second album. Grammy Award-winning Afrobeat star </span><a href="https://everout.com/seattle/events/burna-boy-love-damini-tour/e127734/"><span style="font-weight: 400;">Burna Boy</span></a><span style="font-weight: 400;"> has announced a stop in Kent this October. Plus, viral rapper </span><a href="https://everout.com/seattle/events/flo-milli-girls-just-wanna-have-fun-tour/e127746/"><span style="font-weight: 400;">Flo Milli</span></a><span style="font-weight: 400;"> will stop by in support of her new album, </span><em><span style="font-weight: 400;">You Still Here, Ho</span></em><span style="font-weight: 400;">? </span><span style="font-weight: 400;">Read on for details on those and other newly announced events, plus some news you can use.</span></div>
<p><em><span style="font-weight: 400;"><br/>Tickets go on sale at 10 am unless otherwise noted.</span></em></p>
            
          
            
              
<h3 class="highlighted section-header">ON SALE FRIDAY, SEPTEMBER 9</h3>
<p><span style="text-decoration: underline;"><span style="font-weight: 400;">MUSIC</span></span></p>
            
          
            
              
<p><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="127734" href="https://everout.com/seattle/events/burna-boy-love-damini-tour/e127734/"><strong>Burna Boy: Love, Damini Tour</strong></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="127734">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="127734">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<br/><em><span style="font-weight: 400;">accesso ShoWare Center (Sat Oct 8)</span></em></p>
            
          
            
              

  

  

  

  

  
    
      
        <div id='EverOut-Seattle-Default-EverOut-Native-Inline-1Native-Inline' class="mb-3 text-center ad-placement article-inline" style="display:none;">
          <script>
            googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Default-EverOut-Native-Inline-1Native-Inline'); });
          </script>
        </div>
      
    
  

  

  

  

  

  

  

  


            
          
            
              
<p><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="127735" href="https://everout.com/seattle/events/charley-crockett-the-man-from-waco/e127735/"><strong>Charley Crockett: The Man From Waco</strong></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="127735">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="127735">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<br/><em><span style="font-weight: 400;">Showbox SoDo (Tues Dec 6)</span></em></p>
            
          
            
              
<p><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="127745" href="https://everout.com/seattle/events/courtney-marie-andrews/e127745/"><strong>Courtney Marie Andrews</strong></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="127745">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="127745">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<br/><em><span style="font-weight: 400;">Neumos (Thurs Dec 8)</span></em></p>
            
          
            
              
<p><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="127746" href="https://everout.com/seattle/events/flo-milli-girls-just-wanna-have-fun-tour/e127746/"><strong>Flo Milli: Girls Just Wanna Have Fun Tour</strong></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="127746">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="127746">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<br/><em><span style="font-weight: 400;">Neumos (Tues Nov 8)</span></em></p>
            
          
            
              

  

  

  

  

  

  

  
    
      
        <div id='EverOut-Seattle-Default-EverOut-Native-Inline-2Native-Inline' class="mb-3 text-center ad-placement article-inline" style="display:none;">
          <script>
            googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Default-EverOut-Native-Inline-2Native-Inline'); });
          </script>
        </div>
      
    
  

  

  

  

  

  


            
          
            
              
<p><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="127736" href="https://everout.com/seattle/events/modest-mouse-the-lonesome-crowded-west-tour/e127736/"><strong>Modest Mouse: The Lonesome Crowded West Tour</strong></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="127736">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="127736">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<br/><em><span style="font-weight: 400;">The Showbox (Nov 21-22)</span></em></p>
            
          
            
              

  
    
  

  
    
      
        <div id='EverOut-Seattle-Default-EverOut-Sidebar-1Inline-1' class="mb-3 text-center ad-placement inline-ad" style="display:none;">
          <script>
            googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Default-EverOut-Sidebar-1Inline-1'); });
          </script>
        </div>
      
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  


            
          
            
              
<p><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="127737" href="https://everout.com/seattle/events/seattles-tribute-to-the-last-waltz/e127737/"><strong>Seattle's Tribute to The Last Waltz</strong></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="127737">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="127737">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<br/><em><span style="font-weight: 400;">Neptune Theatre (Fri Nov 25)</span></em></p>
            
          
            
              
<p><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="120747" href="https://everout.com/seattle/events/vance-joy/e120747/"><strong>Vance Joy</strong></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="120747">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="120747">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<strong> *second show added*<br/></strong><em><span style="font-weight: 400;">Paramount Theatre (March 4, 2023)</span></em></p>
            
          
            
              

  

  

  

  

  

  

  

  

  

  
    
      
        <div id='EverOut-Seattle-Default-EverOut-Native-Inline-3Native-Inline' class="mb-3 text-center ad-placement article-inline" style="display:none;">
          <script>
            googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Default-EverOut-Native-Inline-3Native-Inline'); });
          </script>
        </div>
      
    
  

  

  


            
          
            
              
<p><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="127738" href="https://everout.com/seattle/events/the-white-buffalo/e127738/"><strong>The White Buffalo</strong></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="127738">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="127738">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<br/><em><span style="font-weight: 400;">The Showbox (Wed Dec 7)</span></em></p>
            
          
            
              
<h3 class="highlighted section-header">ON SALE NOW</h3>
<p><span style="text-decoration: underline;"><span style="font-weight: 400;">COMEDY</span></span></p>
            
          
            
              
<p><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="127791" href="https://everout.com/seattle/events/dan-cummins-burn-it-all-down-tour/e127791/"><strong>Dan Cummins: Burn It All Down Tour</strong></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="127791">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="127791">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<br/><em><span style="font-weight: 400;">Neptune Theatre (Mar 4, 2023)</span></em></p>
            
          
            
              
<h3 class="highlighted section-header">ON SALE NEXT WEEK</h3>
<p><span style="text-decoration: underline;"><span style="font-weight: 400;">MUSIC</span></span></p>
            
          
            
              
<p><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="127744" href="https://everout.com/seattle/events/dry-cleaning/e127744/"><strong>Dry Cleaning</strong></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="127744">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="127744">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<br/><em><span style="font-weight: 400;">Neptune Theatre (Jan 18, 2023)<br/></span></em><strong>On sale Wed Sept 14</strong></p>
            
          
            
              

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
      
        <div id='EverOut-Seattle-Default-EverOut-Sidebar-2Inline-2' class="mb-3 text-center ad-placement inline-ad" style="display:none;">
          <script>
            googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Default-EverOut-Sidebar-2Inline-2'); });
          </script>
        </div>
      
    
  

  
    
  

  
    
  

  
    
      
        <div id='EverOut-Seattle-Default-EverOut-Sidebar-3Inline-2' class="mb-3 text-center ad-placement inline-ad" style="display:none;">
          <script>
            googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Default-EverOut-Sidebar-3Inline-2'); });
          </script>
        </div>
      
    
  


            
          
            
              
<h3 class="highlighted section-header">EVENT UPDATES</h3>
<p><span style="text-decoration: underline;"><span style="font-weight: 400;">MUSIC</span></span></p>
            
          
            
              
<p><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="120728" href="https://everout.com/seattle/events/dead-can-dance/e120728/"><strong>Dead Can Dance</strong></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="120728">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="120728">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<strong> *canceled*<br/></strong><em><span style="font-weight: 400;">Paramount Theatre (Mar 26, 2023)</span></em></p>
            
          
            
              
<p><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="114797" href="https://everout.com/seattle/events/ibeyi-spell-31-tour/e114797/"><strong>Ibeyi</strong></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="114797">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="114797">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<br/><em><span style="font-weight: 400;">Moved to The Crocodile from the Neptune Theatre (Rescheduled to Mar 15, 2023 from Sept 21)</span></em></p>
            
          
            
              
<h3 class="highlighted section-header">OTHER ANNOUNCEMENTS</h3>
<p><span style="font-weight: 400;">Spectrum Dance Theater has announced its </span><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="127785" href="https://everout.com/seattle/events/spectrum-dance-theater-2022-23-season/e127785/"><span style="font-weight: 400;">2022/23 season</span></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="127785">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="127785">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<span style="font-weight: 400;">, including experimental work </span><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="127783" href="https://everout.com/seattle/events/occurrence-11/e127783/"><em><span style="font-weight: 400;">Occurrence 11</span></em></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="127783">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="127783">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<span style="font-weight: 400;"> and a </span><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="127784" href="https://everout.com/seattle/events/harlem-nutcracker-teaser/e127784/"><span style="font-weight: 400;">“teaser” performance</span></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="127784">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="127784">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<span style="font-weight: 400;"> of forthcoming show </span><em><span style="font-weight: 400;">The Harlem Nutcracker.</span></em></p>
            
          
            
              
<p><span style="font-weight: 400;">Base: Experimental Arts + Space has announced its </span><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="127796" href="https://everout.com/seattle/events/base-2022-23-season/e127796/"><span style="font-weight: 400;">2022/23 programming</span></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="127796">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="127796">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<span style="font-weight: 400;">, including a new round-up of resident artists, </span><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="127787" href="https://everout.com/seattle/events/base-residency-open-houses/e127787/"><span style="font-weight: 400;">free open houses</span></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="127787">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="127787">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<span style="font-weight: 400;">, and </span><a class="add-to-list-link" data-model="attractions.occurrence" data-oid="127788" href="https://everout.com/seattle/events/12-minutes-max/e127788/"><span style="font-weight: 400;">12 Minutes Max</span></a>
<span class="article-item-tools ps-2 pe-2">
<a class="inline-like-button like-btn" data-model="attractions.occurrence" data-object-name="" data-oid="127788">
<i class="far fa-heart like-btn-heart"></i>
<span class="item-tools-label ps-md-1">Like</span>
</a>
<a aria-controls="addToListSheet" class="inline-atl-button add-to-list-btn ms-1" data-bs-target="#addToListSheet" data-bs-toggle="offcanvas" data-model="attractions.occurrence" data-object-name="" data-oid="127788">
<i class="fad fa-plus-square fa-branded"></i>
<span class="item-tools-label ps-md-1">Add to a List</span>
</a>
</span>
<span style="font-weight: 400;">, a performance series of works-in-progress.</span></p>
            
          
            
              </p>
            
          
        
      </div>
    </article>
    
      


  <div class="related-articles border-top mt-4 pt-2">
    <h2 class="pt-4 mb-2 section-header highlighted">You Might Also Like</h2>
    <div class="row row-cols-2 row-cols-md-3 no-gutters">
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/ticket-alert-modest-mouse-burna-boy-and-more-seattle-events-going-on-sale-this-week/c4525/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTY2MjY3MTk2NTQ1Njc2Mi1tb2Rlc3Rtb3VzZTMuanBnIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJjb3ZlciIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA0MDAsICJoZWlnaHQiOiAzMDB9fX0="></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/ticket-alert-modest-mouse-burna-boy-and-more-seattle-events-going-on-sale-this-week/c4525/">Ticket Alert: Modest Mouse, Burna Boy, and More Seattle Events Going On Sale This Week</a>
              </div>
              
                <h6 class="card-subtitle mb-2">Plus, Flo Milli and Event Updates for Sept 8</h6>
              
            </div>
          </div>
        </div>
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/get-lost-in-tomo-nakayamas-dazzling-dance-pop/c4528/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTY2MjY1NzI3NDM1NjQxNS10b21vcHJlc3MuanBlZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY292ZXIiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogNDAwLCAiaGVpZ2h0IjogMzAwfX19"></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/get-lost-in-tomo-nakayamas-dazzling-dance-pop/c4528/">Get Lost in Tomo Nakayama's Dazzling Dance Pop</a>
              </div>
              
                <h6 class="card-subtitle mb-2">Nakayama kicks off his West Coast tour Thursday night at The Triple Door</h6>
              
            </div>
          </div>
        </div>
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/the-last-word-a-new-column-about-cocktails/c4521/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTY2MjUwMDk3MTU2MTcxOS1iYWtlcnNjb2NrdGFpbC5qcGVnIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJjb3ZlciIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA0MDAsICJoZWlnaHQiOiAzMDB9fX0="></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/the-last-word-a-new-column-about-cocktails/c4521/">The Last Word: A New Column about Cocktails!</a>
              </div>
              
                <h6 class="card-subtitle mb-2">Baker&amp;rsquo;s Has a Summery Bring It On-Themed Cocktail List and the East Compton Clovers Is Totally Its Squad Captain</h6>
              
            </div>
          </div>
        </div>
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/where-to-find-mooncakes-and-more-for-the-2022-mid-autumn-festival-in-seattle/c4517/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTY2MjU3NjUyNjMyMTQ2NS1TY3JlZW5fU2hvdF8yMDIyLTA5LTA3X2F0XzExLjQ2LjQ4X0FNLnBuZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY292ZXIiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogNDAwLCAiaGVpZ2h0IjogMzAwfX19"></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/where-to-find-mooncakes-and-more-for-the-2022-mid-autumn-festival-in-seattle/c4517/">Where to Find Mooncakes and More for the 2022 Mid-Autumn Festival in Seattle</a>
              </div>
              
                <h6 class="card-subtitle mb-2">T55, Lucky Envelope, and More</h6>
              
            </div>
          </div>
        </div>
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/concert-review-nyc-post-punks-bush-tetras-are-still-funky-after-all-these-years/c4523/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTY2MjUwMTYzMzYxNTIxOC1TY3JlZW5fU2hvdF8yMDIyLTA5LTA2X2F0XzIuNTkuMjhfUE0ucG5nIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJjb3ZlciIsICJwb3NpdGlvbiI6ICJjZW50cmUiLCAid2lkdGgiOiA0MDAsICJoZWlnaHQiOiAzMDB9fX0="></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/concert-review-nyc-post-punks-bush-tetras-are-still-funky-after-all-these-years/c4523/">Concert Review: NYC Post-Punks Bush Tetras Are Still Funky After All These Years</a>
              </div>
              
                <h6 class="card-subtitle mb-2">Their long-awaited return to Seattle was totally worth the wait.</h6>
              
            </div>
          </div>
        </div>
      
        <div class="col mb-4">
          <div class="card h-100">
            <a href="https://everout.com/seattle/articles/the-top-66-events-in-seattle-this-week-sept-6-11-2022/c4515/"><img class="card-img-top" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTY2MjQzNTA0MTI1MDc5LWZsdW1lLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY292ZXIiLCAicG9zaXRpb24iOiAiY2VudHJlIiwgIndpZHRoIjogNDAwLCAiaGVpZ2h0IjogMzAwfX19"></a>
            <div class="card-body">
              <div class="card-title">
                <a class="headline" href="https://everout.com/seattle/articles/the-top-66-events-in-seattle-this-week-sept-6-11-2022/c4515/">The Top 66 Events in Seattle This Week: Sept 6-11, 2022</a>
              </div>
              
                <h6 class="card-subtitle mb-2">Flume, Wanda Sykes, and More Top Picks</h6>
              
            </div>
          </div>
        </div>
      
    </div>
  </div>


    
  </div>

            </div>
          </div>
          <div class="col-md-4 secondary">
            
  <div id="adSpaceSidebarModule" class="adspace sidebar-module sidebar-module-inset sticky">
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
      
        <div id='EverOut-Seattle-Default-EverOut-Sidebar-1Sidebar' class="mb-3 text-center ad-placement " style="display:none;">
          <script>
            googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Default-EverOut-Sidebar-1Sidebar'); });
          </script>
        </div>
      
    
  

  
    
  

  
    
      
        <div id='EverOut-Seattle-Default-EverOut-Sidebar-2Sidebar' class="mb-3 text-center ad-placement " style="display:none;">
          <script>
            googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Default-EverOut-Sidebar-2Sidebar'); });
          </script>
        </div>
      
    
  

  
    
  

  
    
  

  
    
      
        <div id='EverOut-Seattle-Default-EverOut-Sidebar-3Sidebar' class="mb-3 text-center ad-placement " style="display:none;">
          <script>
            googletag.cmd.push(function() { googletag.display('EverOut-Seattle-Default-EverOut-Sidebar-3Sidebar'); });
          </script>
        </div>
      
    
  

  
    
  


</div>


          </div>
          
        </div>
      </div>
    </div>
    <footer class="mt-4">
      <div class="site-footer">
  <!-- desktop footer -->
  <div class="d-none d-md-block">
    <div class="footer-top-block">
  <div class="container">
    
      

<div class="component email-sign-up ">
  <div class="container text-center">
    
      <h1>Subscribe to our Newsletter</h1>
    
    
      <div class="copy">
        <p>Stay in the loop about the best things to do in Seattle every week!</p>
      </div>
    
    <form id="mc-embedded-subscribe-form" class="form" action="https://everout.us4.list-manage.com/subscribe/post?u=d7708ba310556d83ed7895c57&amp;id=01ccd644f5" method="post" name="" target="_blank">
      <div class="row g-3 align-items-center">
        <div class="col-md-8 offset-md-1"><input class="form-control mb-2 me-sm-2 email-input" name="EMAIL" type="email" placeholder="Email Address" /></div>
        
          
            <input type="hidden" value="1" name="group[71361][1]">
          
        
        <div class="col-md-2"><button class="btn btn-primary mb-2 submit-button" style="width:100%;" type="submit">Sign Up</button></div>
        <div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_d7708ba310556d83ed7895c57_01ccd644f5" type="text" value="" /></div>
      </div>
      <script>
        function setCityValue() {
          if ($('#citySelect').val() == 'seattle') {
            $('#citySelectValue').attr('name', 'group[71361][1]');
            $('#citySelectValue').val(1);
          } else if ($('#citySelect').val() == 'portland') {
            $('#citySelectValue').attr('name', 'group[71361][2]');
            $('#citySelectValue').val(2);
          }
        }
        $(function () {
          setCityValue();
        });
      </script>
    </form>
  </div>
</div>

    
    
      <div class="footer-row row">
        <div class="col-md">
          <div class="col-sm text-center">
            <div class="footer-social-links mt-0">
              <h2>Follow Us</h2>
              
                <a href="https://www.twitter.com/everoutseattle" target="_blank"><i class="fab fa-twitter"></i></a>
              
                <a href="http://www.facebook.com/everoutseattle" target="_blank"><i class="fab fa-facebook-f"></i></a>
              
                <a href="https://instagram.com/everoutseattle" target="_blank"><i class="fab fa-instagram"></i></a>
              
            </div>
          </div>
        </div>
      </div>
    
  </div>
</div>
<div class="footer-bottom-block">
  <div class="container">
    <div class="footer-row row">
      <div class="col-md">
        <div class="footer-brand">
  <a class="navbar-brand" href="https://everout.com/seattle/"><img src="/assets/images/everout-logo-yellow.png" alt="EverOut"></a>
</div>

      </div>
      <div class="col-md-8">
        
          <p class="footer-links text-end pipe-delimited-links">
            
              <span><a href="/about/">About</a></span>
            
              <span><a href="/contact-us/">Contact</a></span>
            
              <span><a href="/follow-us/">Follow Us</a></span>
            
              <span><a href="/FAQ/">FAQ</a></span>
            
              <span><a href="/privacy-policy/">Privacy Policy</a></span>
            
              <span><a href="/terms-of-use/">Terms of Use</a></span>
            
              <span><a href="/takedown-policy/">Takedown Policy</a></span>
            
              <span><a href="https://everout.com/masthead/">Our Team</a></span>
            
              <span><a href="https://everout.com/seattle/events/submit/">Submit an Event</a></span>
            
          </p>
        
      </div>
    </div>
    <div class="row">
      <div class="col">
        <p>
  All contents © Index Newspapers, LLC. 2022<br>
  800 Maynard Ave S, Ste 200, Seattle, WA 98134
</p>

      </div>
    </div>
  </div>
</div> <!-- end footer copyright desktop-->

  </div><!-- end desktop footer -->

  <!-- mobile footer -->
  <div class="d-md-none">
    <!-- mobile footer -->
<div class="footer-mobile">
  <div class="footer-top-block mb-4">
    
      

<div class="component email-sign-up ">
  <div class="container text-center">
    
      <h1>Subscribe to our Newsletter</h1>
    
    
      <div class="copy">
        <p>Stay in the loop about the best things to do in Seattle every week!</p>
      </div>
    
    <form id="mc-embedded-subscribe-form" class="form" action="https://everout.us4.list-manage.com/subscribe/post?u=d7708ba310556d83ed7895c57&amp;id=01ccd644f5" method="post" name="" target="_blank">
      <div class="row g-3 align-items-center">
        <div class="col-md-8 offset-md-1"><input class="form-control mb-2 me-sm-2 email-input" name="EMAIL" type="email" placeholder="Email Address" /></div>
        
          
            <input type="hidden" value="1" name="group[71361][1]">
          
        
        <div class="col-md-2"><button class="btn btn-primary mb-2 submit-button" style="width:100%;" type="submit">Sign Up</button></div>
        <div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_d7708ba310556d83ed7895c57_01ccd644f5" type="text" value="" /></div>
      </div>
      <script>
        function setCityValue() {
          if ($('#citySelect').val() == 'seattle') {
            $('#citySelectValue').attr('name', 'group[71361][1]');
            $('#citySelectValue').val(1);
          } else if ($('#citySelect').val() == 'portland') {
            $('#citySelectValue').attr('name', 'group[71361][2]');
            $('#citySelectValue').val(2);
          }
        }
        $(function () {
          setCityValue();
        });
      </script>
    </form>
  </div>
</div>

    
    
      <div class="footer-row row g-0">
        <div class="col-md">
          <div class="col-sm text-center">
            <div class="footer-social-links mt-0">
              <h2>Follow Us</h2>
              
                <a href="https://www.twitter.com/everoutseattle" target="_blank"><i class="fab fa-twitter"></i></a>
              
                <a href="http://www.facebook.com/everoutseattle" target="_blank"><i class="fab fa-facebook-f"></i></a>
              
                <a href="https://instagram.com/everoutseattle" target="_blank"><i class="fab fa-instagram"></i></a>
              
            </div>
          </div>
        </div>
      </div>
    
  </div>
  <div class="container">
    <div class="footer-row row">
      <div class="col-sm text-center">
        <div class="footer-brand">
  <a class="navbar-brand" href="https://everout.com/seattle/"><img src="/assets/images/everout-logo-yellow.png" alt="EverOut"></a>
</div>

        <p>
  All contents © Index Newspapers, LLC. 2022<br>
  800 Maynard Ave S, Ste 200, Seattle, WA 98134
</p>

        
          <p class="footer-links pipe-delimited-links">
            <small>
              
                <span><a href="/about/">About</a></span>
              
                <span><a href="/contact-us/">Contact</a></span>
              
                <span><a href="/follow-us/">Follow Us</a></span>
              
                <span><a href="/FAQ/">FAQ</a></span>
              
                <span><a href="/privacy-policy/">Privacy Policy</a></span>
              
                <span><a href="/terms-of-use/">Terms of Use</a></span>
              
                <span><a href="/takedown-policy/">Takedown Policy</a></span>
              
                <span><a href="https://everout.com/masthead/">Our Team</a></span>
              
                <span><a href="https://everout.com/seattle/events/submit/">Submit an Event</a></span>
              
            </small>
          </p>
        
      </div>
    </div>
  </div>
</div><!-- end mobile footer -->

  </div><!-- end mobile footer -->
</div><!-- end footer -->

      

  <div class="network-bar navbar d-md-none navbar-dark bg-dark">
    <div class="container">
      <ul class="navbar-nav me-auto">
        <li class="nav-item dropdown">
          <a class="nav-link dropdown-toggle" href="#" id="networkBarDropdown" role="button" data-bs-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
            EverOut
          </a>
          <ul class="dropdown-menu" aria-labelledby="networkBarDropdown">
            <li class="dropdown-item"><a href="/" class="nav-link">Home</a></li>
            <div class="dropdown-divider"></div>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/seattle/">
                  Seattle
                </a>
              </li>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/portland/">
                  Portland
                </a>
              </li>
            
          </ul>
        </li>
        <li class="nav-item nav-item-separator">|</li>
        
          <li class="nav-item"><a class="nav-link" href="https://www.thestranger.com">The Stranger</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.portlandmercury.com">Portland Mercury</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.savagelovecast.com">Savage Love</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://humpfilmfest.com">Hump</a></li>
          
          
        
      </ul>
    </div>
  </div>


      
    </footer>
    <div class="report-sheet offcanvas-sheet offcanvas offcanvas-bottom text-start h-auto" tabindex="-1" id="reportSheet" aria-labelledby="reportSheetLabel">
  <div class="offcanvas-header-wrapper g-0">
    <div class="container">
      <div class="offcanvas-header py-2">
        <h3 class="offcanvas-title" id="reportSheetLabel">
          <div class="report-title-container">
            <div class="report-title display-item">
              Report This
            </div>
          </div>
        </h3>
        <button type="button" class="btn-close text-reset" data-bs-dismiss="offcanvas" aria-label="Close"></button>
      </div>
    </div>
  </div>
  <div class="container g-0">
    <div class="offcanvas-body">
      <div class="report-body">
        <p class="fs-6">
          Please use this form to let us know about anything that violates our <a href="/terms-of-use">Terms of Use</a> or is otherwise no good.
          <br>
          Thanks for helping us keep EverOut a nice place.
        </p>
        <input type="hidden" name="model" value="">
        <input type="hidden" name="oid" value="">
        <label for="sender" class="form-label">Your Email</label>
        <div class="fs-6"></div>
        <label for="reportItem" class="form-label">Message</label>
        <textarea class="form-control" id="reportItem" rows="4" name="report" required></textarea>
        <div class="form-text fs-6">Please include links to specific policy violations if relevant.</div>
        <button type="submit" class="btn btn-primary btn-lg mt-3" onClick="sendReport();return false;">Report</button>
      </div>
      <div class="success-body text-center" style="display:none;">
        <i class="fad fa-branded fa-thumbs-up fa-3x" aria-hidden="true"></i>
        <h1>Thank You!</h1>
        <h3>Our moderators will look into this right away.</h3>
        <div class="mt-3 success-message"></div>
        <div class="mb-3">
          <button type="button" class="btn btn-secondary" data-bs-dismiss="offcanvas" aria-label="Close">Close</button>
        </div>
      </div>
      <div class="error-body" style="display:none;">
        <p class="error-message">
          Whoops! There was a problem sending this report. Please try again later.
        </p>
        <div class="mb-3">
          <button type="button" class="btn btn-secondary btn-sm" data-bs-dismiss="offcanvas" aria-label="Close">Okay</button>
        </div>
      </div>
    </div>
  </div>
</div>

    <div class="login-sheet offcanvas-sheet offcanvas offcanvas-bottom text-start h-auto" tabindex="-1" id="loginSheet" aria-labelledby="loginSheetLabel">
  <div class="offcanvas-header-wrapper g-0">
    <div class="container">
      <div class="offcanvas-header py-2">
        <h3 class="offcanvas-title" id="loginSheetLabel">
          <div class="login-title">Log In</div>
        </h3>
        <button type="button" class="btn-close text-reset" data-bs-dismiss="offcanvas" aria-label="Close"></button>
      </div>
    </div>
  </div>
  <div class="container g-0">
    <div class="offcanvas-body">
      <div class="login-body pb-4">
        <div class="fs-4 px-0 mx-0 px-md-5 mx-md-5 text-center" style="line-height:1.2;">
          Log in to like events and restaurants, create your own lists of all your favorite things, make plans with your friends, and more. It's free!
        </div>
        <div class="row justify-content-center mt-4">
          <div class="col-md-4 col-12 text-center mb-3 mb-md-0">
            <a class="btn btn-primary btn-lg d-block" href="/login/?next=/seattle/articles/ticket-alert-modest-mouse-burna-boy-and-more-seattle-events-going-on-sale-this-week/c4525/">Log In</a>
          </div>
          <div class="col-md-4 col-12 text-center">
            <a class="btn btn-primary btn-lg d-block" href="/signup/?next=/seattle/articles/ticket-alert-modest-mouse-burna-boy-and-more-seattle-events-going-on-sale-this-week/c4525/">Sign Up for Free</a>
          </div>
        </div>
      </div>
    </div>
  </div>
</div>

    <style type="text/css">
  .skelly {
    background: rgba(0, 0, 0, .2);
    min-width: 300px;
  }
  .add-title-skelly {
    height: 1em;
  }
  .list-wrapper-skelly {
    height: 240px;
    display: flex;
    align-items: center;
    justify-content: center;
  }
</style>
<div class="add-to-list-sheet offcanvas-sheet offcanvas offcanvas-bottom text-start h-auto" tabindex="-1" id="addToListSheet" aria-labelledby="addToListSheetLabel">
  <div class="offcanvas-header-wrapper g-0">
    <div class="container">
      <div class="offcanvas-header py-2">
        <h3 class="offcanvas-title" id="addToListSheetLabel">
          <div class="add-title-container">
            <div class="add-title display-item" style="display:none;">
              Adding <span class="object-name text-link"></span> to a list
            </div>
            <div class="add-title-skelly skelly"></div>
          </div>
        </h3>
        <button type="button" class="btn-close text-reset" data-bs-dismiss="offcanvas" aria-label="Close"></button>
      </div>
    </div>
  </div>
  <div class="container g-0">
    <div class="offcanvas-body">
      <div class="add-body">
        <div class="member-alert success fs-5 mb-3" id="newUserListIntro" style="display:none;">
          EverOut lists are a great tool for crafting weekend itineraries, curating restaurant recommendations for your out-of-town friends, and so much more! Endlessly customizable, you can mix and match events, locations, and articles, or keep them separate. You can even invite your friends to contribute to your lists!
        </div>
        <input type="hidden" name="model" value="">
        <input type="hidden" name="oid" value="">
        <input type="hidden" name="object_name" value="">
        <div class="list-wrapper-skelly skelly">
          <div class="lds-ripple"><div></div><div></div></div>
        </div>
        <div class="list-wrapper display-item" style="display:none;">
          <div class="list-select-row new-list mb-1 bg-light">
            <div class="form-check">
              <input class="form-check-input" type="checkbox" id="listCheckNew" data-list="new" data-bs-toggle="collapse"
                data-bs-target="#newListInput" aria-expanded="false" aria-controls="newListInput">
              <label class="form-check-label" for="listCheckNew">Add to a New List</label>
              <div id="newListInput" class="collapse">
                <input type="text" name="newListName" class="form-control" placeholder="Give your new list a name!">
                <div class="form-text">
                  New lists are private and visible only to you. You can change this any time.
                </div>
              </div>
            </div>
          </div>
          <div id="existingListsHeader" class="fs-6 fw-bold mt-3" style="display:none;">Or add to your existing lists:</div>
          <div id="existingListsWrapper"></div>
        </div>
        <div class="my-3">
          <label for="itemNote" class="form-label mb-1">Note</label>
          <span class="text-muted fs-8 ms-2">optional</span>
          <textarea class="form-control" id="itemNote" rows="2" name="note"></textarea>
          <div class="form-text">Say something about this item. If you add it to multiple lists, the note will be added to all lists. You can always change it later!</div>
        </div>
        <div class="mb-3">
          <button type="submit" class="add-btn btn btn-primary btn-lg" onClick="saveListItems();return false;">Add It!</button> <span class="error error-text danger-text fs-6 mx-3"></span>
        </div>
      </div>
      <div class="success-body" style="display:none;">
        <i class="fad fa-branded fa-thumbs-up fa-2x" aria-hidden="true"></i>
        <h1 class="d-inline-block">Done!</h1>
        <div class="mt-3 success-message"></div>
        <div class="lists-message fs-5">
          <strong class="object-name"></strong> is now on these lists:
          <ul class="added-lists list-unstyled mt-3"></ul>
        </div>
        <div class="mb-3 text-end">
          <button type="button" class="btn btn-secondary" data-bs-dismiss="offcanvas" aria-label="Close">Close</button>
        </div>
      </div>
      <div class="error-body" style="display:none;">
        <p class="error-message">
          Whoop! We ran into a problem. Please try again later.
        </p>
        <div class="mb-3">
          <button type="button" class="btn btn-secondary btn-lg" data-bs-dismiss="offcanvas" aria-label="Close">Close</button>
        </div>
      </div>
    </div>
  </div>
</div>

    <script src="https://dyoeldxcrpb0a.cloudfront.net/assets/foot-e86b31e140b68f0263a5.js" ></script>
    
    
    

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  

  
    
  


  </body>

</html>
