




<!DOCTYPE html>
<html>
  <head>
    <script>
      dataLayer = [{
        'Market': 'seattle'
      }];
    </script>
    
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MVCXDDK');</script>
<!-- End Google Tag Manager -->


    


<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=yes">
<script type="text/javascript">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</script>

<link type="text/css" href="https://dyoeldxcrpb0a.cloudfront.net/assets/head.3d9782e72806200da18b.css" rel="stylesheet" />
<script type="text/javascript" src="https://dyoeldxcrpb0a.cloudfront.net/assets/head-3d9782e72806200da18b.js" ></script>
<link type="text/css" href="https://dyoeldxcrpb0a.cloudfront.net/assets/everout_head.3d9782e72806200da18b.css" rel="stylesheet" />
<script type="text/javascript" src="https://dyoeldxcrpb0a.cloudfront.net/assets/everout_head-3d9782e72806200da18b.js" ></script>
<link rel="icon" href="https://dyoeldxcrpb0a.cloudfront.net/assets/images/everout-favicon.ico">
<script data-ad-client="ca-pub-1721737779741429" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>


  <link rel="alternate" type="application/rss+xml" title="EverOut Seattle Picks & Guides Feed" href="https://everout.com/stranger-seattle/articles/feed" />



<link rel="stylesheet" href="https://use.typekit.net/wdx1hsa.css">

<script src="https://kit.fontawesome.com/ae403a2e1f.js" crossorigin="anonymous"></script>




<meta property="og:type" content="article" />

  
    <link rel="canonical" href="https://everout.com/stranger-seattle/articles/your-guide-to-things-to-do-in-seattle-this-october-2020/c183/" />
    <meta property="og:url" content="https://everout.com/stranger-seattle/articles/your-guide-to-things-to-do-in-seattle-this-october-2020/c183/" />
  
  
  



  <title>Your Guide to Things to Do in Seattle This October 2020 - EverOut Seattle</title>
  <meta property="og:title" content="Your Guide to Things to Do in Seattle This October 2020 - EverOut Seattle" />
  <meta name="apple-mobile-web-app-title" content="Your Guide to Things to Do in Seattle This October 2020 - EverOut Seattle" />



  <meta property="og:description" content="Your Guide to Things to Do in Seattle This October 2020 - Haunted Attractions, Art Museum Reopenings, and More Notable Happenings This Month" />
  <meta name="description" content="Your Guide to Things to Do in Seattle This October 2020 - Haunted Attractions, Art Museum Reopenings, and More Notable Happenings This Month" />


  <meta name="twitter:image" content="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYwMTQxNDgyNTAyMzMzMi0xMTk3MDQzNDBfMzQ3NDMxOTg4NTk1NzUxMl8xNDExNjE4MTQxMzQwODE5MzMxX28uanBnIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJpbnNpZGUiLCAid2lkdGgiOiAxMjAwLCAiaGVpZ2h0IjogNjMwfX19" />
  <meta property="og:image" content="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYwMTQxNDgyNTAyMzMzMi0xMTk3MDQzNDBfMzQ3NDMxOTg4NTk1NzUxMl8xNDExNjE4MTQxMzQwODE5MzMxX28uanBnIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJpbnNpZGUiLCAid2lkdGgiOiAxMjAwLCAiaGVpZ2h0IjogNjMwfX19" />

<link rel="mask-icon" href="https://dyoeldxcrpb0a.cloudfront.net/assets/images/everout-pin-icon.svg" color="#fcdc00">

  <link rel="apple-touch-icon-precomposed" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJ3aWR0aCI6IDYwLCAiaGVpZ2h0IjogNjB9fX0=" />
  <link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJ3aWR0aCI6IDcyLCAiaGVpZ2h0IjogNzJ9fX0=" />
  <link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJ3aWR0aCI6IDEyMCwgImhlaWdodCI6IDEyMH19fQ==" />
  <link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAibWFya2V0LTE1OTcwNzc5NzE1ODI2NzgtbWFya2V0LW1hcmtldC1ldmVyb3V0LW1vbm9ncmFtLTIwNDgtMTU2NzY0MTg2NTQxNTU1MS0xNTcyMjkwOTY4NTY4ODMxLmpwZyIsICJlZGl0cyI6IHsicmVzaXplIjogeyJmaXQiOiAiY29udGFpbiIsICJ3aWR0aCI6IDE1MiwgImhlaWdodCI6IDE1Mn19fQ==" />



  <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
  <script>
    window.googletag = window.googletag || {cmd: []};
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[1, 1]]).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Background", [[1, 1]], "Stranger-Content-Background-58").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[970, 250], [970, 100]]).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Top", [[970, 250], [970, 100]], "Stranger-Content-Top-56").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], [[320, 50]]).addSize([768, 0], []).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Mobile_Top", [[320, 50]], "Stranger-Content-Mobile-Top-57").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[300, 250], [300, 600]]).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Sidebar_1", [[300, 250], [300, 600]], "Stranger-Content-Sidebar-1-50").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], [[300, 250]]).addSize([768, 0], []).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Mobile_Inline_1", [[300, 250]], "Stranger-Content-Mobile-Inline-1-54").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], [[300, 250]]).addSize([768, 0], []).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Mobile_Inline_2", [[300, 250]], "Stranger-Content-Mobile-Inline-2-55").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[300, 250], [300, 600]]).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Sidebar_2", [[300, 250], [300, 600]], "Stranger-Content-Sidebar-2-51").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[300, 250], [300, 600]]).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Sidebar_3", [[300, 250], [300, 600]], "Stranger-Content-Sidebar-3-52").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
                googletag.cmd.push(function() {
                    var sizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([768, 0], [[300, 250], [300, 600]]).build();
                    googletag.defineSlot("/1047926/Stranger_Content_Sidebar_4", [[300, 250], [300, 600]], "Stranger-Content-Sidebar-4-53").defineSizeMapping(sizeMapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                });
            
            googletag.cmd.push(function() {
                googletag.pubads().enableSingleRequest();
                googletag.pubads().setTargeting("section", ['stranger-editorial-things-to-do']);
                googletag.enableServices();
            });
        
  </script>



<meta property="og:site_name" content="The Stranger" />
<meta name="twitter:card" content="summary_large_image" />

  
    <meta name="twitter:site" content="@thestranger" />
  
  
    <meta property="article:publisher" content="https://www.facebook.com/strangerseattle" />
  
  
    <meta property="fb:app_id" content="43933993878"/>
  
  
    <meta property="fb:admins" content="741428065"/>
  
  
    <meta property="fb:pages" content="56439755991" />
  

<meta name="cached" content="2020-10-01 10:30:47.819554">

  </head>

  <body class="everout seattle">
    
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MVCXDDK"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->


    <div class="flex-container wrapper">
      

  <div class="network-bar navbar d-none d-md-block navbar-expand-md navbar-dark bg-dark">
    <div class="container">
      <ul class="navbar-nav mr-auto">
        <li class="nav-item dropdown">
          <a class="nav-link dropdown-toggle" href="#" id="navbarDropdown" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
            EverOut
          </a>
          <ul class="dropdown-menu" aria-labelledby="navbarDropdown">
            <li class="dropdown-item"><a href="/" class="nav-link">Home</a></li>
            <div class="dropdown-divider"></div>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/stranger-seattle/">
                  Seattle
                </a>
              </li>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/portland-mercury/">
                  Portland
                </a>
              </li>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/tacoma/">
                  Tacoma
                </a>
              </li>
            
          </ul>
        </li>
        <li class="nav-item nav-item-separator">|</li>
        
          <li class="nav-item"><a class="nav-link" href="https://www.thestranger.com">The Stranger</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.portlandmercury.com">Portland Mercury</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.savagelovecast.com">Savage Love</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://humpfilmfest.com">Hump!</a></li>
          
          
        
      </ul>
    </div>
  </div>


      



      <div class="top-nav desktop">
  <div class="container">
    <nav class="navbar">
      <div class="navbar-brand-container">
        <a class="navbar-brand seattle" href="/stranger-seattle/" alt="Seattle">
          
            <img src="https://d2i729k8wyri5w.cloudfront.net/market-159735153762325-everout-logo-seattle2.png" alt="EverOut Seattle">
          
        </a>
      </div>
      
        <div class="navbar-expand-md desktop-items-container">
          <ul class="nav collapse navbar-collapse justify-content-end nav-items main-nav">
            
              <li class="nav-item">
                <a href="/stranger-seattle/articles/" class="nav-link">Picks &amp; Guides</a>
              </li>
              <li class="nav-item separator">|</li>
            
              <li class="nav-item">
                <a href="/stranger-seattle/events" class="nav-link">All Events</a>
              </li>
              <li class="nav-item separator">|</li>
            
              <li class="nav-item">
                <a href="/streamlocal/" class="nav-link">StreamLocal</a>
              </li>
              <li class="nav-item separator">|</li>
            
            
              <li class="nav-item dropdown">
                <a class="nav-link dropdown-toggle" href="#" id="navbarDropdown" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
                  More
                </a>
                <ul class="dropdown-menu dropdown-menu-right" aria-labelledby="navbarDropdown">
                  
                  <li class="dropdown-item  highlighted   class-change ">
                    <a href="https://everout.com/stranger-seattle/events/?category=in-person">
                      
                        <span class="fas fa-star"></span>
                      
                      
                        In-Person Events
                      
                    </a>
                  </li>
                  
                  <li class="dropdown-item  highlighted  ">
                    <a href="https://everout.com/stranger-seattle/events/?category=livestreamed">
                      
                        <span class="fas fa-star"></span>
                      
                      
                        Livestreamed Events
                      
                    </a>
                  </li>
                  
                  <li class="dropdown-item  highlighted  ">
                    <a href="https://everout.com/stranger-seattle/events/?category=one-day-only">
                      
                        <span class="fas fa-star"></span>
                      
                      
                        One-Day-Only Events
                      
                    </a>
                  </li>
                  
                  <li class="dropdown-item  highlighted  ">
                    <a href="https://everout.com/stranger-seattle/events/?category=resistance">
                      
                        <span class="fas fa-star"></span>
                      
                      
                        Protests & Resistance Events
                      
                    </a>
                  </li>
                  
                  <li class="dropdown-item  highlighted  ">
                    <a href="https://everout.com/stranger-seattle/events/?category=bipoc">
                      
                        <span class="fas fa-star"></span>
                      
                      
                        BIPOC-Focused Events
                      
                    </a>
                  </li>
                  
                  <li class="dropdown-item   class-change ">
                    <a href="https://everout.com/stranger-seattle/locations/?feature=outdoor-dining&amp;feature=dine-in">
                      
                      
                        Dine-In & Outdoor Dining
                      
                    </a>
                  </li>
                  
                  <li class="dropdown-item  ">
                    <a href="https://everout.com/stranger-seattle/locations/?feature=in-person-visits">
                      
                      
                        Now-Open Shops & Attractions
                      
                    </a>
                  </li>
                  
                  <li class="dropdown-item  ">
                    <a href="https://everout.com/stranger-seattle/locations/?category=restaurants&amp;feature=takeout-covid-19&amp;feature=delivery-covid-19&amp;feature=curbside-pickup&amp;feature=walk-up-ordering">
                      
                      
                        Takeout & Delivery
                      
                    </a>
                  </li>
                  
                  <li class="dropdown-item  ">
                    <a href="https://everout.com/stranger-seattle/locations/?category=weed-locations&amp;feature=takeout-covid-19">
                      
                      
                        Weed Locations
                      
                    </a>
                  </li>
                  
                  <li class="dropdown-item  ">
                    <a href="https://everout.com/stranger-seattle/articles/stranger-everout-presents-eat-this/c146/">
                      
                      
                        Eat This!
                      
                    </a>
                  </li>
                  
                </ul>
              </li>
            
          </ul>
        </div>
        <ul class="nav mobile nav-items main-nav d-md-none mt-2">
          
            <li class="nav-item">
              <a href="/stranger-seattle/articles/" class="nav-link">Picks &amp; Guides</a>
            </li>
            <li class="nav-item separator">|</li>
          
            <li class="nav-item">
              <a href="/stranger-seattle/events" class="nav-link">All Events</a>
            </li>
            <li class="nav-item separator">|</li>
          
            <li class="nav-item">
              <a href="/streamlocal/" class="nav-link">StreamLocal</a>
            </li>
            <li class="nav-item separator">|</li>
          
          
            <li class="nav-item menu-toggler" data-toggle="collapse" data-target="#navbarToggle" aria-controls="navbarToggle" aria-expanded="false" aria-label="Toggle navigation">
              <a href="#" class="nav-link" onclick="return false;">More <i class="fa fa-caret-down"></i></a>
            </li>
          
        </ul>
        <div class="collapse navbar-collapse nav-items mobile d-md-none" id="navbarToggle">
          <div class="more-nav">
            
              <div class="nav-item  highlighted   class-change ">
                <a href=https://everout.com/stranger-seattle/events/?category=in-person>
                  
                    <span class="fas fa-star"></span>
                  
                  
                    In-Person Events
                  
                </a>
              </div>
            
              <div class="nav-item  highlighted  ">
                <a href=https://everout.com/stranger-seattle/events/?category=livestreamed>
                  
                    <span class="fas fa-star"></span>
                  
                  
                    Livestreamed Events
                  
                </a>
              </div>
            
              <div class="nav-item  highlighted  ">
                <a href=https://everout.com/stranger-seattle/events/?category=one-day-only>
                  
                    <span class="fas fa-star"></span>
                  
                  
                    One-Day-Only Events
                  
                </a>
              </div>
            
              <div class="nav-item  highlighted  ">
                <a href=https://everout.com/stranger-seattle/events/?category=resistance>
                  
                    <span class="fas fa-star"></span>
                  
                  
                    Protests & Resistance Events
                  
                </a>
              </div>
            
              <div class="nav-item  highlighted  ">
                <a href=https://everout.com/stranger-seattle/events/?category=bipoc>
                  
                    <span class="fas fa-star"></span>
                  
                  
                    BIPOC-Focused Events
                  
                </a>
              </div>
            
              <div class="nav-item   class-change ">
                <a href=https://everout.com/stranger-seattle/locations/?feature=outdoor-dining&amp;feature=dine-in>
                  
                  
                    Dine-In & Outdoor Dining
                  
                </a>
              </div>
            
              <div class="nav-item  ">
                <a href=https://everout.com/stranger-seattle/locations/?feature=in-person-visits>
                  
                  
                    Now-Open Shops & Attractions
                  
                </a>
              </div>
            
              <div class="nav-item  ">
                <a href=https://everout.com/stranger-seattle/locations/?category=restaurants&amp;feature=takeout-covid-19&amp;feature=delivery-covid-19&amp;feature=curbside-pickup&amp;feature=walk-up-ordering>
                  
                  
                    Takeout & Delivery
                  
                </a>
              </div>
            
              <div class="nav-item  ">
                <a href=https://everout.com/stranger-seattle/locations/?category=weed-locations&amp;feature=takeout-covid-19>
                  
                  
                    Weed Locations
                  
                </a>
              </div>
            
              <div class="nav-item  ">
                <a href=https://everout.com/stranger-seattle/articles/stranger-everout-presents-eat-this/c146/>
                  
                  
                    Eat This!
                  
                </a>
              </div>
            
          </div>
        </div>
      
    </nav>
  </div>
</div>

      <div class="standalone-search-bar">
  <div class="search-container container" id="siteSearch">
    <span class="search-bar-label">Show Me</span>
    <input class="typeahead" type="text" placeholder="events, movies, venues, restaurants, guides..." data-sort-group="" data-site-section="">
    <i class="search-icon far fa-search"></i>

    <div role="listbox" class="default-search-panel p-3" style="display: none;" aria-expanded="false">
      <div role="presentation" class="row">
        <i class="loading-spinner fas fa-spinner fa-spin p-3"></i>
        <div class="col-6 col-sm-4 category-list">
        </div>
        <div class="col-6 col-sm-8 article-list">
        </div>
      </div>
    </div>
  </div>

  <script>
    $('.search-container .search-icon').on('click', function() {
      var market_slug = 'stranger-seattle';
      var search_value = $('.tt-input').val()
      if (search_value) {
        if (market_slug !== '') {
          window.location.href = '/' + market_slug + '/search?q=' + encodeURIComponent(search_value);
        } else {
          window.location.href = '/search?q=' + encodeURIComponent(search_value);
        }
      }
    })
  </script>
</div>

      

      <div class="top-super text-center container">
        


  

  
    
      <div id='Stranger-Content-Top-56' class="mb-4 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Top-56'); });
        </script>
      </div>
    
  

  
    
      <div id='Stranger-Content-Mobile-Top-57' class="mb-4 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Mobile-Top-57'); });
        </script>
      </div>
    
  

  

  

  

  

  

  


      </div>

      <div class="container">
        <div class="row main">
          
          <div class="col-md-8 primary">
            <header>
              
  <div class="row">
  <div id="breadcrumbs" class="col-sm-12 ttd-breadcrumbs">
    
      <a href="/stranger-seattle/">Seattle</a>
    
    <span class="breadcrumb-delimiter">&gt;</span>
    
      
        <a href="/stranger-seattle/articles/" class="">Picks &amp; Guides</a>
      
      
    
  </div>
</div>


            </header>

            <div class="content">
              
  <div class="item-detail">
    <article>
      <header class="mb-2">
        <h1>Your Guide to Things to Do in Seattle This October 2020</h1>
        <div class="subhead">
          Haunted Attractions, Art Museum Reopenings, and More Notable Happenings This Month
        </div>
        
          <div class="author">
            by
            
              
                <a href="https://www.thestranger.com/authors/22700136/everout-things-to-do">Stranger EverOut Staff</a>
              
            
          </div>
        
        
          <div class="published-date">
            September 29, 2020
          </div>
        
        

<div class="share-tools border-top border-bottom">
  <span class="share-tools-label pr-2" class="pr-2">Share</span>
  <div class="facebook-this share-tool">
    <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A//everout.com/articles/your-guide-to-things-to-do-in-seattle-this-october-2020/c183/" class="share-link new-window" target="_blank"><i class="fab fa-facebook pr-2"></i></a>
</div>

  <div class="tweet-this share-tool">
    <a href="https://twitter.com/intent/tweet?text=Your%20Guide%20to%20Things%20to%20Do%20in%20Seattle%20This%20October%202020%2C%20from%20EverOut%20https%3A//everout.com/articles/your-guide-to-things-to-do-in-seattle-this-october-2020/c183/" class="share-link new-window" target="_blank"><i class="fab fa-twitter pr-2"></i></a>
</div>

  <div class="mail-this share-tool">
    <a href="mailto:?subject=Your%20Guide%20to%20Things%20to%20Do%20in%20Seattle%20This%20October%202020%2C%20from%20EverOut&body=Your%20Guide%20to%20Things%20to%20Do%20in%20Seattle%20This%20October%202020%2C%20from%20EverOut%20https%3A//everout.com/articles/your-guide-to-things-to-do-in-seattle-this-october-2020/c183/"><i class="fas fa-envelope"></i></a>
</div>

</div>

      </header>
      
        <div class="lead-image my-3">
          <img class="img-responsive" src="https://d2i729k8wyri5w.cloudfront.net/eyJidWNrZXQiOiAiZXZlcm91dC1pbWFnZXMtcHJvZHVjdGlvbiIsICJrZXkiOiAiaW1hZ2UtMTYwMTQxNDgyNTAyMzMzMi0xMTk3MDQzNDBfMzQ3NDMxOTg4NTk1NzUxMl8xNDExNjE4MTQxMzQwODE5MzMxX28uanBnIiwgImVkaXRzIjogeyJyZXNpemUiOiB7ImZpdCI6ICJpbnNpZGUiLCAid2lkdGgiOiAxMDI0LCAiaGVpZ2h0IjogODAwfX19 ">
          
            <div class="caption">
              Your car will protect you from the ghouls and goblins of Snohomish at Stalker Farms' <a href="https://everout.com/events/stalker-farms-drive-thru-haunted-attractions/e36493/">Drive-Thru Haunts</a>, one of several socially distant options on our <a href="https://everout.com/stranger-seattle/events/?category=halloween">Halloween calendar</a>.
              
                <span class="credit">
                  (Stalker Farms Haunted Attractions via Facebook)
                </span>
              
            </div>
          
        </div>
      
      <div class="body-text">
        
          
            <p>According to the Gregorian calendar, that invented superintendent of time, a new month begins this week! October is branded, as usual, with plenty of spooky stuff leading up to <a href="https://everout.com/stranger-seattle/events/?category=halloween">Halloween</a>, but also by social justice events and voter-mobilization efforts in anticipation of the upcoming presidential election. With social distancing measures and pre-planners in mind, we've rounded up this month's biggest happenings in every genre, both online and in-person&mdash;from the reopening of the <a href="https://everout.com/events/frye-art-museum-reopening/e35184/">Frye Art Museum</a> to the inaugural amateur horror film festival <a href="https://everout.com/events/slay/e33924/">SLAY</a> (from the freaks who brought you HUMP! and SPLIFF), and from the <a href="https://everout.com/events/seattle-womens-march-october-2020/e36784/">Seattle Women's March</a> to a publication-day party for <a href="https://everout.com/stranger-seattle/events/lindy-west-shit-actually-publication-day-event/e36286/">Lindy West's new book</a>. For even more options, check out our complete <a href="https://everout.com/stranger-seattle/events/?category=livestreamed">streaming</a> and <a href="https://everout.com/stranger-seattle/events/?category=in-person">in-person</a> event calendars, as well as our guides to <a href="https://everout.com/stranger-seattle/articles/where-to-celebrate-oktoberfest-2020-in-seattle/c166/">Oktoberfest events</a> and <a href="https://everout.com/stranger-seattle/articles/your-complete-guide-to-pumpkin-patches-corn-mazes-and-hay-rides-around-seattle-fall-2020-edition/c169/">COVID-friendly fall activities around town</a>.&nbsp;</p>
          
        
          
            
<p><em>All events are online unless otherwise noted.</em></p>
          
        
          
            
<h3 id="thursday">OCTOBER 1</h3>
<p><strong>SHOPPING</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/c-id-virtual-night-market-2020/e35763/">C-ID Virtual Night Market 2020</a></strong><br />This annual night market in Chinatown-International District, which rolls around just in time for the mid-autumn festival, is going virtual this year. Check it out for demos, shopping, and other activities, including a mixology pairing from&nbsp;Pho Bac Sup Shop, a dance performance from Tanya Woo, and lantern-making with Kobo at Higo. You're encouraged to pick up supplies ahead of time to follow along with the interactive bits.</p>
          
        
          
            
<h3 id="friday">OCTOBER 1-3</h3>
<p><strong>FLM</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/mountainfilm-on-tour/e36526/">Mountainfilm on Tour</a></strong><br />The Mountaineers and REI present a program of <span style="text-decoration: line-through;">romantic period pieces</span> outdoor-focused films for the seventh year in a row, but online this time. Take in sweeping vistas, snow-capped peaks, and brave ascents.</p>
          
        
          
            

<div class="fish-butter article-inline" data-spot="article-inline-ad" data-context-oid="" data-ad-oid="" style="display:none;">
  
    <div class="fish-tag">
      Sponsored
    </div>
  
  <div class="fish-container">
    <div class="fish-image">
      
    </div>
    <div class="fish-body">
      <h1>
        
      </h1>
      <p>
        
      </p>
    </div>
  </div>
</div>

          
        
          
            
<h3 id="friday">OCTOBER 1-4</h3>
<p><strong>PERFORMANCE</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/drive-in-at-on-the-boards/e36573/">Drive-In at On the Boards</a></strong><br />On the Boards' parking lot will transform into a temporary drive-in theater to fill the&nbsp;arts-performance-shaped hole in your life with a special program of variety acts and reflections on creativity. If you don't have a car, you can also bring your own chairs and park up in the "seated audience area," but make sure to bring a radio or phone with FM capabilities. The Sitting Room will provide Mexican food if you get hungry.<br /><em>On the Boards (Queen Anne)</em></p>
          
        
          
            
<h3 id="friday">OCTOBER 1-11</h3>
<p><strong>FILM</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/social-justice-film-festival/e35840/">Social Justice Film Festival</a></strong><br />This film festival highlights fierce and powerful progressive movements around the world. As social justice provides the only throughline, many of the movies have little in common. But the selection skews toward limber, on-the-ground filmmaking in the midst of protests and conflicts. The ninth edition's theme is "Transform," all about the power of collective and personal transformation. Don't miss&nbsp;<em>Ask for Jane</em>, based on a true story of a&nbsp;group of college women who developed an underground abortion network that helped over 11,000 people get illegal abortions in Chicago between 1969 and 1973.</p>
          
        
          
            
<h3 id="friday">OCTOBER 1-15</h3>
<p><strong>MUSIC</strong></p>
          
        
          
            


  

  

  

  

  
    
      <div id='Stranger-Content-Mobile-Inline-1-54' class="mb-4 text-center ad-placement inline-ad">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Mobile-Inline-1-54'); });
        </script>
      </div>
    
  

  

  

  

  


          
        
          
            
<p><strong><a href="https://everout.com/events/freakout-live/e36742/">Freakout Live!</a></strong><br />This year would have been the eighth annual Freakout Fest, a sweet and sweaty weekend festival in Ballard hosted by Freakout Records. Because the pandemic is still in full swing, there will be no moshing or liquid light shows this year&mdash;but there will be music. Instead of Freakout Fest, the Seattle-based music label will host Freakout Live!, a free weekly music series featuring acts from Europe, Mexico, and the Pacific Northwest. The series will officially launch this week on October 1 with Toulouse, France-based band Foggy Tapes bringing their "spaghetti surf" tunes overseas.&nbsp; Freakout's next few weeks are already planned out, with sessions from freaky Paris-based band Dee Dee &amp; the Abracadabras and fiery local trio The Grizzled Mighty going live on October 8 and October 15, respectively. Freakout Live! also plans to bring on King Khan, Smokey Brights, Shaina Shepherd, and CDMX's Carrion Kids in the weeks to come. In addition to music, hosts Skyler Locatelli and Guy Keltner of Freakout Records will interview the bands, either in-person (from a distance) or through Zoom. <strong>JASMYNE KEIMIG</strong></p>
          
        
          
            
<h3 id="friday">OCTOBER 2</h3>
<p><strong>MUSEUMS</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/bellevue-arts-museum-reopening/e36152/">Bellevue Arts Museum Reopening</a></strong><br />The celebrated Eastside museum will reopen its second- and third-floor galleries to the public. They have reduced capacity and visits are timed, but on the plus side, admission is now pay-what-you-can, thanks to the&nbsp;support of Overlake Medical Center and Clinics. They have an all-new lineup of exhibitions, including&nbsp;<em>Steven Holl: Making Architecture</em>&nbsp;(through Oct 11) and&nbsp;<em>America&rsquo;s Monsters, Superheroes, and Villains</em>&nbsp;(through Jan 17).<br /><em>Bellevue Arts Museum</em></p>
          
        
          
            
<p><strong>READINGS &amp; TALKS</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/kristen-millares-young-subduction/e24660/">Kristen Millares Young: Subduction</a></strong><br />Rich Smith has called Millares Young a "crack Seattle journalist and novelist," and her new, meticulously researched historical novel sounds like a winner. Hear her read from this story of a Latinx anthropologist reeling from her husband's betrayal as she tries to carry out a fieldwork project on a Makah Indian Reservation in Neah Bay. When she begins an affair with one of her research subjects, Peter, love, trauma, and colonialism collide.</p>
          
        
          
            
<h3 id="friday">OCTOBER 2-11</h3>
<p><strong>PERFORMANCE</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/men-in-dance/e35195/">Men in Dance</a></strong><br />Men dancers at the highest levels of artistry from the Pacific Northwest will enliven modern, contemporary, urban, jazz, and ballet genres for the 13th year in a row. This year's virtual edition features choreography by Daniel Ojeda of Ballet Idaho, Beth Terwilleger (seen at <em>12 Minutes Max</em> and the Converge Dance Festival),&nbsp;Elise Meiners Schwicht (SALT II Contemporary Company, Converge), Nahshon Marden (Sensible Theatre Company, the Equalux Fundraiser), Joel Hathaway (the Missouri Contemporary Ballet company), and others.</p>
          
        
          
            
<p><strong>READINGS &amp; TALKS</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/novel-nights/e35649/">Novel Nights</a></strong><br />Raise money for Seattle's most beloved writing center, Hugo House, at this virtual book club series featuring special guests with newly published books, including Erik Larson, US congresswoman Pramila Jayapal, Jess Walter, Sharyn Skeeter, Neal Bascomb, and Matt Ruff.</p>
          
        
          
            
<h3 id="friday">OCTOBER 2-29</h3>
<p><strong>MUSIC</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/seattle-symphony-october-events/e36824/">Seattle Symphony October Events</a></strong><br />This month's virtual Seattle Symphony performances look well-worth the price of admission, even though you won't get to make the trip to Benaroya Hall. Starting with an accompanying performance with local alternative soul artist <a href="https://everout.com/events/whitney-monge-with-the-seattle-symphony/e36808/">Whitney Mong&eacute;</a>&nbsp;(Fri Oct 2), the lineup includes the <a href="https://www.thestranger.com/events/45637429/barber-violin-concerto">Barber Violin Concerto</a> (Thurs Oct 8), works by <a href="https://www.thestranger.com/events/45637193/shostakovich-and-haydn">Shostakovich &amp; Haydn</a> (Thurs Oct 15), Vivaldi's&nbsp;<a href="https://www.thestranger.com/events/45637066/vivaldis-the-four-seasons"><em>The Four Seasons</em></a>&nbsp;performed by violinist Rachell Ellen Wong (Thurs Oct 22), and the <a href="https://www.thestranger.com/events/45636824/mendelssohn-violin-concerto">Mendelssohn Violin Concerto</a> (Thurs Oct 29).</p>
          
        
          
            


  

  

  

  

  

  
    
      <div id='Stranger-Content-Mobile-Inline-2-55' class="mb-4 text-center ad-placement inline-ad">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Mobile-Inline-2-55'); });
        </script>
      </div>
    
  

  

  

  


          
        
          
            
<h3>OCTOBER 2-NOVEMBER 14</h3>
<p><strong>FOOD &amp; DRINK</strong></p>
          
        
          
            
<p><a href="https://everout.com/events/canlis-community-college/e36907/"><strong>Canlis Community College</strong></a><br />Seattle's premier fine-dining restaurant has a storied history of throwing unforgettable parties of Gatsby-esque proportions, and now they're channeling their event-planning panache into a new project for the time of COVID-19: Meet Canlis Community College, a six-week-long lineup of fun virtual classes and extracurricular activities. Guests will be able to follow along on a livestream as brothers Mark and Brian Canlis try out all sorts of new things, and there will be "office hours" with appointed experts on topics.&nbsp;On the curriculum: Filipinx food with <a href="https://everout.com/stranger-seattle/locations/musang/l14020/">Musang</a> chef Melissa Miranda, weekly jazzercise with the Pacific Northwest ballet, Japanese drinking food with <a href="https://everout.com/stranger-seattle/locations/kamonegi/l15120/">Kamonegi</a> chef Mutsuko Soma, an introduction to cocktails, bread-baking, homemade dumplings 101, music theory with KEXP, traveling with Rick Steves, at-home haircuts with <a href="https://everout.com/stranger-seattle/search/?q=rudy%27s%20barbershop">Rudy's Barbershop</a>, weed brownies with Jody Hall of The Goodship, and way, way more. There's even a cafeteria with retro at-home TV dinners, available for purchase online or for pickup, and if you want to show off your school spirit, there's also a "campus store" with merch. All of it can be yours for the low, low price of $25, with a suggested $4.50 donation to <a href="https://everout.com/stranger-seattle/locations/farestart/l18755/">FareStart</a>.</p>
          
        
          
            
<h3 id="sunday">OCTOBER 3-4</h3>
<p><strong>GEEK</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/brickcon/e36046/">BrickCon</a></strong><br />Legos may be popular among kids, but there's something about building a world made of tiny blocks that transcends age requirements. At this 19th annual festival, which will take place online, you'll get the chance to marvel at models made by master builders from around the world and purchase custom sets and parts from the Brick Bazaar.</p>
          
        
          
            
<h3 id="sunday">OCTOBER 3-31</h3>
<p><strong>HALLOWEEN</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/stalker-farms-drive-thru-haunted-attractions/e36493/">Stalker Farms: Drive-Thru Haunted Attractions</a></strong><br />Ghouls of Snohomish are back in the habit of lurking in ye olde haunted corn trails. Rather than completing the maze on foot, you'll at least get to cower in the safety of your car as the lot of them jump out at you at this drive-in edition. Be sure to book your spot online first.<br /><em>Stocker Farms (Snohomish)</em></p>
          
        
          
            
<p><strong><a href="https://everout.com/stranger-seattle/events/thomas-family-farm-haunts/e36496/">Thomas Family Farm Haunts</a></strong><br />You'll have to wait until 2021 (hopefully) for zombie paintball and the Nightmare on 9 haunted house, but that doesn't mean you can't still be scared at Thomas Family Farm this year. They've modified their Haunted Hayride and Flashlight Corn Maze for social distancing requirements, and added a brand-new Night Pumpkin Patch experience. <br /><em>Thomas Family Farm (Snohomish)</em></p>
          
        
          
            
<h3 id="sunday">OCTOBER 4</h3>
<p><strong>READINGS &amp; TALKS</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/louise-erdrich-ann-patchett-with-laura-flynn/e36812/">Louise Erdrich &amp; Ann Patchett with Laura Flynn</a></strong><br />If you've gone through your most recent book list and need new recommendations, who better to turn to than acclaimed authors Louise Erdrich and Ann Patchett, who both happen to own their own bookstores (Birchbark Books in Minneapolis and Parnassus Books in Nashville, respectively)? The pair will join Elliott Bay virtually to talk about what they've been reading and working on, and how they've been coping with the current moment. Laura Flynn of the Movement Voter Project will join in, too.&nbsp;</p>
          
        
          
            
<h3>OCTOBER 4-NOVEMBER 1</h3>
<p><strong>COMMUNITY</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/stranger-seattle/events/vote-with-pride/e36841/">Vote with Pride</a></strong><br />Seattle Pride is hosting a month of socially distant weekly events on Capitol Hill to encourage the local LGBTQ+ community to get out and vote in November. You'll have the chance to win prizes during each activity. <br /><em>Various locations (Capitol Hill)</em></p>
          
        
          
            
<h3 id="sunday">OCTOBER 5-9</h3>
<p><strong>MUSIC</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/bellevue-jazz-blues-music-series/e36825/">Bellevue Jazz &amp; Blues Music Series</a></strong><br />The 13th annual Bellevue Jazz &amp; Blues Festival will take the form of the inaugural #HeartofBellevue Jazz &amp; Blues Music Series, which will allow you to get deals on takeout from local restaurants when you buy tickets to online performances. This year's lineup features over 60 regional artists, including the Bill Anschell Trio, Stephanie Anne Johnson, and the Kareem Kandi Trio.</p>
          
        
          
            
<h3 id="sunday">OCTOBER 5-18</h3>
<p><strong>GEEK</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/the-great-seattle-arts-adventure/e36672/">The Great Seattle Arts Adventure</a></strong><br />Using the mobile app&nbsp;Goose Chase, this all-ages, arts-based scavenger hunt hosted by the Seattle Shakespeare Company allows you to complete challenges for the chance to win prizes without straying too far from home.&nbsp; <br /><em>Wherever you are</em></p>
          
        
          
            
<h3 id="wednesday">OCTOBER 6-31</h3>
<p><strong>FOOD &amp; DRINK</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/lil-woodys-fast-food-month/e36717/">Li'l Woody's Fast Food Month</a></strong><br />For the month of October, local burger joint Li'l Woody's is cleverly recreating fast food favorites for its weekly specials. First up is the <strong>Woody's Baconator</strong> (October 6), a take on the Wendy's Baconator with mayo, double Hills bacon, double Painted Hills grass-fed beef, and double American cheese. Next is the Jack in the Box-inspired <strong>Sourdough Woody</strong> (October 13), with mayo, ketchup, sliced tomatoes, Hill's bacon, Swiss cheese, and grass-fed beef on sourdough. (Curly fries are also available for that week for the full experience.) The McDonald's dupe <strong>Li'l Big Mac</strong> (October 20) comes after that, with fry sauce, dill pickles, diced onion, shredded lettuce, American cheese, grass-fed beef, and a center-cut sesame bun. Finally, the <strong>Li'l Crunch Wrap</strong> (October 27), Li'l Woody's interpretation of the Taco Bell Crunch Wrap Supreme with chipotle mayo, shredded lettuce, pico de gallo, tostada, house-made queso, and grass-fed beef, wraps things up (pun not intended).<br /><em>Various locations</em></p>
          
        
          
            
<h3 id="wednesday">OCTOBER 7</h3>
<p><strong>COMMUNITY</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/washington-gubernatorial-debate/e36826/">Washington Gubernatorial Debate</a></strong><br />Democratic incumbent Jay Inslee and republican candidate Loren Culp will debate live online to win Washingtonians' gubernatorial vote. The event will be moderated by Chris Daniels (KING 5), Brandi Kruse (Q13 News), Essex Porter (KIRO 7), and Melissa Santos (KCTS 9/Crosscut).</p>
          
        
          
            
<h3 id="thursday">OCTOBER 8</h3>
<p><strong>FOOD &amp; DRINK</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/omnivorous/e35761/">Omnivorous</a></strong><br />Seattle bars and restaurants will come together to bring you an evening of delectable sips and bites in support of Community Roots Housing (formerly known as Capitol Hill Housing). This year's virtual event will include virtual "demonstration rooms" with local chefs, including a pasta class with <a href="https://everout.com/locations/osteria-la-spiga/l20024/">Osteria la Spiga</a>'s Sabrina Tinsley.</p>
          
        
          
            
<h3 id="thursday">OCTOBER 8-13</h3>
<p><strong>PERFORMANCE</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/pacific-northwest-ballet-2020-2021-season-rep-1/e34830/">Pacific Northwest Ballet 2020/2021 Season: Rep 1</a></strong><br />PNB's 2020/2021 season will be a combination of works performed and recorded (safely) during the lockdown and archival videos of story ballets from pre-COVID times. The company will make up for its less-than-ideal-but-still-perfectly-satisfactory digital platform by offering interviews and other exclusive content with each online performance, which will be available for five days after they're released.</p>
          
        
          
            
<h3 id="thursday">OCTOBER 9-10</h3>
<p><strong>MUSIC</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/make-your-voice-heard-loud-vote/e36815/">Make Your Voice Heard Loud &amp; Vote</a></strong><br />To encourage every young person to participate in the 2020 election, the Washington Bus, League of Women Voters, and Tok The Vote are hosting this two-day virtual voter-registration drive on Nectar's virtual stage. Tune in for live sets from&nbsp;King Youngblood,&nbsp;Naked Giants, and Tennis Pro on Friday, then log back in the next day for tunes from Jaiden Grayson and Acid Tongue, plus a few more from King Youngblood for good measure.&nbsp;</p>
          
        
          
            
<h3 id="saturday">OCTOBER 10</h3>
<p><strong>VISUAL ART</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/luminata-2020/e36827/">Luminata 2020</a></strong><br />The Fremont Arts Council's annual autumnal equinox celebration will move online to help ease you into the less-sunny season while keeping you safe at home. You're invited to share your own light art and lanterns and dress in costumes to show off online. DJ HerShe will provide live tunes.&nbsp;</p>
          
        
          
            
<h3 id="sunday">OCTOBER 11</h3>
<p><strong>MUSIC</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/bach-musical-offerings/e35975/">Bach &amp; Musical Offerings</a></strong><br />Together with flutist Joshua Romatowski and violinist Ingrid Matthews, lauded harpsichordist Byron Schenkman will lead a program of Bach's "Musical Offering" Trio-sonata in C Minor and other works.</p>
          
        
          
            
<h3 id="monday">OCTOBER 12</h3>
<p><strong>COMMUNITY</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/virtual-indigenous-peoples-day/e36828/">Virtual Indigenous Peoples' Day</a></strong><br />The Gathered in this Place Two-Spirit Drum Group, Haida Heritage, Robert Upham, and many others will bring you an afternoon of livestreamed performances on&nbsp;Indigenous Peoples' Day, courtesy of Daybreak Star Indian Cultural Center.&nbsp;</p>
          
        
          
            
<p><strong>READINGS &amp; TALKS</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/seattle-arts-lectures-presents-tana-french/e35196/">Seattle Arts &amp; Lectures presents: Tana French</a></strong><br />The prolific, Stephen King-approved queen of Irish crime fiction, Tana French, will join SAL virtually for a talk on her latest book, <em>The Searcher</em>, and her mastery of mystery.</p>
          
        
          
            
<h3 id="friday">OCTOBER 14</h3>
<p><strong>HALLOWEEN</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/stranger-seattle/events/pumpkin-loop/e36837/">Pumpkin Loop</a></strong><br />Everyone's favorite seasonal gourd will line the cozily-lit one-way paths of the Woodland Park Zoo for your strolling and Instagramming pleasure. On October 24 and 25, kids will be treated to sweets from zoo staff, and costumes are encouraged. <br /><em>Woodland Park Zoo (Phinney)</em></p>
          
        
          
            
<p><strong>MUSEUMS</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/frye-art-museum-reopening/e35184/">Frye Art Museum Reopening</a></strong><br />After announcing a big furlough of staff this summer, the Frye said in a statement that they will bring back all furloughed staff in early September so they can get the ball rolling on reopening. Frye will remain free to visit, but they plan on implementing an online timed ticketing system to adhere to the new 25 percent capacity guidelines (which works out to about 50 people allowed in at one time).&nbsp;Agnieszka Polska's&nbsp;<a href="https://www.thestranger.com/events/44350817/agnieszka-polska-love-bite"><em>Love Bite</em></a>, Francesca Lohmann and Rob Rhee's&nbsp;<a href="https://everout.com/events/subspontaneous-francesca-lohmann-and-rob-rhee/e35180/"><em>Subspontaneous</em></a>, and&nbsp;<a href="https://everout.com/events/unsettling-femininity-selections-from-the-frye-art-museum-collection/e35182/"><em>Unsettling Femininity: Selections from the Frye Art Museum Collection</em></a> are still on view. <strong>JASMYNE KEIMIG</strong><br /><em>Frye Art Museum (First Hill)</em></p>
          
        
          
            
<p><strong>READINGS &amp; TALKS</strong></p>
          
        
          
            
<p><a href="https://www.thestranger.com/events/45673640/launched-kathleen-flenniken-tiffany-midge-and-donna-miscolta"><strong>Launched: Kathleen Flenniken, Tiffany Midge, &amp; Donna Miscolta</strong></a><br />Celebrates poets&nbsp;Kathleen Flenniken (<em>Post Romantic</em>), Tiffany Midge (<em>Bury My Heart at Chuck E. Cheese's</em>), and Donna Miscolta (<em>Living Color</em>) will link up for a virtual reading and discussion with Seattle Arts &amp; Lectures.&nbsp;</p>
          
        
          
            
<h3 id="friday">OCTOBER 15-18</h3>
<p><strong>VISUAL ART</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/refract/e36838/">Refract</a></strong><br />This extravaganza of demos and studio tours by regional glass artists will take place both online and in-person, with a nighttime exhibition viewing at <a href="https://everout.com/locations/chihuly-garden-and-glass/l26306/">Chihuly Garden &amp; Glass</a>&nbsp;(Thurs Oct 15), a virtual&nbsp;<a href="https://everout.thestranger.com/locations/pilchuck-seattle/l26058/">Pilchuck</a> auction (Fri Oct 16), virtual demos from Pike Place artists (Oct 15-18), an evening with local artist&nbsp;Ben Beres at <a href="https://everout.thestranger.com/locations/glass-eye-studio/l25969/">Glass Eye Studio</a> (Sat Oct 16), and tons more opportunities to be mesmerized by the heat-induced transformation of solid objects.</p>
          
        
          
            
<h3 id="friday">OCTOBER 15-25</h3>
<p><strong>FILM</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/seattle-queer-film-festival-2020/e24415/">Seattle Queer Film Festival 2020</a></strong><br />Local shorts, indie features, and national or international releases will stoke and satisfy your appetite for gay, lesbian, bi, trans, enby, and otherwise queer-focused films, which will be available to watch for 72 hours once you hit play.&nbsp;This year's online event is expanding its screenings to include not just Seattle but the rest of Washington, as well as Oregon and Idaho. <em>The Stranger</em>'s Jasmyne Keimig lays out some recommendations <a href="https://www.thestranger.com/slog/2020/09/21/44826661/the-25th-seattle-queer-film-festival-goes-virtual">here</a>, including&nbsp;<em>Monsoon</em>, starring <em>Crazy Rich Asians</em> leading man&nbsp;Henry Golding.</p>
          
        
          
            
<h3 id="friday">OCTOBER 15-31</h3>
<p><strong>FILM</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/slay/e33924/">Slay</a></strong><br />From the freaks who brought you the HUMP! and SPLIFF Film Festivals comes something new, fun, and totally terrifying: SLAY! SLAY calls for filmmakers to send in homemade short horror films&mdash;eight minutes or less&mdash;capturing what scares them most. From classic ghost stories and slasher films to dystopian cults and political nightmares, SLAY dares you to show us your darkest fears. We know reality is scarier than fiction right now. Let&rsquo;s purge our fears together. <strong>WM. STEVEN HUMPHREY</strong></p>
          
        
          
            
<h3>OCTOBER 15-JANUARY 18</h3>
<p><strong>VISUAL ART</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/city-of-tomorrow-jinny-wright-and-the-art-that-shaped-a-new-seattle/e35117/">City of Tomorrow: Jinny Wright and The Art that Shaped a New Seattle</a></strong><br />The late Virginia "Jinny" Wright helped shape the&nbsp;development of the art world as we know it in Seattle and the Pacific Northwest. This exhibit traces her influence through contemporary paintings, sculptures, drawings, and photographs from Wright and her husband's collection, alongside historical ephemera.<br /><em>Seattle Art Museum (Downtown)</em></p>
          
        
          
            
<h3 id="friday">OCTOBER 16</h3>
<p><strong>MUSIC</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/civic-enragement-ft-pet-symmetry-diet-cig-chris-farren-more/e36832/">Civic Enragement ft. Pet Symmetry, Diet Cig, Chris Farren, &amp; more</a></strong><br />With less than a month to go before the November election, this virtual concert co-hosted by King County Elections, FairVote Washington, and the Civil Survival Project will encourage you to (<em>please!!!</em>) cast your ballot. You'll be treated to live sets from rockers Pet Symmetry, Diet Cig, Chris Farren, Grumpster, and Amplifier for doing so.&nbsp;</p>
          
        
          
            
<p><strong>READINGS &amp; TALKS</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/jane-fonda-elizabeth-lesser-the-superpower-of-women-moving-the-world-from-me-to-we/e36805/">Jane Fonda &amp; Elizabeth Lesser: The Superpower of Women &mdash; Moving the World from Me to We</a></strong><br />Why is it that womxn, broadly speaking, get shit done so effectively, from leading environmental justice movements to showing up for social causes like the worldwide Women's Marches? Jane Fonda (the iconic actress and the author of <em>What Can I Do? My Path from Climate Despair to Action</em>) and Elizabeth Lesser (the co-founder of the&nbsp;Omega Institute and the author of<em>&nbsp;Cassandra Speaks: When Women Are the Storytellers, the Human Story Changes</em>) will address this and other questions in a livestreamed conversation with Town Hall.&nbsp;</p>
          
        
          
            
<h3 id="saturday">OCTOBER 16-23</h3>
<p><strong>PERFORMANCE</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/circa-s/e36833/">Circa: S</a></strong><br />Brisbane-based contemporary performance troupe Circa is a vision of limb contortions, blurring the lines between movement, dance, theater, and circus art. Meany Center will stream&nbsp;their new production <em>S</em> on its digital stage for a whole week.&nbsp;</p>
          
        
          
            
<h3 id="saturday">OCTOBER 16-24</h3>
<p><strong>FESTIVALS</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/seattle-made-week-2020/e36319/">Seattle Made Week 2020</a></strong><br />Not only do local producers and manufacturers make cool stuff, but they also create jobs and allow our region to rely less on the global economy. Seattle Made's annual celebration of local makers features a week of virtual pop-ups, meet-the-maker events, a party, a panel discussion, and vendor showcases.</p>
          
        
          
            
<h3 id="saturday">THROUGH OCTOBER 17</h3>
<p><strong>VISUAL ART</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/sensebellum/e36658/">Sensebellum</a></strong><br />The Bellingham-based "experience" Sensebellum features interactive science-y art, 3D projection mapping, intricate lighting systems, and renderings of the natural world.<br /><em>Periodic: A Pop-Up Shop (South Lake Union)</em></p>
          
        
          
            
<h3 id="saturday">OCTOBER 17</h3>
<p><strong>FOOD &amp; DRINK</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/annual-alice-b-toklas-dinner/e36777/">Annual Alice B. Toklas Dinner</a></strong><br />The Hotel Sorrento lays claim to the peculiar honor of having been deemed one of the 13 most haunted hotels in the world by USA Today. Why? It&rsquo;s said that the specter of late eccentric socialite Alice B. Toklas lurks there; she&rsquo;s known mostly as the muse and lover of Gertrude Stein (not to mention the progenitor of an apparently killer pot brownie recipe). Toklas lived briefly in Seattle as a teen, and her apparition has been glimpsed roaming the halls of the Sorrento&rsquo;s fourth floor dressed in flowing white. At this spooky event, the hotel will pay homage to its favorite &ldquo;permanent resident&rdquo; with a tour of some of the sites of reported paranormal activity, followed by a prix-fixe dinner inspired by Toklas&rsquo;s eponymous cookbook. (Alas, her famous brownies will not be served.)<br /><em>Hotel Sorrento (First Hill)</em></p>
          
        
          
            
<p><strong>PROTESTS &amp; RESISTANCE</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/seattle-womens-march-october-2020/e36784/">Seattle Women's March: October 2020</a></strong><br />The organizers of the national Women's March are calling for a march in D.C. on October 17 to "make our resistance clear" and "finish the work we started three years ago." There will also be a companion march in downtown Seattle, as well as Poulsbo&nbsp;and Port Angeles. The organizers of the downtown march write, "We skipped the last march in January 2020 [due to snow]. Well some of us were there. Let&rsquo;s all show up this time for Ruth &amp; John and well to make some 'good trouble'!"<br /><em>City Hall (Downtown)</em></p>
          
        
          
            
<p><strong>READINGS &amp; TALKS</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/seattle-reads-tommy-orange/e36811/">Seattle Reads: Tommy Orange</a></strong><br />At&nbsp;this virtual Seattle Reads event, PEN/Hemingway Award-winning author Tommy Orange&nbsp;will discuss&nbsp;his debut novel <em>There There</em>, which is "completely absorbing, character-rich, kinda funny, mostly pretty sad, definitely existentially fraught, fast-paced-but-not-really-'propulsive'-until-the-end," as <a href="https://www.thestranger.com/slog/2018/06/11/26831214/tommy-oranges-debut-there-there-is-a-hymn-to-urban-indians">Rich Smith has it</a>.</p>
          
        
          
            
<h3 id="tuesday">OCTOBER 20</h3>
<p><strong>READINGS &amp; TALKS</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/lindy-west-shit-actually-publication-day-event/e36286/">Lindy West: Shit Actually (Publication Day Event!)</a></strong><br />Hometown hero and former <em>Stranger</em> writer Lindy West will celebrate the publication of her new book&nbsp;<em>Shit Actually: The Definitive 100% Objective Guide to Modern Cinema</em>, wherein she addresses burning questions such as "Is <em>Twilight</em> the horniest movie in history?" in the past 40 years of movies. Ticketholders will receive a copy of the book.</p>
          
        
          
            
<h3 id="thursday">OCTOBER 20-22</h3>
<p><strong>GEEK</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/seattle-interactive-conference-2020-virtual-edition/e34222/">Seattle Interactive Conference 2020 Virtual Edition</a></strong><br />Entrepreneurs and online business professionals in areas ranging from storytelling and branding to PR and social media will assemble for a three-day online conference to share their work and build connections. The theme for this year's 10th-anniversary event is "Perspective."</p>
          
        
          
            
<p><strong>HALLOWEEN</strong></p>
          
        
          
            
<p><a href="https://www.thestranger.com/events/45674943/haunted-hayride"><strong>Haunted Hayride</strong></a><br />Ghosts, skeletons, pond monsters, and other creepy-but-harmless characters will punctuate this drive-through hayride along a pumpkin-lined trail.&nbsp; <br /><em>Battle Point Park (Bainbridge Island)</em></p>
          
        
          
            
<h3 id="thursday">OCTOBER 20-23</h3>
<p><strong>COMMUNITY</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/pacific-northwest-history-conference/e36819/">Pacific Northwest History Conference</a></strong><br />Whether you have a PhD in history or you're just a fan of reading about it, this virtual Washington State Historical Society conference, whose theme this year is "Power and Resistance in the Pacific Northwest," has a spot for you. At a glance, some interesting-sounding panels this year include "Native, Immigrant and Industrialist Claims to the Duwamish" and "Women's Suffrage in the Pacific Northwest: Seneca Falls to the 19th Amendment."</p>
          
        
          
            
<h3 id="thursday">OCTOBER 20-25</h3>
<p><strong>READINGS &amp; TALKS</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/tasveer-south-asian-litfest/e36806/">Tasveer South Asian Litfest</a></strong><br />Taking place virtually on Tasveer's social media channels, this six-day festival will return to celebrate writers of the South Asian diaspora through readings, panel discussions, and interactive Q&amp;As. Last year's event saw special guests like Amitava Kumar (<em>Immigrant, Montana</em>) and Sharmila Sen (<em>Not Quite Not White</em>), and you can expect an equally great lineup this time.</p>
          
        
          
            
<h3 id="thursday">OCTOBER 22</h3>
<p><strong>FOOD &amp; DRINK</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/brew-with-the-zoo/e24365/">Brew With the Zoo</a></strong><br />At this virtual event hosted by the Woodland Park Zoo, take in some adorable antics from zoo critters and a visit from one of the zoo's most popular "ambassador animals" while sipping craft beer from Puget Sound breweries in the comfort of your own home.</p>
          
        
          
            
<p><strong>PERFORMANCE</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/the-future-is-0-a-benefit-for-on-the-boards/e36834/">The Future Is 0: A Benefit for On the Boards</a></strong><br />"I&rsquo;m often told of a magical TV show that aired during the even more magical era that was Seattle in the 1980s and &rsquo;90s, a time when&nbsp;everyone&nbsp;lived in a punk house and&nbsp;everyone&nbsp;sucked gay cock. That TV show was&nbsp;<em>Almost Live!</em>, and it was basically like Seattle&rsquo;s&nbsp;<em>SNL</em>, and&nbsp;everyone&nbsp;loved it. While I never watched<em>&nbsp;Almost Live!</em>&nbsp;live, I've spent a good deal of time watching it on (gasp) the internet, and I&rsquo;d like to posit that<em>&nbsp;The Future Is 0</em>&mdash;a live game show&mdash;carries on the tradition of&nbsp;<em>Almost Live!</em>&rsquo;s nerdy, affable, charismatic humor. But, of course, they are not the same thing, and Seattle has sucked since&nbsp;<em>Almost Live!</em>&nbsp;ended and the Kingdome exploded," wrote <em>The Stranger</em>'s Chase Burns last year. The game show will again be at the center of this year's online benefit for On the Boards.&nbsp;</p>
          
        
          
            
<h3 id="saturday">OCTOBER 23-NOVEMBER 1</h3>
<p><strong>FILM</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/nffty-2020/e35197/">NFFTY 2020</a></strong><br />The "young filmmaker's Cannes"&mdash;Charles Mudede called it "world-class"&mdash;the National Film Festival for Talented Youth assembles the best films made by directors under 25. See works by promising cineastes who will make you feel very old. We're already choked up over&nbsp;<em>Bloom</em>, about a victim of assault who learns to cope in her abstract world made of clay. There's also&nbsp;<em>Athol Park</em>, wherein a girl searches for her missing school teacher, and a new Chong the Nomad music video.&nbsp;</p>
          
        
          
            
<h3 id="saturday">OCTOBER 24-25</h3>
<p><strong>FESTIVALS</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/seattle-childrens-festival/e36383/">Seattle Children's Festival</a></strong><br />Restless children and parents in need of a nap (or quality parent-offspring time) should cue up this virtual edition of Seattle Center's festival of kids' activities from home. Highlights this year include a musical performance from&nbsp;Caspar Babypants, drag queen storytime with Aleksa Manila, and a dance performance from the Northwest Tap Connection.</p>
          
        
          
            
<h3 id="saturday">THROUGH OCTOBER 25</h3>
<p><strong>VISUAL ART</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/in-the-spirit-contemporary-native-arts-virtual-exhibition/e35115/">In the Spirit Contemporary Native Arts Virtual Exhibition</a></strong><br />For the 15th year, Native artists showcase their work at the <em>In the Spirit</em> contemporary Native arts exhibition, which will offer prizes in categories including Best of Show, Honoring the Northwest, and People's Choice. You can view this year's virtual event at any time to see work by Jim Stritzel, Chholing Taha, RYAN! Feddersen, Peter Boome, and others. Don't miss the <a href="https://everout.com/tacoma/events/in-the-spirit-closing-celebration/e35543/">Closing Celebration</a> (Sat Oct 17) with local band Khu.&eacute;ex&rsquo;.</p>
          
        
          
            
<h3 id="saturday">OCTOBER 28-JUNE 30</h3>
<p><strong>PERFORMANCE</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/childfinder/e36835/">Childfinder</a></strong><br />Adapted by Shermona Mitchell from the previously unpublished science-fiction story "Childfinder," written by&nbsp;Octavia Butler at the 1970 Clarion Writer's Workshop and released after her death, this audio-drama introduction to Book-It Repertory Theatre's digital season will&nbsp;hark toward a future of racial equality through the story of a Black woman named Barbara who identifies pre-telepath children who have the potential to be fully active telepaths.&nbsp;</p>
          
        
          
            
<h3 id="saturday">OCTOBER 29-JANUARY 31</h3>
<p><strong>VISUAL ART</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/the-experimental-self-edvard-munchs-photography/e36836/">The Experimental Self: Edvard Munch's Photography</a></strong><br />This exhibition of photographs, prints, and films by the master experimental painter and printmaker Edvard Munch is making its first stop in Seattle on its tour through the West Coast.<br /><em>National Nordic Museum (Ballard)</em></p>
          
        
          
            
<h3>THROUGH OCTOBER 31</h3>
<p><strong>HALLOWEEN</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/stranger-seattle/events/maris-farms-haunted-woods/e36498/">Maris Farms Haunted Woods</a></strong><br />From a flashlight corn maze to a trek through the haunted Buckley woods, the farm will provide a month's worth of limited-capacity scary activities. <br /><em>Maris Farms (Buckley)</em></p>
          
        
          
            
<h3 id="saturday">OCTOBER 31</h3>
<p><strong>FILM</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/beautyboiz-go-boo-pt-6/e36569/">BeautyBoiz go BOO, pt. 6</a></strong><br />Taking cues from Dame Agatha Christie's detective novels, this queer horror film from the&nbsp;BeautyBoiz collective, whose pre-COVID shtick usually involved showing up to parties and putting on amazing dance performances, will star&nbsp;Arson Nicki, CarLarans, L&uuml;Chi, Britt Brutality, Angel Baby Kill Kill Kill, Bosco, and many other local drag artists.</p>
          
        
          
            
<h3 id="friday">THROUGH NOVEMBER 14</h3>
<p><strong>HALLOWEEN</strong></p>
          
        
          
            
<p><strong><a href="https://everout.com/events/georgetown-morgue/e36500/">Georgetown Morgue</a></strong><br />This annual haunted village of doom&mdash;which takes place in an actual former morgue&mdash;hosts scares all throughout autumn. This year's rig is fashioned for self-guided tours to ensure social distancing. <br /><em>Georgetown Morgue</em></p>
          
        
          
            
<p>&nbsp;</p>
          
        
          
            </p>
          
        
          
            

<div class="fish-butter article-inline" data-spot="article-inline-ad" data-context-oid="" data-ad-oid="" style="display:none;">
  
    <div class="fish-tag">
      Sponsored
    </div>
  
  <div class="fish-container">
    <div class="fish-image">
      
    </div>
    <div class="fish-body">
      <h1>
        
      </h1>
      <p>
        
      </p>
    </div>
  </div>
</div>

          
        
      </div>
    </article>
  </div>

            </div>
          </div>
          <div class="col-md-4 secondary">
            
  <div id="adSpaceSidebarModule" class="adspace sidebar-module sidebar-module-inset">
  


  

  

  

  
    
      <div id='Stranger-Content-Sidebar-1-50' class="mb-4 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Sidebar-1-50'); });
        </script>
      </div>
    
  

  

  

  
    
      <div id='Stranger-Content-Sidebar-2-51' class="mb-4 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Sidebar-2-51'); });
        </script>
      </div>
    
  

  
    
      <div id='Stranger-Content-Sidebar-3-52' class="mb-4 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Sidebar-3-52'); });
        </script>
      </div>
    
  

  
    
      <div id='Stranger-Content-Sidebar-4-53' class="mb-4 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Sidebar-4-53'); });
        </script>
      </div>
    
  


</div>


          </div>
          
        </div>
      </div>
    </div>
    <footer class="mt-4">
      <div class="site-footer">
  <!-- desktop footer -->
  <div class="d-none d-md-block">
    <!-- footer top block -->
<div class="footer-top-block">
  <div class="container">
    <div class="footer-row row">
      
    </div>
  </div>
</div> <!-- end footer top block -->


    <!-- footer bottom block -->
<div class="footer-middle-block">
  <div class="container">
    <div class="row">
      <div class="col-sm text-center">
        <div class="footer-cover">
          <h4>Latest Print Issue</h4>
          
          <p>
            <a href="https://www.thestranger.com/issues">
              
                <img src="https://media2.fdncms.com/stranger/imager/u/original/43106034/cover_mag.jpg" id="issue-cover" class="issue-cover-thumb" alt="Cover of this issue of The Stranger" style="max-width: 130px">
              
              Print Archives
            </a>
          </p>
          
        </div>
      </div>
      
        <div class="col-sm text-center">
          <h4>Publication Info</h4>
          <ul class="list-unstyled">
            
              <li><a href="https://www.thestranger.com/masthead">Masthead</a></li>
            
              <li><a href="https://www.thestranger.com/ad-info">Ad Info &amp; Rates</a></li>
            
              <li><a href="https://www.thestranger.com/distribution">Distribution</a></li>
            
              <li><a href="https://www.thestranger.com/jobs">Jobs at The Stranger</a></li>
            
              <li><a href="https://everout.com">EverOut</a></li>
            
              <li><a href="https://www.thestranger.com/contact-information">Contact</a></li>
            
              <li><a href="https://everout.com/tacoma/movies/">Tacoma Movie Times</a></li>
            
          </ul>
        </div>
      
      <div class="col-sm text-center">
        <h4>Check It Out</h4>
        
          <div class="footer-promo" style="margin-left:0">
            <a href="https://www.savagelovecast.com">
              <img src="https://media1.fdncms.com/stranger/imager/u/original/39759989/savagelovecast.jpg" alt="Savage Lovecast">
            </a>
          </div>
        
          <div class="footer-promo" style="margin-left:0">
            <a href="http://www.cocktailcompass.com">
              <img src="https://media2.fdncms.com/stranger/imager/u/original/39759990/cocktailcompass-188x80.png" alt="Cocktail Compass">
            </a>
          </div>
        
          <div class="footer-promo" style="margin-left:0">
            <a href="https://www.thestranger.com/promotions">
              <img src="https://media1.fdncms.com/stranger/imager/u/original/39759991/checkitout_button-contests.png" alt="The Stranger Promotions">
            </a>
          </div>
        
      </div>
      <div class="col-sm text-center">
       <h4>Follow Us</h4>
        <ul class="footer-social-links list-unstyled text-left">
          
            <li><a href="https://www.thestranger.com/syndication" target="_blank"><i class="fas fa-rss"></i> RSS</a></li>
          
            <li><a href="http://www.facebook.com/strangerseattle" target="_blank"><i class="fab fa-facebook-f"></i> Facebook</a></li>
          
            <li><a href="https://www.thestranger.com/twitter" target="_blank"><i class="fab fa-twitter"></i> Twitter</a></li>
          
            <li><a href="http://instagram.com/thestrangerseattle" target="_blank"><i class="fab fa-instagram"></i> Instagram</a></li>
          
        </ul>
      </div>
    </div>
  </div>
</div><!-- end footer bottom block -->


    <!-- footer bottom block desktop -->
<div class="footer-bottom-block">
  <div class="container">
    <div class="footer-row row">
      <div class="col-md">
        <div class="footer-brand">
  <a class="navbar-brand" href="https://everout.com/stranger-seattle/"><img src="/assets/images/everout-logo-black.png" alt="EverOut"></a>
</div>

      </div>
      <div class="col-md-8">
        
          <p class="footer-links text-right pipe-delimited-links">
            
              <span><a href="/about/">About</a></span>
            
              <span><a href="/contact-us/">Contact Us</a></span>
            
              <span><a href="/follow-us/">Follow Us</a></span>
            
              <span><a href="/FAQ/">FAQ</a></span>
            
              <span><a href="/privacy-policy/">Privacy Policy</a></span>
            
              <span><a href="/terms-of-use/">Terms of Use</a></span>
            
              <span><a href="/takedown-policy/">Takedown Policy</a></span>
            
          </p>
        
      </div>
    </div>
    <div class="row">
      <div class="col">
        <p>
  All contents © EverOut, Inc.<br>
  Index Newspapers, LLC<br>
  800 Maynard Ave S, Ste 200, Seattle, WA 98134
</p>

      </div>
    </div>
  </div>
</div> <!-- end footer copyright desktop-->

  </div><!-- end desktop footer -->

  <!-- mobile footer -->
  <div class="d-md-none">
    <!-- mobile footer -->
<div class="footer-mobile">
  <div class="container">
    <div class="footer-row row">
      <div class="col-sm text-center">
        <div class="footer-mobile-social-links">
          
            <a href="https://www.thestranger.com/syndication" target="_blank"><i class="fas fa-rss"></i></a>
          
            <a href="http://www.facebook.com/strangerseattle" target="_blank"><i class="fab fa-facebook-f"></i></a>
          
            <a href="https://www.thestranger.com/twitter" target="_blank"><i class="fab fa-twitter"></i></a>
          
            <a href="http://instagram.com/thestrangerseattle" target="_blank"><i class="fab fa-instagram"></i></a>
          
        </div>
        <div class="footer-brand">
  <a class="navbar-brand" href="https://everout.com/stranger-seattle/"><img src="/assets/images/everout-logo-black.png" alt="EverOut"></a>
</div>

        <p>
  All contents © EverOut, Inc.<br>
  Index Newspapers, LLC<br>
  800 Maynard Ave S, Ste 200, Seattle, WA 98134
</p>

        
          <p class="footer-links pipe-delimited-links">
            <small>
              
                <span><a href="/about/">About</a></span>
              
                <span><a href="/contact-us/">Contact Us</a></span>
              
                <span><a href="/follow-us/">Follow Us</a></span>
              
                <span><a href="/FAQ/">FAQ</a></span>
              
                <span><a href="/privacy-policy/">Privacy Policy</a></span>
              
                <span><a href="/terms-of-use/">Terms of Use</a></span>
              
                <span><a href="/takedown-policy/">Takedown Policy</a></span>
              
            </small>
          </p>
        
      </div>
    </div>
  </div>
</div><!-- end mobile footer -->

  </div><!-- end mobile footer -->
</div><!-- end footer -->

      

  <div class="network-bar navbar d-md-none navbar-dark bg-dark">
    <div class="container">
      <ul class="navbar-nav mr-auto">
        <li class="nav-item dropdown">
          <a class="nav-link dropdown-toggle" href="#" id="navbarDropdown" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
            EverOut
          </a>
          <ul class="dropdown-menu" aria-labelledby="navbarDropdown">
            <li class="dropdown-item"><a href="/" class="nav-link">Home</a></li>
            <div class="dropdown-divider"></div>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/stranger-seattle/">
                  Seattle
                </a>
              </li>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/portland-mercury/">
                  Portland
                </a>
              </li>
            
              <li class="dropdown-item">
                <a class="nav-link" href="/tacoma/">
                  Tacoma
                </a>
              </li>
            
          </ul>
        </li>
        <li class="nav-item nav-item-separator">|</li>
        
          <li class="nav-item"><a class="nav-link" href="https://www.thestranger.com">The Stranger</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.portlandmercury.com">Portland Mercury</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://www.savagelovecast.com">Savage Love</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          <li class="nav-item"><a class="nav-link" href="https://humpfilmfest.com">Hump!</a></li>
          
          
        
      </ul>
    </div>
  </div>


      
    </footer>
    <script type="text/javascript" src="https://dyoeldxcrpb0a.cloudfront.net/assets/foot-3d9782e72806200da18b.js" ></script>
    
    
    


  
    
      <div id='Stranger-Content-Background-58' class="mb-4 text-center ad-placement ">
        <script>
          googletag.cmd.push(function() { googletag.display('Stranger-Content-Background-58'); });
        </script>
      </div>
    
  

  

  

  

  

  

  

  

  


  </body>

</html>
